Intake temps no longer dropping with methanol injection HELP! - RX7Club.com - Mazda RX7 Forum

Go Back  RX7Club.com - Mazda RX7 Forum > Generation Specific > 3rd Generation Specific (1993-2002)
Reload this Page >

Intake temps no longer dropping with methanol injection HELP!

3rd Generation Specific (1993-2002) 1993-2002 Discussion including performance modifications and Technical Support Sections.

Intake temps no longer dropping with methanol injection HELP!

Reply

 
 
 
Old 09-15-18, 05:30 PM
  #1  
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2015
Location: Long Island, NY
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Intake temps no longer dropping with methanol injection HELP!

Okay so I have been having some issues with my methanol injection lately in that my intake temps are not dropping when hitting boost. Here’s the background info…



I have a FD chassis with a GT35R single turbo setup with an AEM methanol/water injection kit running on pump gas (93). If it makes any difference it is NOT the newer style kit with the “start” and “full” ***** on the fancy looking controller, but the older style kit with the basic looking rectangle control box with the in-set philips head style adjustment screws (I’m not sure of the model number). My intake temps on a decently warm to hot day will hold steady around 40-45*C when cruising on the freeway in the summer here in New York. Before my issues started, the second I hit boost my intake temps would drop sometimes all the way to around 25*C. I used whatever washer fluid my local Mobile gas station had and it always seemed to do the trick, (I live in the north east so in the summer the washer fluids are not low temp rated meaning low meth percentages) but now my intake temps do not drop in the slightest (it literally does not change) even if I hold it wide open for more than just a few seconds (the light on the AEM control box comes on signifying that the meth is spraying).



Here are the issues I have tested and ruled out…

-My methanol tank is in fact full… lol

-There are no leaks along the path from the Methanol tank to the pump to the injector location.

-The vacuum line from the engine to the AEM control box is not pinched, torn, or collapsed as I have replaced it several times, and even on one test ran it out the open window and through the back of the hood to ensure it was not getting pinched anywhere and my results were still the same, so I am ruling that possibility out.

-The pump is getting power and functioning properly. I have my “Start PSI” at around 5 pounds, and my “Full PSI” way above 17 pounds (which is my high boost setting) so the settings are not out of range. To troubleshoot this, I unhooked my meth line injector which is placed just before the sharp bend in my greddy elbow, placed a bung in the hole to prevent a vacuum leak and held the line through the back of the hood on the windshield and ripped it down the block. Shooting all over the windshield and into the open sunroof was the washer fluid. Needless to say, my buddy and I were covered in windshield washer fluid and A LOT of it. So it is in-fact spraying and spraying well…

- I believe that the meth concentration this time around is well enough for the application I am using. As it’s the summer it is hard to find high meth concentrated washer fluids around the northeast, but after searching all the local Walmart and auto zones, I finally found an AutoZone branded, -20* Windshield Washer fluid which according to the MSDS sheet is 33% Methanol by weight. Though not the highest concentration, I should be seeing at least a few degrees of difference in my intake temps and I am not seeing anything at all.



After going through these things many times over I can’t seem to figure it out. Has anyone out there had similar issues that they could shed some more light on for me to troubleshoot? I have no other ideas or explanations for what is happening. My one last possible issue I am seeing, Unless someone states otherwise as I have not done any actual testing on the intake temp sensor itself, I do not think it is faulty as it seems to read correct ranged temperatures depending on the ambient temperature and it does not seem to be finicky or misreading in anyway so I do not believe the intake temp sensor is bad.

If anybody can put 2 cents in it would be greatly appreciated. Thank you in advance.
rx__evan is online now  
Reply With Quote
Old 09-16-18, 03:49 PM
  #2  
rotorhead
iTrader: (3)
 
arghx's Avatar
 
Join Date: Aug 2004
Location: cold
Posts: 15,591
Thanked 42 Times in 42 Posts
Hand pump air pressure into the sensor and see if it triggers with the car off. Replace your air temp sensor with a fast acting one.
arghx is offline  
Reply With Quote
Old 09-16-18, 05:03 PM
  #3  
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2015
Location: Long Island, NY
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
I did that a few times with my compressor set low and the methanol shot right out. I will look into a fast acting IAT sensor!
rx__evan is online now  
Reply With Quote
Old 09-18-18, 06:56 PM
  #4  
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2015
Location: Long Island, NY
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Reposted in Auxiliary injection subforum.
rx__evan is online now  
Reply With Quote
Old 09-27-18, 06:47 PM
  #5  
Full Member
 
Join Date: Dec 2015
Location: Thessaloniki
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
As far as i know metanol is not the one that drops ait temps. Water does that. Methanol adds octane ratings in the fuel as its a fuel on its own with high octane rating . So maybe you need fluid with less meth and more water % ?
AlienHack is offline  
Reply With Quote
Old 09-27-18, 07:33 PM
  #6  
38 years of 7's
iTrader: (1)
 
mikejokich's Avatar
 
Join Date: Jan 2012
Location: Alabama
Posts: 187
Thanked 18 Times in 18 Posts
It is the opposite. Methanol has the greater evaporation coefficient as compared to water. Methanol will drop the temperature more.
Mike
mikejokich is offline  
Reply With Quote
Old 09-28-18, 06:31 PM
  #7  
FD Daily
iTrader: (25)
 
K-Tune's Avatar
 
Join Date: Jul 2003
Location: Gulf Breeze, FL
Posts: 3,282
Thanks: 0
Thanked 3 Times in 3 Posts
Have you verified the check valve for the water injection is working properly?
K-Tune is offline  
Reply With Quote
Old 09-29-18, 08:09 PM
  #8  
Full Member
 
Join Date: Dec 2015
Location: Thessaloniki
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Methanole is also a fuel thats why it changes the afr

Last edited by AlienHack; 09-29-18 at 08:21 PM.
AlienHack is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
swkiller
Auxiliary Injection
7
01-12-09 01:41 AM
slo
Haltech Forum
8
05-24-08 01:25 AM
boriqua51371
1st Generation Specific (1979-1985)
9
01-10-06 07:22 PM
Gamezilla
2nd Generation Specific (1986-1992)
7
08-06-02 05:56 AM
7-sins
General Rotary Tech Support
2
09-03-01 10:26 PM


Thread Tools
Search this Thread
Quick Reply: Intake temps no longer dropping with methanol injection HELP!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.