Time Slips and Dyno Section is for posting 1/4 mile time slips and dyno graphs

Got my car on the Dyno

Old 09-09-05, 12:11 PM
  #1  
Not the company
Thread Starter
 
RE-Amemiya's Avatar
 
Join Date: Jul 2004
Location: UT
Posts: 5,021
Received 4 Likes on 4 Posts
Got my car on the Dyno

Here's a pic.
RE-Amemiya is offline  
Old 09-12-05, 09:32 PM
  #2  
New to FD's
5 Year Member
 
Join Date: Aug 2005
Location: Annapolis, MD
Posts: 59
Likes: 0
Received 0 Likes on 0 Posts
wtf is that spike?!
Timdog1650 is offline  
Old 09-12-05, 09:57 PM
  #3  
EFR IWG 8374
10 Year Member
 
JTurtonRX_7's Avatar
 
Join Date: Aug 2003
Location: C. Springs
Posts: 638
Likes: 0
Received 0 Likes on 0 Posts
boost spike after transition
JTurtonRX_7 is offline  
Old 09-12-05, 11:01 PM
  #4  
New to FD's
5 Year Member
 
Join Date: Aug 2005
Location: Annapolis, MD
Posts: 59
Likes: 0
Received 0 Likes on 0 Posts
That's nuts...Good power levels though dude!
Timdog1650 is offline  
Old 09-12-05, 11:50 PM
  #5  
Original Gangster/Rotary!

iTrader: (206)
 
GoodfellaFD3S's Avatar
 
Join Date: Mar 2001
Location: FL-->NJ/NYC again!
Posts: 29,999
Received 138 Likes on 111 Posts
what did your boost pattern look like?
GoodfellaFD3S is offline  
Old 09-13-05, 05:43 PM
  #6  
Not the company
Thread Starter
 
RE-Amemiya's Avatar
 
Join Date: Jul 2004
Location: UT
Posts: 5,021
Received 4 Likes on 4 Posts
Originally Posted by GoodfellaFD3S
what did your boost pattern look like?

Huh??? Not really sure what you mean. I didn't have the car tuned, and i don't have a boost gauge or anything. (yet)

As for the spike...i can't explain that either.
RE-Amemiya is offline  
Old 09-13-05, 10:29 PM
  #7  
Rotary Enthusiast
10 Year Member
 
treceb's Avatar
 
Join Date: Jul 2001
Location: Santurce
Posts: 1,320
Likes: 0
Received 0 Likes on 0 Posts
turbos are setup in sequential. 1 spools before the other at factory set rpms/load. the drop followed by the spike is the transition from 1 turbo to 2. boost pattern factory is 10 psi, 8 psi at transition the back up to 10 psi with in seconds.
treceb is offline  
Old 09-14-05, 04:32 PM
  #8  
Not the company
Thread Starter
 
RE-Amemiya's Avatar
 
Join Date: Jul 2004
Location: UT
Posts: 5,021
Received 4 Likes on 4 Posts
Ahhh...that would explain what i feel when i drive the car hard then. Thanks guys!!
RE-Amemiya is offline  
Old 09-14-05, 06:53 PM
  #9  
Rotary Freak
 
2FAST7S's Avatar
 
Join Date: Oct 2001
Location: Carmel, NY
Posts: 1,884
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by rx7twinturboboy
Ahhh...that would explain what i feel when i drive the car hard then. Thanks guys!!
It looks like the switchover is a bit laggy...Years ago i got a real good working selenoid and the switchover was way smoother. It still showed just not that pronnounced.
Almost 20hp over the average bone stock #s! I didnt read your mods list but i'm more than sure youre still running that pre-cat? Ditch it and get a dowpipe, it will net your a few horses and improve the switchover a little! Anything over that and youre asking for trouble! Be careful when it gets cold! you'll need a rechiped or piggy back...if you got the sickness a stand alone will go a long way!!!!
how many miles on the motor/trubos???
2FAST7S is offline  
Old 09-14-05, 08:21 PM
  #10  
Not the company
Thread Starter
 
RE-Amemiya's Avatar
 
Join Date: Jul 2004
Location: UT
Posts: 5,021
Received 4 Likes on 4 Posts
Originally Posted by 2FAST7S
It looks like the switchover is a bit laggy...Years ago i got a real good working selenoid and the switchover was way smoother. It still showed just not that pronnounced.
Almost 20hp over the average bone stock #s! I didnt read your mods list but i'm more than sure youre still running that pre-cat? Ditch it and get a dowpipe, it will net your a few horses and improve the switchover a little! Anything over that and youre asking for trouble! Be careful when it gets cold! you'll need a rechiped or piggy back...if you got the sickness a stand alone will go a long way!!!!
how many miles on the motor/trubos???
Yeah, it's got a 3" downpipe all the way, with the cat still in place for the emissions test.

New motor--5,000miles ago from the previous owner. Not sure about the turbos.

I'm not that worried about it anway, i've got stuff on order to make it run better, including an eventual single turbo, and FMIC. (etc.....)
RE-Amemiya is offline  
Old 09-15-05, 08:47 PM
  #11  
Rotary Freak
 
2FAST7S's Avatar
 
Join Date: Oct 2001
Location: Carmel, NY
Posts: 1,884
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by rx7twinturboboy
Yeah, it's got a 3" downpipe all the way, with the cat still in place for the emissions test.

New motor--5,000miles ago from the previous owner. Not sure about the turbos.

I'm not that worried about it anway, i've got stuff on order to make it run better, including an eventual single turbo, and FMIC. (etc.....)
good! just keep up with maintenance and you'll be fine! you'll get a kick once you mod it a little more...and a single, forget it!!! lol
2FAST7S is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dkwasherexd
Single Turbo RX-7's
21
05-27-17 04:51 AM
stickmantijuana
Microtech
5
08-23-15 11:04 AM
morataya
Microtech
4
08-17-15 01:04 PM
Turblown
Single Turbo RX-7's
0
08-14-15 04:48 PM
Clacor
Single Turbo RX-7's
0
08-14-15 09:17 AM


Thread Tools
Search this Thread
Quick Reply: Got my car on the Dyno


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.