Microtech Area is for discussing Microtech systems

Microtech Timing check !!

Old 09-30-06, 12:11 AM
  #1  
Full Member
5 Year Member
Thread Starter
 
BeNO's Avatar
 
Join Date: Apr 2006
Location: Tampa, FL
Posts: 171
Likes: 0
Received 0 Likes on 0 Posts
Timing check !!

Could some one tell me if this timing is good, bad, allright.. and if anybody know what the timing should be.

What's the most advance and retarted i can reach ??

would retarting too much detonate or effect the engine as much as Advancing ?

thanks guys
Attached Thumbnails Timing check !!-timing-1.jpg   Timing check !!-timing-2.jpg  
BeNO is offline  
Old 09-30-06, 07:42 AM
  #2  
www.lms-efi.com
iTrader: (27)
 
C. Ludwig's Avatar
 
Join Date: Mar 2001
Location: Floyds Knobs. IN
Posts: 5,112
Received 30 Likes on 23 Posts
http://forum.teamfc3s.org/showthread.php?t=41915


Here's a good discussion that includes some safe numbers. How did you save the screenshots? That would come in very handy.
C. Ludwig is offline  
Old 09-30-06, 01:25 PM
  #3  
Full Member
5 Year Member
Thread Starter
 
BeNO's Avatar
 
Join Date: Apr 2006
Location: Tampa, FL
Posts: 171
Likes: 0
Received 0 Likes on 0 Posts
there is a buttom on the keybord usualy on the right is called ( prt Scrn )
and then open (paint) in program menu and past it there. thats it.
BeNO is offline  
Old 10-01-06, 12:17 AM
  #4  
20BFD
10 Year Member
 
black93RX7's Avatar
 
Join Date: Sep 2002
Location: Winnipeg
Posts: 506
Likes: 0
Received 0 Likes on 0 Posts
your t_rpm map looks similar to , believe it goes up to 30 degree.

Low rpm it starts off at 5degrees at idle, this was from the base map.


This is giving me 1200-1500 f egt's at cruise and when I stopped my manifole and snail were glowing red. Wasnt boosting or going above 3k, since its a new engine.
black93RX7 is offline  
Old 10-02-06, 10:11 PM
  #5  
Full Member
5 Year Member
Thread Starter
 
BeNO's Avatar
 
Join Date: Apr 2006
Location: Tampa, FL
Posts: 171
Likes: 0
Received 0 Likes on 0 Posts
i don't have egt gauge but i recently change my timing (advance it more)
The car feels smother on lower RPM but i think sometimes i hear clicking sound !! i am not sure if it is detonation or not !! I hope not.
BeNO is offline  
Old 10-04-06, 02:27 PM
  #6  
That's what she said...
10 Year Member
iTrader: (2)
 
myfc3s's Avatar
 
Join Date: Jul 2005
Location: Socal
Posts: 572
Likes: 0
Received 0 Likes on 0 Posts
?

Originally Posted by BeNO
i don't have egt gauge but i recently change my timing (advance it more)
The car feels smother on lower RPM but i think sometimes i hear clicking sound !! i am not sure if it is detonation or not !! I hope not.

That could be a slow transition from primary injection, and than secondary. Let me guess.. do you hear it @ 3-4k? If so you might want to adjust the maps..
myfc3s is offline  
Old 11-02-06, 10:25 AM
  #7  
Full Member
5 Year Member
 
lousrx2's Avatar
 
Join Date: Sep 2006
Location: New Jersey
Posts: 126
Likes: 0
Received 0 Likes on 0 Posts
Unhappy Water Temp

I have a 71 rx2 and I run a microtech lt8s. My water temp wire from the microtech is hook up to the stock water sending unit. I belive its the purple wire from the lt8s. I also have a mechanical water temp gauge that runs to the water pump. My water temp on the computer reads 106C while my mechanical gauge reads 180F does anyone know why. I would love some help and I must say I've been braking apex seals left and right.

signed need some help
Thanxs.
lousrx2 is offline  
Old 11-02-06, 01:53 PM
  #8  
Sharp Claws
iTrader: (30)
 
RotaryEvolution's Avatar
 
Join Date: Oct 2003
Location: Central Florida
Posts: 5,135
Likes: 0
Received 16 Likes on 15 Posts
at 180F you should be able to grab the upper radiator hose with it being fairly warm but not scalding, at 106C you would not be able to hold the hose for long if at all.
RotaryEvolution is offline  
Old 11-07-06, 10:14 AM
  #9  
Full Member
5 Year Member
 
lousrx2's Avatar
 
Join Date: Sep 2006
Location: New Jersey
Posts: 126
Likes: 0
Received 0 Likes on 0 Posts
Thanks for the reply I like to know if 106c is bad or ok for my engine.
lousrx2 is offline  
Old 11-14-06, 02:29 AM
  #10  
That's what she said...
10 Year Member
iTrader: (2)
 
myfc3s's Avatar
 
Join Date: Jul 2005
Location: Socal
Posts: 572
Likes: 0
Received 0 Likes on 0 Posts
too high

Originally Posted by lousrx2
Thanks for the reply I like to know if 106c is bad or ok for my engine.

Thats too high, I wouldnt go any higher than 96c. But i have seen my temps
go as high as 100c, than i turn her off..
myfc3s is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Queppa
New Member RX-7 Technical
8
09-02-18 09:53 AM
trickster
2nd Generation Specific (1986-1992)
20
03-29-18 02:05 PM
Rotospectre
New Member RX-7 Technical
3
03-28-18 03:33 PM
PhillyFC
General Rotary Tech Support
9
08-21-15 06:36 PM


Thread Tools
Search this Thread
Quick Reply: Microtech Timing check !!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: