Microtech Area is for discussing Microtech systems

Microtech Msd Coils Not Shooting?? Please Help

Old 10-31-08, 09:00 AM
  #1  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
Msd Coils Not Shooting?? Please Help

Hi i have a microtech lt10s with x4 box..... i have the coils wired the correct way because about a week ago when the car was still not completed we started the engine. but for reasons unkown to me the coils are getting power to the positive side of the coils and the negative side. i know its not the wiring because i have power only running to the positives on the coils. and the negatives are connected to the X4 box..

please someone help me i really cant figure this out!

thank you,

Vic
illtakeyochik is offline  
Old 10-31-08, 12:04 PM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
its normal that power travels accross the pole.

what your actually looking for is that the negative flashes when your cranking.
if it dosnt flash your x4 box is dead.
rx72c is offline  
Old 11-02-08, 02:57 PM
  #3  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
ok.. the Microtech itself shows the orange light flashing (the ignition pulse light).. so i would have to send it in to microtech then... and how can that happen if i havent done anything to it.. it jus sat in the car i haven driven the car or nothing
illtakeyochik is offline  
Old 11-02-08, 08:43 PM
  #4  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
orange light is a pulse from crank angle sensor.
if that is flashing then that is good.

So your saying that when you put a test light at the coil packs it isnt flashing?
rx72c is offline  
Old 11-03-08, 10:19 AM
  #5  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
no sir the test light wont flash to negative?? i just has steady power to both sides... do you think theres something wrong with the microtech??
illtakeyochik is offline  
Old 11-03-08, 04:13 PM
  #6  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
Have you grounded the earth wire that goes to the x4 box, to the block.

Why did you use MSD coils and not the bosch coils?
Microtech dont recommend any of the MSD gear. Recommend bosch.

If your earth wire from the x4 box is grounded and still no spark.

The x4 box/microtech need to be sent back.
rx72c is offline  
Old 11-04-08, 08:40 AM
  #7  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
i have the x4 grounded but not to the block? its on the firwall...

how can i go about sending the x4 box/microtech back???

the MSD's were recommended from a shop where im from, but when i first finished the setup the MSD's worked very well.
illtakeyochik is offline  
Old 11-04-08, 03:02 PM
  #8  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
Next time dont use them. I have never had anything but trouble from MSD.

AND your ground should be on your BLOCK.

This is what has killed your X4.

Youll have to send the microtech back to a dealer here in sydney. And they will have it dropped off at Microtech Putney to be repaired.

or you can send it to John at www.microtechefi.com
rx72c is offline  
Old 11-04-08, 03:39 PM
  #9  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
you should move to the U.S.A we need more techs like you over here
illtakeyochik is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Medevack1
Naturally Aspirated Performance Forum
13
11-10-17 04:53 PM
dillrx7
Single Turbo RX-7's
3
09-07-15 09:38 AM


Thread Tools
Search this Thread
Quick Reply: Microtech Msd Coils Not Shooting?? Please Help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: