Microtech Area is for discussing Microtech systems

Microtech LT10 Help - No Start

Old 09-07-10, 06:29 PM
  #1  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Dec 2004
Location: Chicago
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
LT10 Help - No Start

I have a friend with a Miata that has an RX7 FC motor in it.

The car has kind of a crazy set-up. I have done a little with microtechs before but nothing like this car.

The list is:

Turbo2 Motor S4 (4 port) with FD rotors 3mm seals
Racing Beat 48mm ITB setup
Street Port
650cc prim /1060 cc sec with ks parts fuel rails
255 fuel pump
3.5bar MAP
turbo2 crank sensor

its on a Microtech LT-10.

The problem is when we try to start it the car floods and doesnt want to start no matter how I have adjusted the settings to this point.
mxturboracer86 is offline  
Old 09-07-10, 06:53 PM
  #2  
Senior Member
5 Year Member
iTrader: (11)
 
drifting in drifting's Avatar
 
Join Date: Feb 2008
Location: drifting .pa
Posts: 368
Likes: 0
Received 0 Likes on 0 Posts
Try this Worked great for me
Idle Map
Screen 1

30" ~ 1.38
25" ~ 1.48
20" ~ 1.33
15" ~ 1.71
10" ~ 2
05" ~ 2.1
00" ~ 2.56
2-20psi ~ 4.95

Load Map
Screen 3

30" ~ 0.95
25" ~ 1.19
20" ~ 1.33
15" ~ 1.71
10" ~ 2.14
05" ~ 2.57
00" ~ 3.56
2psi ~ 2.9
4psi ~ 3.9
6psi ~ 4.7
8psi ~ 5.1
10psi ~ 5.6
14psi ~ 6.2
16psi ~ 6.8
18psi ~ 7.4
20psi ~ 8

RPMwot Map Screen 17

5000 ~ 05
5500 ~ 08
6000 ~ 08
6500 ~ 10
7000 ~ 11
7500 ~ 11
8000 ~ 11
9000 ~ 12

The rest are zero

RPMcrs Screen 18

1000 ~ -12
1500 ~ -11
2000 ~ -12

THe rest are zero



Pump Map
Screen 19

Pump2Start ~ 2000
Pump1Amt ~ 00
Pump1Pulse ~ 04
Pump1Trig ~ 18
Pump1Stop ~ 00
Pump1Adv ~ 05

Pump2Time ~ 10
Pump2Amt ~ 30
Pump2Trig ~ 16
Pump2Stop ~ 00
Pump2Adv ~ 05

PumpDwell ~ 3.00
PumpTimers ~ No
Pump1Sync ~ No
PumpSpare ~ 00
PumpCold ~ 00

Water Map
Screen 20

-25 ~ 0
-17 ~ 70
-9 ~ 60
-01 ~ 50
05 ~ 45
11 ~ 45
18 ~ 42
24 ~ 34
31 ~ 26
38 ~ 24
46 ~ 19
60 ~ 12
68 ~ 06
82 ~ 0
99 ~ 0
124 ~ 0

Air_t Map
Screen 21

-25 ~ 0
-17 ~ 8
-9 ~ 6
-1 ~ 5
5 ~ 4
11 ~ 3
18 ~ 3
24 ~ 0
31 ~ 0
38 ~ 0
46 ~ 0
60 ~ 0
68 ~ 0
82 ~ 0
99 ~ 0
124 ~ 0

Crank Map
Screen 22

-25 ~ 72
-17 ~ 72
-9 ~ 72
-1 ~ 67
5 ~ 62
11 ~ 57
18 ~ 50
24 ~ 41
31 ~ 31
38 ~ 26
46 ~ 20
60 ~ 15
68 ~ 5
82 ~ 0
99 ~ 0
124 ~ 0

t*rpm
Screen 23

Idle ~ 10
1000 ~ 10
1500 ~ 15
2000 ~ 20
2500 ~ 25
3000 ~ 25
3500 ~ 25
4000 ~ 25
4500 ~ 25
5000 ~ 25
5500 ~ 25
6000 ~ 25
6500 ~ 25
7000 ~ 25
7500 ~ ??
8000 ~ 25
9000 ~ 25

t*map Map
Screen 24

Idle ~ 00
25 ~ 05
20 ~ 04
15 ~ 03
10 ~ 02
05 ~ 00
00 ~ 00
2psi ~ 00
4psi ~ 00
6psi ~ 02
8psi ~ -04
10psi ~ -06
14psi ~ -10
16psi ~ -12
18 psi ~ -16
20 psi ~ -20

t*air Screen 25
Correction value Is expressed as number of degrees you wish to advance or Retard to the Ignition curve and values Is set at zero.

t*gap
Screen 26

0500 ~ 15
1000 ~ 15
1500 ~ 15
2000 ~ 14
2500 ~ 12
3000 ~ 10
3500 ~ 10
4000 ~ 10
4500 ~ 10
5000 ~ 10
5500 ~ 10
6000 ~ 10
6500 ~ 10
7000 ~ 10
8000 ~ 10

t*Inj Map
Screen 27

0500 ~ 120
1000 ~ 150
1500 ~ 150
2000 ~ 150
2500 ~ 150
3000 ~ 150
3500 ~ 150
4000 ~ 150
4500 ~ 180
5000 ~ 210
5500 ~ 210
6000 ~ 240
6500 ~ 240
7000 ~ 270
8000 ~ 270
9000 ~ 270

t*wat Map Screen 28


ANd the rest are zero

Option Map
Screen 30

Af_StE ~ 10
Dwell ~ 3.25 *set at Time Base - not at Duty Cycle*
REVstg ~ 2000
MAPstg ~ 02"
%stg ~ 50

Get new plugs too
drifting in drifting is offline  
Old 09-08-10, 07:51 AM
  #3  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Dec 2004
Location: Chicago
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
i had tried that including variations as i think i've seen that map posted on here before or something very close to it.

Its quite a mystery, starting to think that something is mechanically wrong, but we have checked the basics.
mxturboracer86 is offline  
Old 09-08-10, 08:45 AM
  #4  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
The thing probably draws no vacuum with that setup, so swap the ECU to Alpha-N. And that's where my advice ends, becuase I have never tuned Alpha-N on a Microtech before.

That is a tonne of injector for an engine that's going to make around 230HP.
Aaron Cake is offline  
Old 09-08-10, 09:25 AM
  #5  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Dec 2004
Location: Chicago
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Aaron Cake View Post
The thing probably draws no vacuum with that setup, so swap the ECU to Alpha-N. And that's where my advice ends, becuase I have never tuned Alpha-N on a Microtech before.

That is a tonne of injector for an engine that's going to make around 230HP.
Cant go alpha-n its a turbo set-up I did not add the fact it has a 60 trim turbo, that should make sense of the injector size
mxturboracer86 is offline  
Old 09-09-10, 02:08 AM
  #6  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
put some oil in both rotors and put some new plugsin it.
rx72c is offline  
Old 09-09-10, 09:23 AM
  #7  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Dec 2004
Location: Chicago
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by rx72c View Post
put some oil in both rotors and put some new plugsin it.
the oil was something we had tried and the new plugs were put in just before trying that, about 2 days before the be exact and the car had sat for those 2 days. I will pull them out after all of the things we have tried to make sure they have not been fouled out before changing maps to attempt to start the car again, so at that point they can be replaced if needed.
mxturboracer86 is offline  
Old 09-10-10, 09:12 AM
  #8  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
Well, when all else fails, a push start with another vehicle always works.
Aaron Cake is offline  
Old 09-10-10, 10:37 AM
  #9  
Hardcore Rx7 *****
5 Year Member
iTrader: (3)
 
TuRbOnOs7's Avatar
 
Join Date: Oct 2007
Location: San Diego, CA
Posts: 80
Likes: 0
Received 0 Likes on 0 Posts
u need to be a lil more specific man? What do you mena it floods? Is the fuel pump relaey wired correctly? Are the injectors new/used? Is the CAS in correctly? Are the coils wired per the diagram? Where is the power for the microtech coming from? I knew of a guy that had a similar problem and it turned out that he had his +12v ignition signal to the microtech hooked up to basically the same wire as his radio, this is too weak as you may know most radios turn off when one cranks the engine so we moved it to the same wire that powers the coils when you turn the key and the car started right up. The microtech was kinda half-blind so it wasn't working right and the signal would come and go...he would get flooded too, but after we moved the wire to the coil source never had an issue after that...
TuRbOnOs7 is offline  
Old 09-11-10, 01:26 PM
  #10  
Sharp Claws
iTrader: (30)
 
RotaryEvolution's Avatar
 
Join Date: Oct 2003
Location: Central Florida
Posts: 5,135
Likes: 0
Received 16 Likes on 15 Posts
fuel
compression
spark

start with the basics, sounds like something is missing, do a compression test on the engine to find out it's integrity before moving forward. i have a feeling the cranking compression is low due to one reason or another, be sure cranking speed is at least 250RPMs.
RotaryEvolution is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rx7jocke
Suspension/Wheels/Tires/Brakes
72
06-17-16 03:48 AM
ZacMan
Build Threads
4
09-19-15 09:20 PM
sherff
Adaptronic Engine Mgmt - AUS
5
09-12-15 12:22 PM
whinin
New Member RX-7 Technical
10
09-05-15 11:52 PM


Thread Tools
Search this Thread
Quick Reply: Microtech LT10 Help - No Start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: