Microtech Area is for discussing Microtech systems

Microtech desperate need advice

Old 07-21-07, 10:26 AM
  #1  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
desperate need advice

im gettin fustrated with the car what afrs do you guys tune to, if anyone knows, i cant get a smooth rev past 4000 it sounds like maybe too much gas but when i try to lean it out at around 12afr its it runs lean. samething when drivin. if i cruise and idle at 11.5 afrs to 4000 it wont pass that rpm while boosting 6-8 pounds.
a_reyes1014 is offline  
Old 07-21-07, 07:40 PM
  #2  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
ok i got the car to drive normal now but now i have a hesitation at around 4000 to 4500 rpm when starting to boost and i wont pass that only when im at cruisin throttle if anyone can help thanks
a_reyes1014 is offline  
Old 07-22-07, 09:35 AM
  #3  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
Originally Posted by a_reyes1014 View Post
im gettin fustrated with the car what afrs do you guys tune to, if anyone knows, i cant get a smooth rev past 4000 it sounds like maybe too much gas but when i try to lean it out at around 12afr its it runs lean. samething when drivin. if i cruise and idle at 11.5 afrs to 4000 it wont pass that rpm while boosting 6-8 pounds.
I like lean ratios in vacuum and at low throttles. High 13s to mid 14s at light throttles, then as lean as the car will handle when cruising (15:1 and leaner if you don't mind melting turbos).

11.5:1 is way too lean at idle.

12:1 is way too rich under light load.

Under boost at 6-8 PSI, 12:1 is a safe point.

What are your staging settings? Injector sizes? A little bit of info on you setup?
Aaron Cake is offline  
Old 07-22-07, 10:23 AM
  #4  
Rotary Enthusiast
10 Year Member
 
Join Date: Feb 2004
Location: Freeport, Maine
Posts: 1,225
Likes: 0
Received 0 Likes on 0 Posts
11.5 is too lean for idle? that doesn't sound right to me. I'm in the 13's at idle
Dom_C is offline  
Old 07-22-07, 11:30 AM
  #5  
pwned
5 Year Member
 
dean23's Avatar
 
Join Date: Sep 2005
Location: Northern Indiana
Posts: 1,296
Likes: 0
Received 0 Likes on 0 Posts
i think he meant rich....
dean23 is offline  
Old 07-22-07, 12:19 PM
  #6  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
i have 4x800cc injector with a walbro fuel pump its set at stock setting for the staging
a_reyes1014 is offline  
Old 07-22-07, 03:13 PM
  #7  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
youll find some cars will idle nice and firm anywere between 13:1 all the way down to 11:1. depends on porting etc. see where your car is comfortable.

as for cruise afrs Aaron is correct, 13-14.5:1 is good place to be.

12.5:1 at 00HG(00psi) and drop to 11.7:1 by around 10 psi.
rx72c is offline  
Old 07-22-07, 03:37 PM
  #8  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
i checked my plugs just to make sure my wideband was ok it is running lean right when boost kicks in so the wideband is right i just cant tell if my secondaries on coming on and or my fuel pump went bad. everything on the car is pretty much brand new as far as injectors and fuel pump
a_reyes1014 is offline  
Old 07-23-07, 10:16 AM
  #9  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
I meant rich. Sometimes easy to get confused when bouncing back and forth between posts. Sorry about that.

What happens when you add more fuel to the 0 HG and 2 PSI bins? Does that effect the reading?

Are you staging at -2 and 3000 RPM as is default (I think)?

Do you have any way to monitor fuel pressure?
Aaron Cake is offline  
Old 07-23-07, 07:07 PM
  #10  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
yea you know what guys good news i fixed the problem i had a low pressure filter before the pump and was really restricting it while i revved it. the car is a monster really pulls hard at 10psi the car went sideways while boosting i love it but i think the plugs are fouled out it started hesitating when the secondaries kicked in a few hard pulls. i appreciate all the feed back. a little more tuning and i will feel more confident with the car.
a_reyes1014 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Andrew7dg
1st Generation Specific (1979-1985)
3
08-06-17 01:41 PM
Aramir
New Member RX-7 Technical
24
10-18-15 02:39 AM
Zinraf
2nd Generation Specific (1986-1992)
3
10-01-15 01:09 PM
izzolaw
1st Gen General Discussion
2
09-27-15 08:33 PM
risingsunroof82
1st Generation Specific (1979-1985)
8
09-07-15 01:11 PM


Thread Tools
Search this Thread
Quick Reply: Microtech desperate need advice


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: