No Fuel gauge No fuel Pump - RX7Club.com - Mazda RX7 Forum

2nd Generation Specific (1986-1992) 1986-1992 Discussion including performance modifications and technical support sections.
Sponsored by:

No Fuel gauge No fuel Pump

Old 01-13-19, 09:44 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2018
Location: Coral Springs, Fl
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
FL No Fuel gauge No fuel Pump

Hi all, I recently got intalled a turbo kit, along with all the fuel requirements ( aeromotive fuel pump, Id injects, new fp regulator etc) also a new fuel sender. A few days ago the car died on the road. Now I dont hear the fuel pump when I put the car in start, no fuel pressure and also no fuel Gauge.

I replaced the relay under the steering column, also the one on the engine bay with the resistor, can also hear the main relay clicking. All fuces replaced. New battery. What else could it be???

Note that the car has a microtech lt10 and this new setup has less than 100 miles.

Thanks!
Rx7Taino is offline  
Old 01-16-19, 11:16 AM
  #2  
Junior Member
 
Join Date: Jul 2018
Location: South Carolina
Posts: 37
Thanks: 0
Thanked 1 Time in 1 Post
Have you tried jumping the fuel pump connector in the engine bay?
CryoSignal is offline  
Old 01-19-19, 07:09 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Feb 2018
Location: Coral Springs, Fl
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Not yet how do I do that?
Rx7Taino is offline  
Old 01-19-19, 07:18 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Feb 2018
Location: Coral Springs, Fl
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Also I have no Tach, would a bad coil cause all this?
Rx7Taino is offline  
Old 01-22-19, 10:05 PM
  #5  
Rotary Enthusiast
iTrader: (23)
 
Join Date: Nov 2007
Location: san diego
Posts: 819
Thanks: 0
Thanked 0 Times in 0 Posts
Does the ecu even have power? No tach, no fuel pump, is the ecu even turning on and activating both? With ignition on, do you have power to sensors on the engine?
DR_Knight is offline  
Old 01-22-19, 10:18 PM
  #6  
Junior Member
Thread Starter
 
Join Date: Feb 2018
Location: Coral Springs, Fl
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Yes the microtech turns on and all others read ok on the microtech.
Rx7Taino is offline  
Old 01-23-19, 11:34 AM
  #7  
Junior Member
 
Join Date: Jul 2018
Location: South Carolina
Posts: 37
Thanks: 0
Thanked 1 Time in 1 Post
I don't know much about mircotech but like most ECUs it should have a fuel pump pin on the harness. I'd start by checking if that's getting power.
CryoSignal is offline  
Old 01-23-19, 07:16 PM
  #8  
Junior Member
Thread Starter
 
Join Date: Feb 2018
Location: Coral Springs, Fl
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
I will check that, this microtech has give me trouble before, It will be replaced by a haltech this year.
Rx7Taino is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
muibubbles
3rd Generation Specific (1993-2002)
31
02-04-10 06:08 PM
--MAstermind--
2nd Generation Specific (1986-1992)
0
06-01-06 11:43 AM
pomanferrari
3rd Generation Specific (1993-2002)
1
11-30-03 10:57 PM


Thread Tools
Search this Thread
Quick Reply: No Fuel gauge No fuel Pump


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: