Time Slips and Dyno Section is for posting 1/4 mile time slips and dyno graphs

[email protected]

Old 03-15-05, 07:50 PM
  #1  
Ee / Cpe
5 Year Member
Thread Starter
 
XSTransAm's Avatar
 
Join Date: Jan 2003
Location: Gaithersburg, MD / WVU
Posts: 2,843
Likes: 0
Received 0 Likes on 0 Posts

http://img.photobucket.com/albums/v1...al/rx7dyno.jpg

I was going for alot more power but it appears i used too light of a spring in my wastegate because i cant get over 12ish psi. This would also explain why my boost is coming on so late. But its only a spring and will be easily remedied very shortly


Im using a t61 and haltech e6k.

The motor is one of rx7stores stage2 engines with their street port and the thing runs GREAT.

Thanks everyone who has helped me, ive come along way since I bought the car when it was completely stock 2 years ago.

car page: www.cardomain.com/id/azezial
XSTransAm is offline  
Old 03-15-05, 07:53 PM
  #2  
Ee / Cpe
5 Year Member
Thread Starter
 
XSTransAm's Avatar
 
Join Date: Jan 2003
Location: Gaithersburg, MD / WVU
Posts: 2,843
Likes: 0
Received 0 Likes on 0 Posts
i really need to learn how to post friggen thumbnails
XSTransAm is offline  
Old 03-15-05, 08:00 PM
  #3  
Full Member
10 Year Member
 
trunks's Avatar
 
Join Date: Mar 2002
Location: earth
Posts: 192
Likes: 0
Received 0 Likes on 0 Posts
good numbers and set up, let us know
trunks is offline  
Old 03-15-05, 08:32 PM
  #4  
omgwtfposlol
10 Year Member
 
particleeffect's Avatar
 
Join Date: Dec 2002
Location: Orange City, FL
Posts: 862
Likes: 0
Received 0 Likes on 0 Posts
i bet it pulls like crazy making 1150lbs of tq.
particleeffect is offline  
Old 03-15-05, 10:37 PM
  #5  
meek and uninteresting
5 Year Member
 
Join Date: Mar 2005
Location: 3rd rock from the sun
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
yea, geez... you must be pullin' wheelies from a roll. Nice #s.

Last edited by FDgte; 03-15-05 at 10:41 PM.
FDgte is offline  
Old 03-19-05, 12:17 PM
  #6  
I brake boost
10 Year Member
 
FD Rey's Avatar
 
Join Date: Aug 2003
Location: Orlando
Posts: 2,128
Likes: 0
Received 0 Likes on 0 Posts
Nice numbers. I wonder what it puts down with a lil more boost.
FD Rey is offline  
Old 03-19-05, 03:22 PM
  #7  
rotors + turbos = bliss
5 Year Member
 
Madmax670's Avatar
 
Join Date: Oct 2004
Location: Chicago (Mt. Prospect)
Posts: 737
Likes: 0
Received 0 Likes on 0 Posts
what are all of your mods if you dont mind me asking.
Madmax670 is offline  
Old 03-21-05, 03:53 PM
  #8  
The king of the highway!
10 Year Member
iTrader: (2)
 
darkphantom's Avatar
 
Join Date: May 2004
Location: Home of the 305 Boyz(miami)
Posts: 2,989
Likes: 0
Received 0 Likes on 0 Posts
Nnoooiiicccee!!!
darkphantom is offline  
Old 03-22-05, 11:36 AM
  #9  
Ee / Cpe
5 Year Member
Thread Starter
 
XSTransAm's Avatar
 
Join Date: Jan 2003
Location: Gaithersburg, MD / WVU
Posts: 2,843
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Madmax670
what are all of your mods if you dont mind me asking.
HKS manifold
HKS wastegate
HkS Intake
T61 turbo
3" all the way back
Greddy Pulleys
Twin TurboXS RFL's
TurboXS HPDSBC
Rx7store stage 2 engine
Hyperflow custom FMIC
ACT extreme clutch
FC1000 ignition amplifier
1680cc secondarys
Aeromotive fpr
Upgraded pump
Kgparts secondary rail
Haltech E6k

heres all the relative power mods just copied out of my garage thingi
XSTransAm is offline  
Old 03-22-05, 01:10 PM
  #10  
Im Back Bitches
iTrader: (1)
 
550rwhprex's Avatar
 
Join Date: Dec 2003
Location: crazyness
Posts: 283
Likes: 0
Received 0 Likes on 0 Posts
those torque numbers are incorrect..... you might want to check that
550rwhprex is offline  
Old 03-22-05, 01:19 PM
  #11  
It has begun
iTrader: (20)
 
lane_change's Avatar
 
Join Date: Feb 2002
Location: Houston, TX
Posts: 3,388
Likes: 0
Received 0 Likes on 0 Posts
I am running a 60-1 on mine...and I put down 345rwhp and 278rwtq witha stock motor, pfc, 1600cc, etc.... at 12psi. Just for a torque reference, in case you were wondering what it was supposed to be around....instead of 1100.
lane_change is offline  
Old 03-22-05, 05:42 PM
  #12  
Ee / Cpe
5 Year Member
Thread Starter
 
XSTransAm's Avatar
 
Join Date: Jan 2003
Location: Gaithersburg, MD / WVU
Posts: 2,843
Likes: 0
Received 0 Likes on 0 Posts
The dyno im using shows either hub torque or wheel torque. I accidently copied the hub torque graph when i was coping off the dyno computer so thats why the numbers look rediculous. Its around 290 torque to the wheels.
XSTransAm is offline  
Old 03-28-05, 02:32 PM
  #13  
Full Member
5 Year Member
 
7777 Nepok 7777 -rx-'s Avatar
 
Join Date: Oct 2004
Location: Miami, FL
Posts: 217
Likes: 0
Received 0 Likes on 0 Posts
omg, i almost peed my pants when i saw those tq #s....
7777 Nepok 7777 -rx- is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Queppa
New Member RX-7 Technical
8
09-02-18 09:53 AM
Snook
3rd Generation Specific (1993-2002)
21
09-01-15 06:32 PM
ximi
3rd Generation Specific (1993-2002)
14
07-08-02 09:39 PM
LUV94RX7
Rotary Car Performance
24
06-17-02 02:17 PM
mr rx
Rotary Car Performance
3
02-17-02 10:12 PM


Thread Tools
Search this Thread
Quick Reply: [email protected]


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.