Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Single Turbo RX-7's
Reload this Page >

Blowing out spark WI at 30psi 7000rpm crane hi6 Suggestions ?

Single Turbo RX-7's Questions about all aspects of single turbo setups.

Blowing out spark WI at 30psi 7000rpm crane hi6 Suggestions ?

Old 04-06-15, 02:20 PM
  #51  
Junior Member
 
trinirx's Avatar
 
Join Date: Jul 2010
Location: trinidad
Posts: 34
Likes: 0
Received 1 Like on 1 Post
How would stock FD coils work with the m&w ign?
trinirx is offline  
Old 04-07-15, 02:05 AM
  #52  
Senior Member
iTrader: (8)
 
Join Date: Jul 2011
Location: AZ
Posts: 481
Received 5 Likes on 4 Posts
AZ

Originally Posted by Copeland View Post
t-von, you're probably right but I was thinking maybe there was some backpressure issue causing exhaust to be recirulated in the engine somehow. I'll probably still change the turbine housing since it's a little undersized for my plans to raise the boost further.

rx72c, I'm fairly certain it's not fuel related since the issue goes away for a few runs after a fresh set of plugs that are gapped .018" - it still degrades rather quickly though. I'll still check if I can troubleshoot that somehow though.
While turning up the boost I had a similar issue. I have the same coil and plug setup as you and for me 30+psi and anything richer then 11.8 or so would simply cutout. Leaning it out got ride of the issue for me and since E85 is so forgiving there was no knock at all.
Neutron is offline  
Old 04-07-15, 01:25 PM
  #53  
32psi+
iTrader: (42)
 
Copeland's Avatar
 
Join Date: Sep 2006
Location: Raleigh, NC
Posts: 1,218
Received 7 Likes on 7 Posts
Originally Posted by Neutron View Post
While turning up the boost I had a similar issue. I have the same coil and plug setup as you and for me 30+psi and anything richer then 11.8 or so would simply cutout. Leaning it out got ride of the issue for me and since E85 is so forgiving there was no knock at all.
Yeah I figured it must have been a limitation with the AEM coils so I'm working on upgrading to a M&W setup now. Doing a semi as well while I'm at it.
Copeland is offline  
Old 04-08-15, 02:05 AM
  #54  
Senior Member
iTrader: (8)
 
Join Date: Jul 2011
Location: AZ
Posts: 481
Received 5 Likes on 4 Posts
AZ

Originally Posted by Copeland View Post
Yeah I figured it must have been a limitation with the AEM coils so I'm working on upgrading to a M&W setup now. Doing a semi as well while I'm at it.
Please let me know how it goes. Also when you get it all sorted out send me a parts list. I'm probably going to have to follow in your foots steps on this.
Neutron is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
24seven_dada
3rd Generation Specific (1993-2002)
20
11-10-18 12:03 PM
HalifaxFD
Canadian Forum
126
05-09-16 07:06 PM
The1Sun
1st Generation Specific (1979-1985)
7
09-18-15 07:13 PM
The1Sun
New Member RX-7 Technical
5
09-15-15 04:45 PM


Thread Tools
Search this Thread
Quick Reply: Blowing out spark WI at 30psi 7000rpm crane hi6 Suggestions ?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: