is 24lbs max reading for the AFM? s4 t2 rtek 2.1, trouble shooting lean in boost - RX7Club.com - Mazda RX7 Forum

Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Rtek Forum
Reload this Page >

is 24lbs max reading for the AFM? s4 t2 rtek 2.1, trouble shooting lean in boost

Rtek Forum Discuss the Rtek 2.0 and other Rtek ECU's

is 24lbs max reading for the AFM? s4 t2 rtek 2.1, trouble shooting lean in boost

Reply

 
 
 
Old 07-19-14, 01:07 PM
  #1  
I
Thread Starter
iTrader: (6)
 
KompressorLOgic's Avatar
 
Join Date: May 2004
Location: Renton, WA
Posts: 3,611
Thanks: 0
Thanked 2 Times in 2 Posts
is 24lbs max reading for the AFM? s4 t2 rtek 2.1, trouble shooting lean in boost

rtek 2.1

while troubleshooting, with the car not running but on I pressed the afm all the way in and it moved linearly, but maxed out at about 24lbs, temps were about 70 deg, at an altitude of 300 ft.

which is about 2/3 up the graph, and even on my safc it shows it as about 66%

on some old logs which were in cfm it would max out at around 900 cfm near the top of the scale. having trouble pulling the new logs up on the computer.


problem ive been having, car ran great, just suddenly this week it runs pretty lean at part throttle- full throttle when going into boost. a/f get into high 13-14 and doesn't make much power.

it did this same thing a couple yrs ago, I checked many things and re loaded the map and it went away...

map, temp, air temp, tps all are functioning correctly. fuel pressure is normal. tried reloading map and it still is doing it.

I noticed if I added fuel( which modifies the afm signal ) with the safc it will richen up as it should. and power is restored, roughly.
KompressorLOgic is offline  
Reply With Quote
Old 07-19-14, 01:54 PM
  #2  
I
Thread Starter
iTrader: (6)
 
KompressorLOgic's Avatar
 
Join Date: May 2004
Location: Renton, WA
Posts: 3,611
Thanks: 0
Thanked 2 Times in 2 Posts
well I added about 20% fuel with the safc across the board , and was able to do a pull up to around 6K and got a max afm reading of 30.6, as it was so lean before it was to risky to try pull.

something with the afm im thinking?
KompressorLOgic is offline  
Reply With Quote
Old 07-19-14, 03:30 PM
  #3  
I
Thread Starter
iTrader: (6)
 
KompressorLOgic's Avatar
 
Join Date: May 2004
Location: Renton, WA
Posts: 3,611
Thanks: 0
Thanked 2 Times in 2 Posts
hmm I suspect the afm has gone amiss, it doesn't seem to ohm out correctly fully open getting about 60 ohms looks like I should get 20- 1.0 ohms? hmm or maybe its 20-1000 ohms seems like a wide swing...
KompressorLOgic is offline  
Reply With Quote
Old 07-19-14, 04:32 PM
  #4  
I
Thread Starter
iTrader: (6)
 
KompressorLOgic's Avatar
 
Join Date: May 2004
Location: Renton, WA
Posts: 3,611
Thanks: 0
Thanked 2 Times in 2 Posts
completely unwired safc, and the problem has went away, it must have been doing something funky to the afm signal!
KompressorLOgic is offline  
Reply With Quote
Old 09-19-17, 08:18 PM
  #5  
I
Thread Starter
iTrader: (6)
 
KompressorLOgic's Avatar
 
Join Date: May 2004
Location: Renton, WA
Posts: 3,611
Thanks: 0
Thanked 2 Times in 2 Posts
this same issue has resurfaced again!!! 3 years later WTF? AFM maxes out at 660-730 instead of in the 900s like before.
KompressorLOgic is offline  
Reply With Quote
Old 09-19-17, 08:55 PM
  #6  
I
Thread Starter
iTrader: (6)
 
KompressorLOgic's Avatar
 
Join Date: May 2004
Location: Renton, WA
Posts: 3,611
Thanks: 0
Thanked 2 Times in 2 Posts
I unplugged ecu,afm, tps, and the conections left over from the SAFC (bullet style) and now it runs good again and I am seeing normal readings once again!
KompressorLOgic is offline  
Reply With Quote
Old 09-26-17, 09:50 AM
  #7  
[R.R.]
iTrader: (17)
 
White Charisma's Avatar
 
Join Date: Oct 2008
Location: Glen Burnie, MD
Posts: 165
Thanks: 0
Thanked 0 Times in 0 Posts
While trying to troubleshoot my Rtek setup recently I used an S4 NA (N326) AFM temporarily.
I noticed its max reading was right around 24lbs, and would cause a lean condition under boost.
Have you made sure you're using an N318 TII AFM? Just a thought.
White Charisma is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trickster
2nd Generation Specific (1986-1992)
20
03-29-18 02:05 PM
smikels
Rtek Forum
4
05-12-16 12:34 AM
TerryD
2nd Generation Specific (1986-1992)
1
08-23-15 07:40 AM
smikels
2nd Generation Specific (1986-1992)
3
08-18-15 01:26 PM
andyvideopro
General Rotary Tech Support
2
08-11-15 09:16 PM


Thread Tools
Search this Thread
Quick Reply: is 24lbs max reading for the AFM? s4 t2 rtek 2.1, trouble shooting lean in boost


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: