Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Microtech
Reload this Page >

Microtech LT10S + X4 and MSD 8207 Blaster SS Wiring Questions

Microtech Area is for discussing Microtech systems

Microtech LT10S + X4 and MSD 8207 Blaster SS Wiring Questions

Old 07-21-08, 06:48 PM
  #1  
AKA Poindexter
10 Year Member
Thread Starter
iTrader: (2)
 
Poindexter10thae's Avatar
 
Join Date: Apr 2001
Location: Austin, TX; JABLAM!, WA; Iraq
Posts: 632
Likes: 0
Received 0 Likes on 0 Posts
LT10S + X4 and MSD 8207 Blaster SS Wiring Questions

Hello all, I am upgrading from my LT8 and Stock FC coils to the LT10S+x4 box and 4 MSD 8207 Blaster SS coils.

My question is in regard to the +12V source for the coils. According to the wiring diagram, it states that it is "12V Ignition", and the pink +12V ignition on wire from the mircotech needs to be connected to the + side of the leading coil.


I just wanted to clarify, I should run +12V switched Ign on from an existing source in the car(such as the stock connector for the old Lead coil) to all 4 of my new coils, and run the pink +12V ign on lead from the microtech, to the positive side of the L1 coil.

Am I right or horribly wrong in my translation of the wiring diagram
Poindexter10thae is offline  
Old 07-22-08, 12:59 AM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
that is correct.

the pink wire does NOT have to go the coil. it can go to another ignition source.
rx72c is offline  
Old 07-28-08, 07:47 PM
  #3  
Scream baby Scream!!!
10 Year Member
 
Rotorhead34's Avatar
 
Join Date: Sep 2002
Location: Clarksville, Tn.
Posts: 434
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by BigWoogie View Post
Hello all, I am upgrading from my LT8 and Stock FC coils to the LT10S+x4 box and 4 MSD 8207 Blaster SS coils.

My question is in regard to the +12V source for the coils. According to the wiring diagram, it states that it is "12V Ignition", and the pink +12V ignition on wire from the mircotech needs to be connected to the + side of the leading coil.


I just wanted to clarify, I should run +12V switched Ign on from an existing source in the car(such as the stock connector for the old Lead coil) to all 4 of my new coils, and run the pink +12V ign on lead from the microtech, to the positive side of the L1 coil.

Am I right or horribly wrong in my translation of the wiring diagram
That is the exact setup I am running and I ran the pink wire to an ign on source seperate from the 12v source for the coils. I also used an inline fuse as a precaution on the pink wire. I am pleased with the results.
Rotorhead34 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BNR34RB26DETT
Build Threads
42
02-28-18 11:27 AM
stickmantijuana
MoTeC
5
09-10-15 07:58 PM
Professorpeanutrx7
New Member RX-7 Technical
5
08-15-15 01:38 PM


Thread Tools
Search this Thread
Quick Reply: Microtech LT10S + X4 and MSD 8207 Blaster SS Wiring Questions


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: