Microtech Area is for discussing Microtech systems

Microtech lt10 secondary injector

Old 03-05-09, 02:00 PM
  #1  
bassrotor
5 Year Member
Thread Starter
 
bassrotor's Avatar
 
Join Date: Jan 2007
Location: kissimmee
Posts: 125
Likes: 0
Received 0 Likes on 0 Posts
FL lt10 secondary injector

hello fellows I have a problem with my secondary injectors. I when to tuned and is only running on primary, they put the car on idle and setup with all 4 injector and the car didnt get flooded, I put 850cc and then 1200cc on secondary but still the same its getting power on the harnes and connector too. the car runs fine and boost at 13 psi is a 12a turbo but not getting 2dary to work, I have a walbro 255 pump inline fpr at 45psi, 800cc primary and 1200 secondary , I dont know what else to do, thanks and guide will help
bassrotor is offline  
Old 03-05-09, 02:11 PM
  #2  
Sharp Claws
iTrader: (30)
 
RotaryEvolution's Avatar
 
Join Date: Oct 2003
Location: Central Florida
Posts: 5,135
Likes: 0
Received 16 Likes on 15 Posts
you tried the test feature to double check that the secondaries were in fact not firing? you can do it with the manifold off and listen to the injectors by only plugging in the ones you think are not firing. if you have power to the injector then just ohm test the wire from the ground firing circuit down to the ECU connector. if both circuits are fine then just plug in the clip to an injector you know is firing in the primary position to verify a possibly faulty ECU, if it checks out then you may possibly have a faulty ECU so i would then contact microtech about it.
RotaryEvolution is offline  
Old 03-05-09, 02:22 PM
  #3  
bassrotor
5 Year Member
Thread Starter
 
bassrotor's Avatar
 
Join Date: Jan 2007
Location: kissimmee
Posts: 125
Likes: 0
Received 0 Likes on 0 Posts
yes I plug to injector outside the manifold and it work,thats why I put diffrent size to see if get flooded, but when the engine is running they dont open
bassrotor is offline  
Old 03-05-09, 04:17 PM
  #4  
Full Member
5 Year Member
 
Join Date: Apr 2005
Location: nz
Posts: 115
Likes: 0
Received 0 Likes on 0 Posts
is the rev lim or boost cut on?
mattmarrx3 is offline  
Old 03-05-09, 04:35 PM
  #5  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
Why would it flood when you switch them on?
When you activate all 4 through the microtech it will make up for the extra injectors and cut down opening times.

Give us these settings

Opt_mapstg
OPT_revstg
OPT_stg%
rx72c is offline  
Old 03-05-09, 07:11 PM
  #6  
bassrotor
5 Year Member
Thread Starter
 
bassrotor's Avatar
 
Join Date: Jan 2007
Location: kissimmee
Posts: 125
Likes: 0
Received 0 Likes on 0 Posts
my tuner said that the when he activate all 4 injector the engine supous to shutt down due to the amount of fuel while is idleling.
but I been going crazy today checking why is doing that, I check my fpr and is a mallory 4309 I did some search on it and find out the is a 3 to 12 psi, but I can understand why my gauge reading 45 psi and when I driving the car for a while read about 25 psi , when is coold down read 45 againg

Originally Posted by rx72c View Post
Why would it flood when you switch them on?
When you activate all 4 through the microtech it will make up for the extra injectors and cut down opening times.

Give us these settings

Opt_mapstg
OPT_revstg
OPT_stg%
bassrotor is offline  
Old 03-05-09, 09:46 PM
  #7  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
So hold on.
Youve got 3psi of fuel pressure when its warm?

I.e the fuel pump has **** itself?
Get the above settings out of the microtech.
rx72c is offline  
Old 03-06-09, 02:32 PM
  #8  
Sharp Claws
iTrader: (30)
 
RotaryEvolution's Avatar
 
Join Date: Oct 2003
Location: Central Florida
Posts: 5,135
Likes: 0
Received 16 Likes on 15 Posts
find a shop that knows what the hell they are doing, the guy who is working on your car has no clue. 25 psi of fuel pressure is way too low and what he is telling you about the injector pairing is BS, the fuel pressure should be around 35-40PSI with the FPR vacuum port unplugged and raise 1 PSI per PSI of boost. if the injectors tested ok and are firing in test mode then he is doing something wrong, period. the injector staging is way out of whack causing a lean transition is what i am guessing too, which is why he is thinking the secondaries are not turning on.
RotaryEvolution is offline  
Old 03-11-09, 08:21 PM
  #9  
bassrotor
5 Year Member
Thread Starter
 
bassrotor's Avatar
 
Join Date: Jan 2007
Location: kissimmee
Posts: 125
Likes: 0
Received 0 Likes on 0 Posts
I order a fpr for fuel injection the one that I was using if carb tipe, ones a changed and check fuel pressure I will keep update it
bassrotor is offline  
Old 03-24-09, 03:24 PM
  #10  
bassrotor
5 Year Member
Thread Starter
 
bassrotor's Avatar
 
Join Date: Jan 2007
Location: kissimmee
Posts: 125
Likes: 0
Received 0 Likes on 0 Posts
rx2 this is what I got


mapstg 02
recstg 1320
stg % 50

Originally Posted by rx72c View Post
Why would it flood when you switch them on?
When you activate all 4 through the microtech it will make up for the extra injectors and cut down opening times.

Give us these settings

Opt_mapstg
OPT_revstg
OPT_stg%
bassrotor is offline  
Old 03-24-09, 07:21 PM
  #11  
Senior Member
5 Year Member
iTrader: (5)
 
pistones's Avatar
 
Join Date: Oct 2005
Location: nyc
Posts: 721
Likes: 0
Received 0 Likes on 0 Posts
umm.. how would the secondaries fire at idle? did anybody notice what he said in the first post?
pistones is offline  
Old 03-26-09, 06:43 PM
  #12  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
You can get them to fire on idle if need be.

mapstg is 2" not 2psi.
dont confuse this.
rx72c is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HalifaxFD
Canadian Forum
126
05-09-16 07:06 PM
ZacMan
Build Threads
4
09-19-15 09:20 PM


Thread Tools
Search this Thread
Quick Reply: Microtech lt10 secondary injector


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: