Microtech Area is for discussing Microtech systems

How do you know what series the ECU is?

Old 11-07-17, 01:48 PM
  #1  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
Angry How do you know what series the ECU is?

Is there some way to know what series your ecu is factory programmed for? Is it programmed for an FC or FD crank setup.
I have an FD and bought a used ecu on here some time ago and have been unable to get the car started. I am wondering if it was not programmed for FD. The only thing I can see on my ecu that many give some idea is that says b2.0 on one of the screens. What is that for?
BluRR is offline  
Old 11-11-17, 10:11 AM
  #2  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
You'll find these settings on screen 31.

Specifically the Config settings, Firing, InputTrig, SparkTrig.

If you post these we can give you a good guess as to how it is set up.
Aaron Cake is offline  
Old 11-11-17, 04:53 PM
  #3  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
From menory these are options

firing- group fire or sequential
input trig - +ve or -ve
sparktrig - -ve or maz (something like that or maz+)

When cranking i will get spark from the leading plugs when when the SparkTrig is set to Maz only, it doesnt fire when the sparktrig is set to -ve.
Once the sparktrig is set to Maz then it will spark regardless if the input is on +ve or -ve. It will sound like it almost wants to start but just doesnt.

I did a pull start attempt and after some pulling the engine kinda ran but i had to keep my foot on throttle to keep it "running" and it sounded like when you have a dead rotor or bad timing and the red light was blinking for rpm and reference, etc errors.

Its a new build, havent done a compression test yet, but even if a rotar was bad it shouldn't have been throwing the errors i think if all else was ok.

Last edited by BluRR; 11-11-17 at 05:08 PM.
BluRR is offline  
Old 11-12-17, 09:36 AM
  #4  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
I'd need to see the settings exactly as shown. Not as familiar with how the Microtech is set up on the FD however the trigger should be the same as the FC. If I saw them, I'd recognise wrong ones.

Maybe someone else knows off hand.
Aaron Cake is offline  
Old 11-17-17, 05:22 PM
  #5  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
MAPs = Matrix, Normal
Config +04cyl/R
Firing Sequential, GroupFire
Load = MAP sensor, TPS sensor
DWELL= time base, duty cycle
Input Trig +POS, -NEG
Spark Trig Maz+, -NEG
Timing check OFF, LOCK ON
Rpm_ON 1500 Log
Map_ON 10"Hg Log
spare1 +00% Log
spare 2 _00% Log
SHIFT 7060 Dash
WATER 94C Dash
AIR_T 72C Dash
BOOST 12psi Dash
BluRR is offline  
Old 11-18-17, 10:13 AM
  #6  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
I think that's set up for FC.
Aaron Cake is offline  
Old 11-18-17, 10:29 AM
  #7  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
If that is the case. Can it run the engine with the FD crank sensors? Has anyone successfully done this?
BluRR is offline  
Old 11-19-17, 09:46 AM
  #8  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
FD and FC crank triggers are both 24-2 so yes, no problem.
Aaron Cake is offline  
Old 11-19-17, 07:27 PM
  #9  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
Have you ever seen a single ecu work on both setups?
BluRR is offline  
Old 02-01-18, 05:09 PM
  #10  
87 SE WITH S5 T2 SWAP
iTrader: (11)
 
joeylyrech's Avatar
 
Join Date: May 2004
Location: allentown pa
Posts: 2,070
Likes: 0
Received 0 Likes on 0 Posts
My lt9c will run fc or fd setups but it was asked 2 be set up like that when they first came out.Most lt16c are like that 2.
joeylyrech is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: