Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Microtech
Reload this Page >

Microtech Help: Can't Connect To ECU, Software Screen "Freezes"

Microtech Area is for discussing Microtech systems

Microtech Help: Can't Connect To ECU, Software Screen "Freezes"

Old 07-15-07, 04:55 PM
  #1  
Engine, Not Motor
Thread Starter
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,674
Likes: 0
Received 24 Likes on 23 Posts
Help: Can't Connect To ECU, Software Screen "Freezes"

I'm trying to start my car after the big turbo upgrade but cannot get connected to the ECU. When I try to connect, the Microtech software screen simply "freezes". All the values at the bottom blank out, and the gauges don't respond. I've included a screenshot.

The car does want to start as fuel and ignition are firing, but I can't troubleshoot why it is not running without being able to connect to the ECU.

If I disconnect the laptop and key on, the fuel pump primes and the TPS light responds as it should (lit at zero throttle, goes off at more then zero throttle).

This whole thing worked last year before I put the car away, but now suddenly I cannot connect.

I also did a serial port capture to try and find out if my machine simply had a bad serial port, but it looks like it can see the Microtech just fine. Here's a paste from the serial capture on the DCE side:


(key on)

DCE:
(FC)
(8C)(8C)(FC)(CE)(CE)(FE)(FE)
(FE)
(FC)(8E)(FC)(FC)(FC)(FE)
(FE)(FC)(FC)
(8E)(FC)(FC)(FC)(FE)(FE)(FC)
(FC)
(8E)(FC)(FC)(FC)(FE)(FE)(FC)
(FC)
(8E)(FC)(FC)(FC)(FE)(FE)(FC)
(FC)
(8E)(FC)(FC)(FC)(FE)(FE)(FC)
(8E)(FC)(FC)(FC)(FE)(FC)(FE)(FC)
(8E)(FC)(FC)(FC)(FE)(FC)(FE)(FC)
(8E)(FC)(FC)(FC)(FE)(FC)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(FC)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FE)
(FC)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FE)
(8E)(FC)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FE)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FE)
(FC)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FC)
(FC)
(8E)(FE)
(FC)


(and it continues from there)

Attempting to move through the menus to the data gauges or through any of the screens resulted in no response....

HELP! I've waited 6 years to drive this car and am now stopped by a non-problem.

I will try to find another computer to test with but laptops with serial ports are getting hard to find. I'm using a PCMCIA adapter in this laptop, which has always worked in the past (even with this car).
Attached Thumbnails Help: Can't Connect To ECU, Software Screen "Freezes"-microtech-screen-capture.jpg  
Aaron Cake is offline  
Old 07-15-07, 08:04 PM
  #2  
Engine, Not Motor
Thread Starter
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,674
Likes: 0
Received 24 Likes on 23 Posts
Nevermind, I'm an idiot. I forgot the laptop adapter. Apparently it had fallen off the end of the serial cable and I didn't even realise until I found it in my laptop bag.

Looks like I deserve this:
Attached Thumbnails Help: Can't Connect To ECU, Software Screen "Freezes"-assclown.jpg  
Aaron Cake is offline  
Old 07-15-07, 09:07 PM
  #3  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
hahahah.
thats funny.
good ****.
rx72c is offline  
Old 07-16-07, 08:51 AM
  #4  
Engine, Not Motor
Thread Starter
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,674
Likes: 0
Received 24 Likes on 23 Posts
Yeah, talk about a brain fart. I had been working nonstop on the car for the last month or so and just completely forgot about the laptop adapter. It was nearly 5PM and I was out of time, and running on very little sleep...
Aaron Cake is offline  
Old 08-03-07, 12:31 PM
  #5  
Full Member
 
Join Date: Jul 2007
Location: alabama
Posts: 71
Likes: 0
Received 0 Likes on 0 Posts
do you have to have the laptop adapter to tune it with your laptop? the serial cable matches up perfectly with the port in my laptop but its doing exactly what you are describing. if so do you know where i can pick up just the adapter?
slade.khazid is offline  
Old 08-03-07, 01:50 PM
  #6  
Engine, Not Motor
Thread Starter
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,674
Likes: 0
Received 24 Likes on 23 Posts
You must have the laptop adapter. It contains a small PIC based circuit to allow communication with the Microtech.

A-Spec tuning sells the adapter, as do most Microtech dealers.

Would be nice if Microtech would put a warning in the software that says something like "Hey dumbass, you don't have the adapter installed!" instead of just locking.
Aaron Cake is offline  
Old 08-03-07, 02:21 PM
  #7  
Dirty Harry
iTrader: (5)
 
MaczPayne's Avatar
 
Join Date: Dec 2005
Location: California
Posts: 5,659
Received 2 Likes on 2 Posts
Your car's driving you nuts =)
MaczPayne is offline  
Old 08-06-07, 10:26 AM
  #8  
Full Member
 
Join Date: Jul 2007
Location: alabama
Posts: 71
Likes: 0
Received 0 Likes on 0 Posts
awesome! thanks for the info
slade.khazid is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
24seven_dada
3rd Generation Specific (1993-2002)
20
11-10-18 12:03 PM
Frox
Introduce yourself
5
02-27-16 11:11 AM
mulcryant
2nd Generation Specific (1986-1992)
10
09-09-15 05:24 PM


Thread Tools
Search this Thread
Quick Reply: Microtech Help: Can't Connect To ECU, Software Screen "Freezes"


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: