General Rotary Tech Support Use this forum for tech questions not specific to a certain model year

S4 t2 lose off power and strange exhaust sound

Old 02-06-18, 07:04 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2017
Location: Western Australia
Posts: 10
Received 0 Likes on 0 Posts
Exclamation S4 t2 lose off power and strange exhaust sound

Hi all.

i have a 1986 rx7 turbo and habe been having some problems with power. There is a weird exhaust sound. All most sounds like a wrx. And is not boosting very well. Huge lose of power. Is this a blown seal or could it be exhaust, fuel or intake related. Would like some veiws on people more experience before i go taking the engine out.

also i dont have have a compression tester but i toke out the spark on each rota housing and sounds like three even puffs
David Crooky is offline  
Old 02-07-18, 07:54 AM
  #2  
roTAR needz fundZ
iTrader: (1)
 
Join Date: Aug 2002
Location: Freeland, MI
Posts: 2,663
Likes: 0
Received 29 Likes on 29 Posts
what your explaining is a blown rotor. Find/buy/borrow a compression tester and see what you get
lduley is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Saminya
2nd Generation Specific (1986-1992)
8
08-05-17 06:39 PM
Glass Machine
NW RX-7 Forum
25
07-30-12 12:40 PM
TurboIIRyan
2nd Generation Specific (1986-1992)
7
07-26-05 01:52 AM
Cubfan
1st Generation Specific (1979-1985)
18
10-04-02 02:29 PM
execelon1
2nd Generation Specific (1986-1992)
5
04-23-02 06:01 PM


Thread Tools
Search this Thread
Quick Reply: S4 t2 lose off power and strange exhaust sound


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: