Time Slips and Dyno Section is for posting 1/4 mile time slips and dyno graphs

Dyno'd for the first time, stock twins 15psi *vid*

Old 05-14-05, 06:55 PM
  #1  
RotorRocket
10 Year Member
Thread Starter
iTrader: (5)
 
Venom-X1's Avatar
 
Join Date: Jul 2004
Location: Austin, TX
Posts: 148
Likes: 0
Received 0 Likes on 0 Posts
Dyno'd for the first time, stock twins 15psi *vid*

Finally got dyno'd for the first time, got 2 runs. It was really hot and humid out. Wicked breakup uptop, and Ignore the top 2 lines on the graph somehow they messed up the torque rating. Mods are in sig.

Run 1
ftp://lnxsrt:[email protected]_0013.wmv

Run 2
ftp://lnxsrt:[email protected]_0014.wmv
Attached Thumbnails Dyno'd for the first time, stock twins 15psi *vid*-mvc-427x.jpg  
Venom-X1 is offline  
Old 05-15-05, 02:38 PM
  #2  
Rotary Freak
10 Year Member
 
pluto's Avatar
 
Join Date: Feb 2001
Location: fort worth, tx, usa
Posts: 1,926
Likes: 0
Received 0 Likes on 0 Posts
you really need an ignition amp. that'll fix your problem. also to change your plugs every 2k-3k miles to keep the performance the same.
pluto is offline  
Old 05-15-05, 02:41 PM
  #3  
Rotary Freak
iTrader: (7)
 
Join Date: Mar 2002
Location: St. Louis
Posts: 1,591
Received 3 Likes on 2 Posts
What was the setting on your PFC for 15 psi? What were your AFRs?
books is offline  
Old 05-16-05, 07:52 AM
  #4  
Eats, Sleeps, Dreams Rotary
 
Join Date: Mar 2001
Location: CT
Posts: 4,886
Likes: 0
Received 7 Likes on 7 Posts
damn thats an odd looking chart. i had some break up as well. my break up sounded worse but man my graph looked nothing like that. we installed twin power and it was smooth as silk. Order up a twin power and bolt it right in.
matty is offline  
Old 05-16-05, 02:55 PM
  #5  
silver ghost
iTrader: (11)
 
G's 3rd Gen's Avatar
 
Join Date: Sep 2003
Location: Home of the Rolex 24
Posts: 3,050
Likes: 0
Received 1 Like on 1 Post
yup..Twin power did the same for me....
G's 3rd Gen is offline  
Old 05-16-05, 04:52 PM
  #6  
RotorRocket
10 Year Member
Thread Starter
iTrader: (5)
 
Venom-X1's Avatar
 
Join Date: Jul 2004
Location: Austin, TX
Posts: 148
Likes: 0
Received 0 Likes on 0 Posts
been waitin on the twin power, but it was on backorder. Ordered it over 2 months ago from rx7store.net
Venom-X1 is offline  
Old 05-17-05, 09:15 AM
  #7  
Rotary Freak
iTrader: (7)
 
Join Date: Mar 2002
Location: St. Louis
Posts: 1,591
Received 3 Likes on 2 Posts
What was the setting on your PFC or Commander for 15 psi (x.xx kg/cm^2)?
What were your AFRs?
books is offline  
Old 05-17-05, 09:25 PM
  #8  
RotorRocket
10 Year Member
Thread Starter
iTrader: (5)
 
Venom-X1's Avatar
 
Join Date: Jul 2004
Location: Austin, TX
Posts: 148
Likes: 0
Received 0 Likes on 0 Posts
the PFC was set at 1.05 kg/cm^2, boost gauge read 15psi and AFR's were high 10's low 11's.
Venom-X1 is offline  
Old 05-17-05, 09:43 PM
  #9  
Rotary Freak
iTrader: (7)
 
Join Date: Mar 2002
Location: St. Louis
Posts: 1,591
Received 3 Likes on 2 Posts
Originally Posted by Venom-X1
the PFC was set at 1.05 kg/cm^2, boost gauge read 15psi and AFR's were high 10's low 11's.
thanks...good luck with your quest for the HKS
books is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dkwasherexd
Single Turbo RX-7's
21
05-27-17 04:51 AM
stickmantijuana
Engine Management Forum
11
11-09-15 01:15 PM
Turblown
Single Turbo RX-7's
0
08-14-15 04:48 PM
Clacor
Single Turbo RX-7's
0
08-14-15 09:17 AM
rkhanso
2nd Generation Specific (1986-1992)
1
08-13-15 11:40 AM


Thread Tools
Search this Thread
Quick Reply: Dyno'd for the first time, stock twins 15psi *vid*


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.