Race Car Tech Discuss anything related to road racing and auto X.

Crack Front iron n blow oil pump

Old 03-25-14, 03:37 AM
  #1  
RE for life
Thread Starter
 
diyman25's Avatar
 
Join Date: May 2002
Location: sca
Posts: 1,180
Likes: 0
Received 18 Likes on 15 Posts
Crack Front iron n blow oil pump

Last year, i was complain to my Team. with loose of oil pressure at end of front straight way
(from 120-100)

this years first event the condion get worse. with even lower Pressure n very hight oil temp

after a lot time spend under the car we find out.. the Oil pump crack into half !!!!!!!!!!!!!!!

that really sucks.... n i never heard this kind of problem before. and because race is about start in
24hr so i neeed to rush 700KM to get a oil pump from friends

another old nighter.... finally get it done. n ready to go to pratice before the race

Kaboom... with ligh load.. n about sec gear turn. i see the low oil psi sign.... n smoke

n i was like **** now what.............. park the car at safe zone n wait for the tow truck to tow it back

n this is what i find.. a Crack front iron... anotther thing i never experience before.............

i am totoal speechless ... hopely my accsump will save the engine .....

any thoght on this n possible upgrade so this wont happeand again ?

thanks for your time
J
Attached Thumbnails Crack Front iron n blow oil pump-.jpg   Crack Front iron n blow oil pump-1-.jpg  
diyman25 is offline  
Old 03-27-14, 08:10 AM
  #2  
Derwin
iTrader: (2)
 
dradon03's Avatar
 
Join Date: Apr 2005
Location: MTL, QC
Posts: 2,888
Likes: 0
Received 0 Likes on 0 Posts
Had you been running the plug on the oil feed for quite sometime?

Was the oil pressure abnormally high before?
dradon03 is offline  
Old 03-27-14, 02:21 PM
  #3  
Blood, Sweat and Rotors
iTrader: (1)
 
DriveFast7's Avatar
 
Join Date: Aug 2001
Location: California
Posts: 3,733
Received 0 Likes on 0 Posts
Assuming the plug is straight threaded and not tapered (taper will split the cast front iron), and isn't over-torqued... That part of the iron is weak as it has a dowel going longitudinally into it. Add a bolt going down and another bolt going in from the side..there you go. Why is there a socket head plug in there anyways, from the factory it was plugged.

What do you have bolted to the side of the motor via that aluminum bracket? Is it heavy or a stressed member?

Is the motor solid mounted to the frame or are you using rubber or polyurethane motor mounts?

Most likely the oil pump sucked something in and cracked.
DriveFast7 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
FD7KiD
3rd Generation Specific (1993-2002)
13
06-04-19 11:02 PM
cristoDathird
Introduce yourself
28
05-30-19 08:47 PM
FD7KiD
Single Turbo RX-7's
1
08-17-15 11:50 PM


Thread Tools
Search this Thread
Quick Reply: Crack Front iron n blow oil pump


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: