Microtech Area is for discussing Microtech systems

Microtech Wat's wrong with my microtech?

Old 09-28-03, 11:18 AM
  #1  
Full Member
5 Year Member
Thread Starter
 
Join Date: Mar 2003
Location: Singapore
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
Wat's wrong with my microtech?

Hi,
Is there something wrong with my microtech? We have tried setting it, but if it's too lean the car dies off at every stop, or when it comes to idle, but if it's too rich I feel sluggish and lots of carbon from the exhaust. And furthermore, the car always gives a jerking feeling. Can anyone explain why?

Thanks
Francis
seven is offline  
Old 09-28-03, 11:54 AM
  #2  
I F****D a mermaiiiid
10 Year Member
 
Join Date: Dec 2001
Location: Jacksonville, FL
Posts: 208
Likes: 0
Received 0 Likes on 0 Posts
can you provide us with a detailed description of the car? what injectors are you using? what kind of porting do you have done, what size turbo?
GTRay is offline  
Old 09-28-03, 12:18 PM
  #3  
what 7
10 Year Member
 
Piranha's Avatar
 
Join Date: Feb 2002
Location: Portage, MI
Posts: 670
Likes: 0
Received 0 Likes on 0 Posts
Have you tried going by the step by step rough setup in the manual?
Piranha is offline  
Old 09-28-03, 07:09 PM
  #4  
Full Member
5 Year Member
Thread Starter
 
Join Date: Mar 2003
Location: Singapore
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
My current setup is a standard series 4 13bt engine, with a Knightsports hybrid turbo with stock 13b injectors. The rest are basically stock. Can I have my microtech sent back for repairs or probably convert to LT-8?

Thanks
Francis
seven is offline  
Old 09-29-03, 12:51 AM
  #5  
Rotary Enthusiast
 
10sec rx7's Avatar
 
Join Date: Mar 2001
Location: Sydney, Australia
Posts: 1,307
Likes: 0
Received 0 Likes on 0 Posts
sounds like it is a tuning problem, not the ecu,

what ecu is it?? MT8??

Dale
10sec rx7 is offline  
Old 09-29-03, 05:33 AM
  #6  
Full Member
5 Year Member
Thread Starter
 
Join Date: Mar 2003
Location: Singapore
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
Hi Dale,

Yes. Mine is a MT-8. I have 2 rx7's now. One is a first gen with 8injectors, mild port, Hybrid [email protected], 2mm Hurley race seals and MT-8. The MT-8 for this car acts rather weird too, if the load is brought down lower, it feels like the engine is running on one rotor, and I have change the seals for this car 2 times in a month. This car is fully strip and used only for the drag race. But the FC is more for my daily use, but due to the problems stated, it feels rather difficult to drive. Do you have anyone to recommend, that can tune both my cars? We have a rather low count of rotary fanatics over here. But ever since the launch of the Rx8, we are about to see a huge jump. So pls help.

Thanks,
Francis
seven is offline  
Old 09-29-03, 05:38 PM
  #7  
Rotary Enthusiast
 
10sec rx7's Avatar
 
Join Date: Mar 2001
Location: Sydney, Australia
Posts: 1,307
Likes: 0
Received 0 Likes on 0 Posts
hey mate,

it definatly sounds like tuning issues,

ill do some hunting around to find someone in singapore for you

Dale
10sec rx7 is offline  
Old 09-29-03, 07:08 PM
  #8  
Full Member
5 Year Member
Thread Starter
 
Join Date: Mar 2003
Location: Singapore
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
Hi Dale,

Really appreciate it, if you can provide me someone in Singapore that can provide help. Anyways, is there any courses that I can attend to learn on the tunning of the microtech? How much & how long will it take? And do you know of any reliable and good workshop in rotary that provides courses on modifications? I believe in Sydney, there should be Maztech right? Pls advise.

Thanks,
Francis
seven is offline  
Old 09-30-03, 06:36 PM
  #9  
Rotary Enthusiast
 
10sec rx7's Avatar
 
Join Date: Mar 2001
Location: Sydney, Australia
Posts: 1,307
Likes: 0
Received 0 Likes on 0 Posts
hey mate,

we are having no luck in singapore, we have trained dealers in Malasya tho, are they any use to you??.,

please contact Tim at Microtech Global, [email protected]
tell him i gave you his details, he will be able to work out some training for you .,

Dale
10sec rx7 is offline  
Old 10-09-03, 08:17 AM
  #10  
Rotary Freak
5 Year Member
 
SaabGuy's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA
Posts: 1,514
Likes: 0
Received 0 Likes on 0 Posts
Turn up the settings at idle, 500, 1000, and 1500 below 15 inches of vac and that should fix you. My car did the same thing;

and then I richened the 30, 25, 20, and 15 settings at 1000 and it did much better.

Make sure you log your setting changes.
SaabGuy is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dona1326cosprings7
1st Generation Specific (1979-1985)
4
10-29-15 06:47 AM
pfsantos
2nd Generation Specific (1986-1992)
1
09-30-15 01:29 PM


Thread Tools
Search this Thread
Quick Reply: Microtech Wat's wrong with my microtech?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: