Microtech Area is for discussing Microtech systems

Microtech rx8 people are dumb please help me!!!

Old 11-10-09, 02:21 AM
  #1  
Full Member
Thread Starter
 
Join Date: Nov 2009
Location: Terre Haute, Indiana
Posts: 52
Likes: 0
Received 0 Likes on 0 Posts
rx8 people are dumb please help me!!!

Hello everyone lol so I know your work is with the rx7 and I'm on the 7 site. It just seems people don't know what they are doing with the 8's. My first engine went after 40k with about 5k of boost at 10psi. The second motor which is covered only made it like 3k and I had it built and tuned at pettit racing. I climb into boost at like 13's and by 5psi I drop down between 10.9 and 11.1 afr. I thought it was my timing that's why I had them tune it. Now I'm lost so I'm going to people who have experience...people who are putting out real power on a 13b. Just wondering if you could tell me what my split should look like and where my timing should be from idle up. Last I was wondering are you running the ALS seals...is that what you recommend.

My rx8 rotors are machined to hold the rx7 seal
I do premix
drive it easy till warmed up
and it's never seen the track since the turbo
Microtech ECU

oh and since tuning is so important...is there a way to wire the knock sensor the the microtech so you could see what it's reading..or is there a way... Does the knock sensor just send a ground single like a temp sensor?
outinnowhere3193 is offline  
Old 11-10-09, 03:07 PM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
Yes run ALS seals.

No knock sensor for microtech. BUT YOU HAVE TO REMEMBER you have very high comp rotors.

Get your self a water injection kit, we do sell them you can pm me on details of that.

This will let you run your N/A rotors up to 18-19psi very safely.

If you want to keep those rotors. Keep it under 10psi and run around 4-5 degrees of timing and keep mixtures at 10.80-11.

If thats not working. Then you have a problem elsewere. Your plugs are too hot(Use Trust/NGK R7420-10.5)

Also your fuel system can be surging cause your using and intank fuel pump, which in that case, you want to put a surge tank and a 044 fuel pump.

You need to rule out your variables. It might be alot of money but you are spending your moeny as it is in the wrong place, building engines. Build one engine. Dont thrash it till you do the accessories correctly. Then tune it. And it will be rock solid reliable.
rx72c is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
zyph3r
Canadian Forum
10
09-16-18 07:14 PM
antman0408
2nd Generation Specific (1986-1992)
4
10-05-15 04:33 PM
Captain Hook
2nd Generation Specific (1986-1992)
13
10-04-15 06:35 PM


Thread Tools
Search this Thread
Quick Reply: Microtech rx8 people are dumb please help me!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: