Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Microtech
Reload this Page >

Microtech New motor running really lean,afraid 2 drive her 2 the dyno. Help please!

Microtech Area is for discussing Microtech systems

Microtech New motor running really lean,afraid 2 drive her 2 the dyno. Help please!

Old 11-14-10, 01:13 PM
  #1  
87 SE WITH S5 T2 SWAP
Thread Starter
iTrader: (11)
 
joeylyrech's Avatar
 
Join Date: May 2004
Location: allentown pa
Posts: 2,070
Likes: 0
Received 0 Likes on 0 Posts
PA New motor running really lean,afraid 2 drive her 2 the dyno. Help please!

Got another project running a couple of days ago but it looks like is running really lean and i am afraid 2 drive her 2 the dyno,i have used this map that was given to me several times in the past with good results(minor adjustment 2 get fuel on the spot)but it seems not 2 work on this particular motor,turbo combo.Looking at my wideband the motor goes lean right at -10,-05,0HG. have tried 2 adjust fuel but it looks like is not working.I have being driving the car in a perfectly flat street avoiding 2 put load on it but it just want to build boost and not responding to the changes on the microtech i am afraid 2 blow her up on the way 2 the dyno.Here are some specs on the combo.
Half Bridgeported S5 turbo Block(big port with notched housings)
Pinned and balanced
OEM internals
Custom SS divided manifold(long runners)
50MM HKS wastegate
Turbonetics T72 1.00 AR P trim divided housing T4 flange
FD upper intake and throttle body(secondaries butterflys removed and ported)
Aeromotive FPR
Parallel fuel system with with 680cc primaries and 1600 secondaries feed by a walbro pump.
LTS8 ECU

Here is the map that i used to start her up.
Idle Map
Screen 1

30" ~ 1.38
25" ~ 1.48
20" ~ 1.33
15" ~ 1.71
10" ~ 1.71
05" ~ 1.62
00" ~ 2.00
2-20psi ~ 4.95

Load Map
Screen 3

30" ~ 0.95
25" ~ 1.19
20" ~ 1.33
15" ~ 1.71
10" ~ 2.14
05" ~ 2.57
00" ~ 2.86
2psi ~ 2.2
4psi ~ 3.2
6psi ~ 3.8
8psi ~ 4.4
10psi ~ 4.9
14psi ~ 5.5
16psi ~ 5.9
18psi ~ 6.5
20psi ~ 7

RPMwot Map Screen 17

5000 ~ 05
5500 ~ 08
6000 ~ 08
6500 ~ 10
7000 ~ 11
7500 ~ 11
8000 ~ 11
9000 ~ 12

The rest are zero

RPMcrs Screen 18

1000 ~ -12
1500 ~ -11
2000 ~ -12

THe rest are zero



Pump Map
Screen 19

Pump2Start ~ 2000
Pump1Amt ~ 00
Pump1Pulse ~ 04
Pump1Trig ~ 18
Pump1Stop ~ 00
Pump1Adv ~ 05

Pump2Time ~ 10
Pump2Amt ~ 30
Pump2Trig ~ 16
Pump2Stop ~ 00
Pump2Adv ~ 05

PumpDwell ~ 3.00
PumpTimers ~ No
Pump1Sync ~ No
PumpSpare ~ 00
PumpCold ~ 00

Water Map
Screen 20

-25 ~ 0
-17 ~ 70
-9 ~ 60
-01 ~ 50
05 ~ 45
11 ~ 45
18 ~ 42
24 ~ 34
31 ~ 26
38 ~ 24
46 ~ 19
60 ~ 12
68 ~ 06
82 ~ 0
99 ~ 0
124 ~ 0

Air_t Map
Screen 21

-25 ~ 0
-17 ~ 8
-9 ~ 6
-1 ~ 5
5 ~ 4
11 ~ 3
18 ~ 3
24 ~ 0
31 ~ 0
38 ~ 0
46 ~ 0
60 ~ 0
68 ~ 0
82 ~ 0
99 ~ 0
124 ~ 0

Crank Map
Screen 22

-25 ~ 72
-17 ~ 72
-9 ~ 72
-1 ~ 67
5 ~ 62
11 ~ 57
18 ~ 50
24 ~ 41
31 ~ 31
38 ~ 26
46 ~ 20
60 ~ 15
68 ~ 5
82 ~ 0
99 ~ 0
124 ~ 0

t*rpm
Screen 23

Idle ~ 00
1000 ~ 10
1500 ~ 15
2000 ~ 20
2500 ~ 25
3000 ~ 25
3500 ~ 25
4000 ~ 25
4500 ~ 25
5000 ~ 25
5500 ~ 25
6000 ~ 25
6500 ~ 25
7000 ~ 25
7500 ~ ??
8000 ~ 25
9000 ~ 25

t*map Map
Screen 24

Idle ~ 00
25 ~ 05
20 ~ 04
15 ~ 03
10 ~ 02
05 ~ 00
00 ~ 00
2psi ~ 00
4psi ~ 00
6psi ~ 02
8psi ~ -04
10psi ~ -06
14psi ~ -10
16psi ~ -12
18 psi ~ -16
20 psi ~ -20

t*air Screen 25
Correction value Is expressed as number of degrees you wish to advance or Retard to the Ignition curve and values Is set at zero.

t*gap
Screen 26

0500 ~ 15
1000 ~ 15
1500 ~ 15
2000 ~ 14
2500 ~ 12
3000 ~ 10
3500 ~ 10
4000 ~ 10
4500 ~ 10
5000 ~ 10
5500 ~ 10
6000 ~ 10
6500 ~ 10
7000 ~ 10
8000 ~ 10

t*Inj Map
Screen 27

0500 ~ 120
1000 ~ 150
1500 ~ 150
2000 ~ 150
2500 ~ 150
3000 ~ 150
3500 ~ 150
4000 ~ 150
4500 ~ 180
5000 ~ 210
5500 ~ 210
6000 ~ 240
6500 ~ 240
7000 ~ 270
8000 ~ 270
9000 ~ 270

t*wat Map Screen 28


ANd the rest are zero

Option Map
Screen 30

Af_StE ~ 10
Dwell ~ 3.25 *set at Time Base - not at Duty Cycle*
REVstg ~ 1320
MAPstg ~ 02"
%stg ~ 50

Any help will be really appreciated!Thanks.
joeylyrech is offline  
Old 11-16-10, 01:06 AM
  #2  
talking head
5 Year Member
 
bumpstart's Avatar
 
Join Date: Apr 2008
Location: Perth, WA, OZ
Posts: 2,775
Likes: 0
Received 2 Likes on 2 Posts
for a cracker i dont think very much at all for that staging setup , as amounts to having an ECU that stages almost at any movement of throttle at revs just over idle
and thus defeats the original intention of staged sequential ignition

anything that is running 1600 as secondaries with 550- 800 primaries should have the staging % value in the 90-99% range to ensure when staging and unstaging there is no lean glitch

its all there in black and white as a sticky above this post " how injector staging works"

changing your staging value to the map as is will radically increase fuel UP TO the stage threshold
( and the total volumes of fuel after the stage point will be the same and true to the look up table )

i think you need to push staging % to 95 and then make the staging thresholds around 2 psi and 2500 rpms
( then it will require a juggle to fine tune it for threshold and value slightly when the main maps are nearly correct off the dyno )
bumpstart is offline  
Old 11-16-10, 06:25 AM
  #3  
87 SE WITH S5 T2 SWAP
Thread Starter
iTrader: (11)
 
joeylyrech's Avatar
 
Join Date: May 2004
Location: allentown pa
Posts: 2,070
Likes: 0
Received 0 Likes on 0 Posts
Thanks Bumpstar!I am gonna give it a try.
joeylyrech is offline  
Old 11-18-10, 04:53 PM
  #4  
Full Member
5 Year Member
 
Join Date: Apr 2005
Location: nz
Posts: 115
Likes: 0
Received 0 Likes on 0 Posts
tps not working properly?
mattmarrx3 is offline  
Old 11-20-10, 02:34 PM
  #5  
87 SE WITH S5 T2 SWAP
Thread Starter
iTrader: (11)
 
joeylyrech's Avatar
 
Join Date: May 2004
Location: allentown pa
Posts: 2,070
Likes: 0
Received 0 Likes on 0 Posts
TPS is working fine(FD TPS)
I did tried bumpstar idea and it did not work.
Injectors were service prior to install(primaries)secondaries are brand new.
Fuel pump is working fine and my AEROMOTIVE REG is holding pressure.
Every connection was soldered and wrapped.
No ecu codes.Car starts right up,idles perfect,revs fine in neutral and thats about it.
Any other ideas?
joeylyrech is offline  
Old 11-21-10, 07:52 AM
  #6  
Full Member
5 Year Member
 
zeaone's Avatar
 
Join Date: Apr 2007
Location: miami
Posts: 181
Likes: 0
Received 0 Likes on 0 Posts
It sounds like your secondary's are clogged also zero out your RPRcrs until you figure this out . What fuel?
zeaone is offline  
Old 11-21-10, 12:01 PM
  #7  
87 SE WITH S5 T2 SWAP
Thread Starter
iTrader: (11)
 
joeylyrech's Avatar
 
Join Date: May 2004
Location: allentown pa
Posts: 2,070
Likes: 0
Received 0 Likes on 0 Posts
PA one more try

Originally Posted by zeaone View Post
It sounds like your secondary's are clogged also zero out your RPRcrs until you figure this out . What fuel?
I am using pump gas,93 oct.
I was told to check the secondaries injectors to see if they were clogged so i am taking 2 1600cc injectors of my other car(i know that they are working fine)and using them on this motor,then i am gonna give bumpstar idea another try.If this one set of injectors is in good shape changing the stage to 95 will make the car super rich so then i have to take around 40% off fuel of the entire map,fix the staging area and redo my idle map,correct?
joeylyrech is offline  
Old 11-21-10, 06:03 PM
  #8  
talking head
5 Year Member
 
bumpstart's Avatar
 
Join Date: Apr 2008
Location: Perth, WA, OZ
Posts: 2,775
Likes: 0
Received 2 Likes on 2 Posts
Originally Posted by joeylyrech View Post
I am using pump gas,93 oct.
I was told to check the secondaries injectors to see if they were clogged so i am taking 2 1600cc injectors of my other car(i know that they are working fine)and using them on this motor,then i am gonna give bumpstar idea another try.If this one set of injectors is in good shape changing the stage to 95 will make the car super rich so then i have to take around 40% off fuel of the entire map,fix the staging area and redo my idle map,correct?
playing the split % up and down will not effect mixtures AFTER staging
after staging the look up tables ( and sundary corrections ) are produced at all 4 injectors
so the ECU wouldnt care less if you have 50 or 90 %
it is ignoring the staging value when beyond the threshold trigger points
and so will still add the same mixture post staging

the difference is PRE staging
ones with 50%,, and a look up table value of 1ms ,, and below the staging thresholds
will be outputing 1.5 ms ( 1 + 50 % ) to the two primary injectors only


ones with 90%,, will be adding 1.9 m ms


demonstrating that playing the staging split % ONLY effects the low down prestaging maps
and so fiddling it does NOT require a full load tune again
MIXTURES AT HIGH LOAD HAVE NOT CHANGED

the low load numbers pre staging will need to be fiddled again
to make the map work,, this time hopefully without the momentary lean glitches and sneezes at the staging point


if i read what you wrote,, i surmise you currently have 40% mixture trim on to keep the low down mixtures at a running level
( and when post staged the normally nearly right map will be 40% too much )
thats a huge hint that currently 50% split + ( 40% mix trim )
is the equivilent to a 90 % split value while unstaged

and hence,, you have already found out for yourself how much low down trim you need,, just didnt put it into the correct correction map
it needs to be in the staging %,, and not mix trim
bumpstart is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trickster
2nd Generation Specific (1986-1992)
20
03-29-18 02:05 PM
ChrisRX8PR
Single Turbo RX-7's
18
08-21-15 01:56 PM
smikels
2nd Generation Specific (1986-1992)
3
08-18-15 01:26 PM


Thread Tools
Search this Thread
Quick Reply: Microtech New motor running really lean,afraid 2 drive her 2 the dyno. Help please!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: