Microtech Area is for discussing Microtech systems

Microtech need some help tuning

Old 07-14-07, 05:45 PM
  #1  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
need some help tuning

my cruising afrs are 10 i know thats way too rich but my real concern is tuning on boost im on 10 psi and it starts to lean out at 5000 rpm my injectors are at 6.6ms does that sound right? i have 4x800cc injectors.
a_reyes1014 is offline  
Old 07-14-07, 10:39 PM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
lean your cruise afrs back to around 13-14.

What setup have you got? turbo, fuel pump, engine etc then i can tell you more.
it sounds to me like your fuel pump isnt keeping up.
rx72c is offline  
Old 07-15-07, 06:39 AM
  #3  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
i have t60 turbo with a 1.15 turbine housing,4x800 injectors,walbro 255 fuel pump,decent size street port,voltage stay at 13.5 with everything on,water injection that helps a lot and no intercooler, thats pretty much it for the engine
a_reyes1014 is offline  
Old 07-15-07, 08:03 PM
  #4  
Junior Member
 
butcheryboy's Avatar
 
Join Date: Mar 2007
Location: New Zealand
Posts: 43
Likes: 0
Received 0 Likes on 0 Posts
R u sure ur actually leaning out?, cos if ur way too rich the AFR will spike lean for a second, it feels the same as leaning out, just that the car will "bog more gradually"

You could be actually flooding ur engine instead of leaning out, 4x800cc injectors will be getting u lots of fuel especially at 6ms of injector opening time,

As he said ^,

1. lean out ur cruzing AFR'S,
2. Be sure that ur actually leaning out @ 10psi
3. Check that your secondary injectors are staged properly and are acutally working

how does your car cruise with AFR's in the 10s? i only have high 10's @ 20psi and thats still rich.
butcheryboy is offline  
Old 07-15-07, 10:15 PM
  #5  
Senior Member
5 Year Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2005
Location: chicago
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
it sounds about right when at cruise it drives ok but a little lazy. also what are the egts for cruise normally supposed to be at. mine in 5th gear cruising was 1100deg.F. sorry for the noobie questions this is my first turbo setup.
a_reyes1014 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Logan Reinisch
General Rotary Tech Support
44
09-17-18 12:20 PM
Andrew7dg
1st Generation Specific (1979-1985)
3
08-06-17 01:41 PM
demetlaw
3rd Generation Specific (1993-2002)
6
10-02-15 06:22 PM
93FD510
New Member RX-7 Technical
2
10-01-15 02:00 PM


Thread Tools
Search this Thread
Quick Reply: Microtech need some help tuning


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: