Microtech Area is for discussing Microtech systems

LTX-12 Microtech 20B help

Old 05-20-16, 02:47 PM
  #1  
Rotary Enthusiast
Thread Starter
 
Join Date: Aug 2008
Location: Portsmouth UK
Posts: 1,101
Received 13 Likes on 13 Posts
LTX-12 Microtech 20B help

So, today was the big day. My first trip down to the dyno to get a base map setting one low boost. After running into some issues with wastegate control having being sold a completely wrong spring we were able to really run in anger but got some half reasonable load runs done up to about 6k with around 7-8psi boost. Mostly the map so far seems pretty smooth and the car runs quite nice. However I have noticed a couple of things I am hoping I can get some help with solving.
First of all idle.. after cold start being super rich and taking out some fuel and compensation my tuner can get it to idle nicely warm. However it seems to sit idling for a couple of minutes and then just dye like someone turned of the ignition. I presume it is dropping into some other section of map causing this but don't know what? Either that or could it maybe cooling a couple of degrees in this time and dropping into a different water temp compensation area that is not yet tweaked and too rich or lean?Currently the idle valve is disconnected as when we plugged it in it seems to open and stay that way so the rpm was too high. Plan it to find out what is wrong with that and run it for a bit better stability on idle. Want to try and get the idle working nicely without first so the valve is just there for backup.

The other issue that I didn't like and we ran out of time with due to the boost issue was when you lift off after a load run there is a thick black puff of smoke from the exhaust for a second. This then turns mid grey but pretty thick and plumes from the exhaust pretty much until the revs have dropped right back down to idle. then it idles quite clean again? Is this a decelleration enrichment gone crazy or something? I am running premix and 1680 injectors all round for a bit of info. Strange that it predominently seems okay under load other than a few rich spots where you get a dark puff of exhaust. Also I should not it didn't breath at all during the runs and I gather this is something that 20B's are also quite good at!
Would be great if I can get some pointers or which screens I need to post for further help.

Cheers
Lee
Leeroy_25 is offline  
Old 05-20-16, 07:51 PM
  #2  
Rotary Enthusiast
iTrader: (1)
 
Join Date: Dec 2006
Location: east
Posts: 927
Received 5 Likes on 4 Posts
need more data. like what was AFR before it died. also I would make sure there is no big leak anywhere by spraying some brake cleaner all around the manifold while the engine is running to see whether that can affect the idle. vacuum leak and faulty tps sensor can do many weird things. when it dies, you need to be looking at the microtech screen. make sure the tps is still at 0%, watch afr, etc.

I don't know what's going on with smoke. I wouldn't worry too much about smoke until you go through heatcycle a few times. new exhaust/wrap etc. can smoke initially. also make sure your turbo doesn't have oil leak by looking at the compressor side. good luck.
stickmantijuana is offline  
Old 05-21-16, 04:07 AM
  #3  
Rotary Enthusiast
Thread Starter
 
Join Date: Aug 2008
Location: Portsmouth UK
Posts: 1,101
Received 13 Likes on 13 Posts
Thanks for the reply.. Chees for the pointer. Cannot remember AFR's off hand. But I think idle was around 11.2 and I think it starts to climb before dying but didn't really get to check that. I was going to get a smoke machine and check the inlet side anyway. To check there are no leaks. So will make sure I rule that out.
Turbo is brand new and I am pretty confident it is not oil smoke too grey. Runner thought the black puff could be crap off the rotors on lift off? Wondering if the grey could be fuel and rubbish burning up in the exhaust still. Would have expected it to clear pretty. Soon though.that said we only had about 4 big pulls. I had an injector stick open before I got it all running and it filled up the engine and exhaust with fuel. Maybe ot is that burning up in the silencer still? It look like smoke from a bonfire?!

Will see if anyone else has thoughts on that or have to wait until I get back to the dyno.


If I get a chance I will run it up and see if I can get some more info for the idle stall issue.
Leeroy_25 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Joshowen
General Rotary Tech Support
22
04-05-16 09:30 PM
David Galloway
3rd Generation Specific (1993-2002)
4
03-24-16 01:43 PM
wstrohm
3rd Generation Specific (1993-2002)
17
03-20-16 11:31 AM
corsa1
New Member RX-7 Technical
4
03-18-16 11:12 AM
CharlieBronson
Drifting
0
03-17-16 07:23 PM


Thread Tools
Search this Thread
Quick Reply: LTX-12 Microtech 20B help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: