Microtech Area is for discussing Microtech systems

LT8 s5 harness

Old 07-08-14, 11:59 AM
  #1  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
LT8 s5 harness

So i have a couple questions,

first of just acquired a 87 fc3s with a 90fc3s motor so a s5, its running a LT8 standalone. now im unfamiliar with microtechs and lt8s so im not sure what they can do is it a good standalone, should i sell it, what is it worth with a harness, car does run so they did something right with it haha, umm so yea any help is appreciated! thanks!
dillrx7 is offline  
Old 07-12-14, 10:39 AM
  #2  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
The LT8s is not a good standalone by today's standards. It's antiquated in every way. Frankly this has been true since it was produced.

That said, if the car is running well on the Microtech, then there's no reason to change it unless you need the ECU to so something the old Microtech can't.
Aaron Cake is offline  
Old 07-13-14, 05:02 PM
  #3  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Aaron Cake View Post
The LT8s is not a good standalone by today's standards. It's antiquated in every way. Frankly this has been true since it was produced. That said, if the car is running well on the Microtech, then there's no reason to change it unless you need the ECU to so something the old Microtech can't.

It came in a parts car and my car is running the t2 ecu with fic piggy back, so was wondering about swapping it over and going full standalone to lose the maf and get more adjustability.
dillrx7 is offline  
Old 07-14-14, 11:24 AM
  #4  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
It's coming out of a t2 street port running 550/1000 inj and stock s5 turbo, so I will do s4 n/a keg hybrid turbo with those injectors and should run decent
dillrx7 is offline  
Old 07-16-14, 12:05 PM
  #5  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
so after wiring it in, the thing started and idled... then today trying to start it no go, the injectors where leaking so i took care of that, but still nothing ive went threw the "base map" in the archives but nothing i just am so lost on how the tuning works with this ecu so far but im playng with it to try to get it to start but nothing so far.
dillrx7 is offline  
Old 07-16-14, 06:14 PM
  #6  
Full Member
 
Join Date: Mar 2013
Location: Western Australia
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
https://www.rx7club.com/microtech-11...highlight=1000
use the map by bumpstart. ive used it for a few years and its a good safe map
rx3sum is offline  
Old 07-16-14, 08:24 PM
  #7  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by rx3sum View Post
https://www.rx7club.com/microtech-11...highlight=1000 use the map by bumpstart. ive used it for a few years and its a good safe map
. Thanks!
dillrx7 is offline  
Old 07-16-14, 10:33 PM
  #8  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
It stumbles once it starts and goes flat , and then takes a bit to get it to do that, we arnt certain we have the timing right the pulley is 28 years old.. And all the marks are gone so we are gojng out on what we think are the marks
dillrx7 is offline  
Old 07-16-14, 10:56 PM
  #9  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
all good now, just a throttle adjustment needed to get it to idle! oops didnt see the time i got a grumpy someone from my basement telling me its 11:30 oh well! call it a night thanks!
dillrx7 is offline  
Old 07-17-14, 01:44 PM
  #10  
Senior Member
Thread Starter
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 558
Likes: 0
Received 0 Likes on 0 Posts
Any reason why the microtech would read the wrong rpm? it reads a ridiculous 3000 idle and will rev to 8000 with the just a slip of the throttle
dillrx7 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
scissorhands
New Member RX-7 Technical
0
09-16-15 01:25 PM


Thread Tools
Search this Thread
Quick Reply: LT8 s5 harness


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: