Microtech Area is for discussing Microtech systems

Microtech lt10s x4 firing

Old 05-29-10, 08:09 AM
  #1  
FD Project
Thread Starter
iTrader: (58)
 
BLACK MAMBA's Avatar
 
Join Date: Apr 2009
Location: Palm Beach, FL
Posts: 2,353
Likes: 0
Received 1 Like on 1 Post
FL lt10s x4 firing

ok guys have couple questions, i did a self test on the ecu and it shows that all 4 coils are firing and all 4 injectors are also firing,

Is it posssible for the 4 coils to fire if the x4 box was bad?

also after the self test the red light remains flashing does that means there is a problem.

the problem im having is that the car wont rev like it was before and its starts like breaking up around 3000 rpm, also every time i pulled the spark plugs the plugs are very black mainly the L1 and T1. i swaped the msd coils for 4 trailing coils and still the same.

really getting upset over this issue, car was running fine and the 1 day after getting it tuned it started with this issue.
BLACK MAMBA is offline  
Old 05-30-10, 03:38 AM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
Check your fuel pressure? id say thats your problem. Either bad reg or fuel pump
rx72c is offline  
Old 05-30-10, 07:42 AM
  #3  
Senior Member
5 Year Member
iTrader: (11)
 
drifting in drifting's Avatar
 
Join Date: Feb 2008
Location: drifting .pa
Posts: 368
Likes: 0
Received 0 Likes on 0 Posts
Kinda sounds like a voltage issue
drifting in drifting is offline  
Old 05-30-10, 08:20 AM
  #4  
FD Project
Thread Starter
iTrader: (58)
 
BLACK MAMBA's Avatar
 
Join Date: Apr 2009
Location: Palm Beach, FL
Posts: 2,353
Likes: 0
Received 1 Like on 1 Post
it was a faulty injector on front rotor, i guess it was stuck open or its leaking,
BLACK MAMBA is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Aramir
New Member RX-7 Technical
24
10-18-15 02:39 AM
LongDuck
1st Generation Specific (1979-1985)
12
10-07-15 08:12 PM
ls1swap
3rd Generation Specific (1993-2002)
12
10-01-15 07:58 PM
baix2
Power FC Forum
1
09-28-15 09:40 AM


Thread Tools
Search this Thread
Quick Reply: Microtech lt10s x4 firing


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: