Microtech Area is for discussing Microtech systems

Microtech Constant spark with Lt8s

Old 07-17-10, 07:58 PM
  #1  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
Constant spark with Lt8s

Ok bought a used LT-8s off the forum for a FD (i have a fd as well). I didn't get it with a wire harness or plug and play adapter. I had a wire harness from another lt8x i have (from a FC). So i wire it using the stock tralingcoils and FC leading coil, by running both leading outputs to the FC Leading coil on the -ve terminal. Run the +ve termianl on the coil to the battery. There are no igniters or amp boxes in the system currently. I have an msd 6a lying around and I also got a jacobs in a bundle with LT-8s and it have all the coil clips already on it including the connection back the stock setup (that plug with 4 tips and is yellow on the inside).

So i plug up the harness straight to coils and try to start and it wont. From there was power going the ecu i heard a ticking in the engine bay. The green light is on the ecu even if there is no ignition power to it. The yellow light stays on and blinks slowly when cranking. When i pulled the leading plug wire and put a spark plug in it... its constantly firing with the car not being turned over. When you turn it over it stops sparking during the crank and goes back to constant when you stop. The trailing plugs are not firing during being off or during cranking. What could be the problem??

Things to note..I have all the grounds (coil harness, and the 2 brown wires) at the same location. Thanks
BluRR is offline  
Old 07-18-10, 10:26 AM
  #2  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,674
Likes: 0
Received 24 Likes on 23 Posts
The ECU may be in test mode. Check that Config in screen 31 is not set to 0.
Aaron Cake is offline  
Old 07-18-10, 02:01 PM
  #3  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
Its not.. its just the spark leading plugs.. When i put in test mode the injectors, etc start clicking away too. How do you normally wire up a Lt-8s with stock coils? Do you the wires straight from the ecu to the coils or you have to use and ignitor or something?
BluRR is offline  
Old 07-18-10, 04:18 PM
  #4  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
are you getting a flashing orange light on crank ?
rx72c is offline  
Old 07-18-10, 11:07 PM
  #5  
Senior Member
Thread Starter
iTrader: (1)
 
BluRR's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Posts: 462
Likes: 0
Received 0 Likes on 0 Posts
Yes I am getting the yellow light during crank. But i still at time still get a red light with RPM and Ref error msg.
I have a pair of ls2 coils with igniters in them and when i wired it up today it only sparked when it got the signal to.
Spoke to the previous owner of the unit and he said he got the car with it and it was wired with the mircotech wiring harness and factory igniter then through the jacobs unit.

1) How do i wire the factory igniter into the system so i can run the factory coils?

2)And i think my CAS is messed up. Between the splices i made to the harness and at a next point i made in the line when i had first cut them. Also one the wire are loose in the plug but its kinda stuffed in there. I did the foil thing but i dont know it has resolved that part of the sheathing issue

3)The ECU says Maz b2.0. Is that the right version for the FD?
BluRR is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Prediict
2nd Generation Specific (1986-1992)
32
11-18-15 08:41 AM
Aramir
New Member RX-7 Technical
24
10-18-15 02:39 AM
WyomingTII
2nd Generation Specific (1986-1992)
12
09-28-15 10:32 AM


Thread Tools
Search this Thread
Quick Reply: Microtech Constant spark with Lt8s


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: