General Rotary Tech Support Use this forum for tech questions not specific to a certain model year

FD RX7 weird idle?

Old 03-27-19, 03:54 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2016
Location: Los Angeles
Posts: 22
Likes: 0
Received 0 Likes on 0 Posts
FD RX7 weird idle?

I recently bought a 1992 Efini RX-7 FD3S Type R and have no previous history on the vehicle. Has 71k miles and compression tested and she's still healthy. Whenever shes idling, she misfires and you can clearly hear it in the exhaust. The mods on the car are HKS dual intake, Blitz BOV, Autometer Boost Gauge, and Trust Exhaust. Since I've had her, I've changed all the fluids, cleaned the throttle body and the sensors and spark plugs and spark plug wires. She also idles a bit high too, around 1200-1300 when cold start and even stays at that when stopped at a red light and warmed up. Sometimes drops down to 800. She runs and drives fine, just an annoying misfire at idle. Vacuum at 18inHg and oil pressure when warm is around 1.5-2 kg/cm2. Could it be a small vacuum leak or something like that? Any advice would help. Thanks.
MiniRotary is offline  
Old 03-27-19, 04:19 PM
  #2  
half ass 2 or whole ass 1
iTrader: (110)
 
cr-rex's Avatar
 
Join Date: Nov 2011
Location: okinawa to tampa
Posts: 1,971
Received 63 Likes on 58 Posts
likely a small vacuum leak, yes. check to see if its the stock ecu. if it is, then it may help to clean or replace the o2 sensor as well.
cr-rex is offline  
Old 03-27-19, 04:25 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Dec 2016
Location: Los Angeles
Posts: 22
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by cr-rex View Post
likely a small vacuum leak, yes. check to see if its the stock ecu. if it is, then it may help to clean or replace the o2 sensor as well.
It's the stock ECU. I'll go out and buy a new O2 and see if that changes anything. I know the motor was pulled at one point because the body is factory red but the engine bay has been professionally painted gloss black. Maybe it was rebuilt, maybe it wasnt.
MiniRotary is offline  
Old 03-27-19, 05:14 PM
  #4  
half ass 2 or whole ass 1
iTrader: (110)
 
cr-rex's Avatar
 
Join Date: Nov 2011
Location: okinawa to tampa
Posts: 1,971
Received 63 Likes on 58 Posts
i would bet its just a small vacuum leak somewhere honestly... the o2 sensor may or may not doing anything. i only suggest it because the stock ecu is sensitive and dramatic when anything is out of parameters.
cr-rex is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ported13b
3rd Generation Specific (1993-2002)
9
09-21-05 02:55 PM
faye x7
1st Generation Specific (1979-1985)
18
08-04-04 06:46 PM
bubba211
1st Generation Specific (1979-1985)
2
04-21-04 07:23 PM
ColumbusTurboTwo
2nd Generation Specific (1986-1992)
2
09-13-02 04:58 AM


Thread Tools
Search this Thread
Quick Reply: FD RX7 weird idle?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: