2nd gen vert hasn't run in two years - RX7Club.com - Mazda RX7 Forum

2nd Gen General Discussion The place for non-technical discussion about 2nd Gen RX-7s or if there's no better place for your topic
Sponsored by:

2nd gen vert hasn't run in two years

Reply

 
 
 
Old 10-13-18, 11:45 AM
  #1  
Junior Member
Thread Starter
 
2genvert.duck's Avatar
 
Join Date: Dec 2013
Location: Seattle
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
2nd gen vert hasn't run in two years

Pulled battery - topped it off with distilled water and have recharged it.

Don't trust the gas. IIRC, the last time I brought it back from the dead there is a drain plug on the fuel tank. Correct?

Picking up a new fuel filter later this morning.

Once I have the tank drained, can I disconnect the fuel system somewhere and have it pump out the old fuel in the fuel lines?

Any other pointers?
2genvert.duck is offline  
Reply With Quote
Old 10-13-18, 12:02 PM
  #2  
Junior Member
Thread Starter
 
2genvert.duck's Avatar
 
Join Date: Dec 2013
Location: Seattle
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Would it be bad to just try starting it on the old gas without draining the fuel system or could that mess things up?

I absolutely have to have it running by Monday because it is parked in a spot in front of my house where they need to do some digging on Monday for some utility work.
2genvert.duck is offline  
Reply With Quote
Old 10-14-18, 08:37 PM
  #3  
Junior Member
Thread Starter
 
2genvert.duck's Avatar
 
Join Date: Dec 2013
Location: Seattle
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Well, case closed.

Once I hooked up the battery, I turned it on to see how much gas was in it. The needle didn't budge so I thought I might have lucked out on that front. Nope. I pulled the drain plug and ended up draining about eight gallons of old gas. The gas gauge was working when parked so I'll have to troubleshoot that now.

I'd forgotten what a PITA is is to replace the fuel filter but while I had the fuel filter off I turned it over a few times to run the fuel pump to get the old gas out of the fuel lines before installing the new fuel filter.

After that it fired right up!
2genvert.duck is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SteffanRX7
New Member RX-7 Technical
12
10-21-15 09:20 AM
omg_miiiike
New Member RX-7 Technical
3
08-03-15 04:44 PM
ACSRX7
3rd Generation Specific (1993-2002)
3
03-05-13 09:37 PM
simplyjessi
2nd Generation Specific (1986-1992)
7
03-31-11 10:43 AM
JTP_86_rx-7
New Member RX-7 Technical
3
08-10-10 10:44 PM


Thread Tools
Search this Thread
Quick Reply: 2nd gen vert hasn't run in two years


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: