RX7Club.com


Go Back   RX7Club.com > Generation Specific > 3rd Generation Specific (1993-2002)
Register Forgot Password?
Register Photos FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryUsed Cars Garage
Welcome to RX7Club.com

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 03-25-08, 05:08 PM   #1
the one and only
5 Year Member
 
axnjaksn's Avatar
 
Trader Score: (2)

Join Date: Jan 2007
Location: socal
Posts: 261
Still losing coolant, no idea where??!!!

Allright i'm still losing coolant and I haven't the slightest idea where, holds 20 psi at the cap, runs fine, no white smoke at all, no visual leaks under the hood or car, holds fluid with the plugs out, is it an airbubble somewhere taking forever to find or what???????????
axnjaksn is offline   Reply With Quote
Old 03-25-08, 05:11 PM   #2
fadedvr=pink
5 Year Member
 
pinkrx7's Avatar
 
Trader Score: (2)

Join Date: Nov 2005
Location: Sacramento,CA
Posts: 1,402
Send a message via AIM to pinkrx7 Send a message via Yahoo to pinkrx7
you sure your ast isn't leaking at the cap?
__________________
1998 Integra GSR
1993 FD3S (http://www.rx7club.com/vbgarage.php?do=view&id=77601)
1993 Civic hatch (recently restored)
1969 Camaro (85%ish restored)
http://i34.tinypic.com/t8qgxs.jpg
pinkrx7 is offline   Reply With Quote
Old 03-25-08, 05:40 PM   #3
sleeper
 
4CN A1R's Avatar
 
Trader Score: (6)

Join Date: Oct 2007
Location: Abbottstown, PA
Posts: 1,957
whats determining your losing coolant?
__________________
how i fund my fd:
http://www.neobux.com/?r=adamintegra
4CN A1R is offline   Reply With Quote
Old 03-25-08, 07:35 PM   #4
fadedvr=pink
5 Year Member
 
pinkrx7's Avatar
 
Trader Score: (2)

Join Date: Nov 2005
Location: Sacramento,CA
Posts: 1,402
Send a message via AIM to pinkrx7 Send a message via Yahoo to pinkrx7
prolly the fact that e takes of the coolant cap and its not at the top
__________________
1998 Integra GSR
1993 FD3S (http://www.rx7club.com/vbgarage.php?do=view&id=77601)
1993 Civic hatch (recently restored)
1969 Camaro (85%ish restored)
http://i34.tinypic.com/t8qgxs.jpg
pinkrx7 is offline   Reply With Quote
Old 03-25-08, 09:58 PM   #5
I luv my carbon footprint
10 Year Member
 
mgoddard1's Avatar
 
Trader Score: (0)

Join Date: Mar 2002
Location: Indianapolis
Posts: 452
When you check the level in the overflow tank when the engine is cold is it consistent or is it dropping as well? If you take the filler cap off when the engine is cold the coolant level will drop due to the suction caused by the cooling system pulling coolant back in from the overflow tank when the engine cools down.
__________________



mgoddard1 is offline   Reply With Quote
Old 03-25-08, 10:33 PM   #6
needs more track time
 
gracer7-rx7's Avatar
 
Trader Score: (13)

Join Date: Mar 2006
Location: Bay Area CA
Posts: 7,374
Remember that water/coolant expands and contracts when heated or cooled.
gracer7-rx7 is offline   Reply With Quote
Old 03-26-08, 12:36 AM   #7
the one and only
5 Year Member
 
axnjaksn's Avatar
 
Trader Score: (2)

Join Date: Jan 2007
Location: socal
Posts: 261
Ima keep an eye on it tomorrow, but I may just be freaking out and not loosing any coolant, cars has been getting warm and I just re-wired my stock fans to get maximum voltage and I think that may solve my hot issue and stop me from popping the cap all the time!!!
axnjaksn is offline   Reply With Quote
Old 03-26-08, 05:35 AM   #8
sleeper
 
4CN A1R's Avatar
 
Trader Score: (6)

Join Date: Oct 2007
Location: Abbottstown, PA
Posts: 1,957
have you flushed the coolant system lately?
__________________
how i fund my fd:
http://www.neobux.com/?r=adamintegra
4CN A1R is offline   Reply With Quote
Old 03-26-08, 08:32 AM   #9
No Sleep, No Food
10 Year Member
 
mrb63083's Avatar
 
Trader Score: (4)

Join Date: Feb 2002
Location: North Dallas
Posts: 5,733
Also... do you have the factory AST?
mrb63083 is offline   Reply With Quote
Old 03-26-08, 08:32 AM
RX7Club
Mazda RX7




Paid Advertisement


 
 
 
Reply

Tags
93, antifreeze, civic, coolant, fd3s, hatch, integra, loosing, losing, rs, rx7, smoking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing coolant... Can't find the source... May be coolant seal problem. Schmitty 2nd Generation Specific (1986-1992) 6 12-12-06 01:08 PM
losing coolant. AST? mr.veilsidewankel 3rd Generation Specific (1993-2002) 7 06-20-06 02:37 PM
losing coolant on my tII zoomzoomsecondgen 2nd Generation Specific (1986-1992) 8 12-13-02 11:06 AM
losing coolant through oil whitekingsnake 3rd Generation Specific (1993-2002) 4 02-06-02 07:39 AM
Losing coolant? speckamp 1st Generation Specific (1979-1985) 6 08-08-01 01:19 AM


All times are GMT -5. The time now is 04:26 AM.
All content Copyright 2007 by Internet Brands, Inc.

Contacts

SEO by vBSEO ©2010, Crawlability, Inc.