Powersteering issues v8/krc pump

Old 06-29-14, 12:10 PM
  #1  
Senior Member
5 Year Member
Thread Starter
iTrader: (3)
 
10thslydur's Avatar
 
Join Date: Nov 2007
Location: In the paint booth
Posts: 660
Likes: 0
Received 0 Likes on 0 Posts
Powersteering issues v8/krc pump

hey guys I running a lt4 with a krc pump. I having major issues ive tried everything I can think of now im not even sure if I have the lines on correct. anyways ive blown the seal out of the top of the rack now twice and my wheel is jumping around violently still. bled the air and still the same thing. I have bought a restricting fitting like turn ones and still same issues. please help guys im going nuts and getting pretty frustrated
10thslydur is offline  
Old 06-30-14, 09:03 PM
  #2  
Sponsor
RX7Club Vendor
 
Ronin Speedworks's Avatar
 
Join Date: Aug 2012
Location: OC, CA
Posts: 127
Likes: 0
Received 0 Likes on 0 Posts
Sounds like the lines from quill to the rack are crossed. That'll set up a feedback loop where the wheel jumps back and forth. Track that down and be 100% sure you have it right before you do anything else.
__________________
v8 swap kits, 8.8" diffs, widebodies, wings, and more...

www.roninspeedworks.com
Ronin Speedworks is offline  
Old 06-30-14, 09:57 PM
  #3  
Senior Member
5 Year Member
Thread Starter
iTrader: (3)
 
10thslydur's Avatar
 
Join Date: Nov 2007
Location: In the paint booth
Posts: 660
Likes: 0
Received 0 Likes on 0 Posts
Thanks Joel I actually took a break for it this weekend and tracked that exact problem down tonight thanks for responding
10thslydur is offline  
Old 07-05-14, 08:34 PM
  #4  
Junior Member
10 Year Member
iTrader: (1)
 
Join Date: Dec 2003
Location: Wisconsin
Posts: 36
Likes: 0
Received 0 Likes on 0 Posts
Yeah, your lines at the rack are definitely backwards.
NeedToSellMyCar is offline  
Old 07-05-14, 08:52 PM
  #5  
Senior Member
5 Year Member
Thread Starter
iTrader: (3)
 
10thslydur's Avatar
 
Join Date: Nov 2007
Location: In the paint booth
Posts: 660
Likes: 0
Received 0 Likes on 0 Posts
Yea got it fixed up and working correctly thanks for the help guys
10thslydur is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Queppa
New Member RX-7 Technical
8
09-02-18 09:53 AM
Rotospectre
New Member RX-7 Technical
3
03-28-18 03:33 PM
stickmantijuana
Microtech
30
04-23-16 06:37 PM
2nd Generation Specific (1986-1992)
7
08-31-15 07:49 PM


Thread Tools
Search this Thread
Quick Reply: Powersteering issues v8/krc pump


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: