Time Slips and Dyno Section is for posting 1/4 mile time slips and dyno graphs

rx7 brothers...here's my first dyno!!

Old 05-22-06, 04:10 PM
  #1  
Full Member
10 Year Member
Thread Starter
 
rx_obsessed's Avatar
 
Join Date: Mar 2005
Location: Canada
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
rx7 brothers...here's my first dyno!!

street port
full exhaust
air intake
Haltech E6K
***stock twins...only one turbo comes online...for some reason when I bought the car, the wastegate of the rear turbo had been welded open..this dyno is without the second turbo and boost was a bone stock 10 lbs

I was quite happy with the numbers..what do you guys think??

Tuning done by Tuning Factory in Farmington Hills Mich (metro Detroit..)

Mark
Attached Thumbnails rx7 brothers...here's my first dyno!!-dyno_may06-009.jpg  
rx_obsessed is offline  
Old 05-22-06, 04:15 PM
  #2  
Full Member
10 Year Member
Thread Starter
 
rx_obsessed's Avatar
 
Join Date: Mar 2005
Location: Canada
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
oh yes please ignore the "flywheel power" title at the top...no idea why it said that..just an incorrect title....this was a chassis dyno....this is rwhp....i tried to include a pic from the tuning session, but the files are too big and I have no editing software right now...
rx_obsessed is offline  
Old 05-22-06, 04:17 PM
  #3  
development
10 Year Member
 
dubulup's Avatar
 
Join Date: Aug 2002
Location: Lafayette, LA
Posts: 5,714
Likes: 0
Received 2 Likes on 2 Posts
sounds like your twins are set-up non seq.

as in they are both spooling. There is no way a single tiny turbo can breathe all the way to 7k, or make that power.

nice numbers though...but it looks like your boost is creeping.
dubulup is offline  
Old 05-22-06, 04:39 PM
  #4  
***** "Nazi"...lol!
 
bajaman's Avatar
 
Join Date: Jul 2001
Location: near Wichita, Kansas
Posts: 4,958
Received 13 Likes on 13 Posts
This run was back in August of last year?
bajaman is offline  
Old 05-22-06, 04:42 PM
  #5  
Junior Member
5 Year Member
 
projectx605's Avatar
 
Join Date: Aug 2005
Location: Newport Beach
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
good numbers and welcome to 300 hp
projectx605 is offline  
Old 05-23-06, 12:55 AM
  #6  
Full Member
10 Year Member
Thread Starter
 
rx_obsessed's Avatar
 
Join Date: Mar 2005
Location: Canada
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
-no the test was done the other day....i think it says Aug somewhere maybe cause they opened a file for me....that's when the motor was built...

-my boost looks like it's creeping?
rx_obsessed is offline  
Old 05-23-06, 01:03 AM
  #7  
Full Member
10 Year Member
Thread Starter
 
rx_obsessed's Avatar
 
Join Date: Mar 2005
Location: Canada
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
yeah dub i won't argue with you about my turbos....this made no sense to me either...the vacuum system is definately set up like a ns setup....but what they told me is that the rear turbo isn't even working and needs rebuilding...there's an RX7 genuis at that shop, but sometimes a couple of the other guys don't seem to know as much as he does....

thanks for welcoming me to 300rwhp...cool...guys at the shop were like "congratulations" once we got the numbers..cool guys considering they see (and have) faster cars....I was pleased
rx_obsessed is offline  
Old 05-23-06, 01:06 AM
  #8  
Full Member
10 Year Member
Thread Starter
 
rx_obsessed's Avatar
 
Join Date: Mar 2005
Location: Canada
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
the pic...

just so everyone knows this is NOT flywheel hp, but rw...don't know why that title is on there....
Attached Thumbnails rx7 brothers...here's my first dyno!!-dyno_may06-004b.jpg  

Last edited by rx_obsessed; 05-23-06 at 01:09 AM.
rx_obsessed is offline  
Old 05-23-06, 03:59 AM
  #9  
Ferrari Red Hotness
10 Year Member
 
xblazinlv's Avatar
 
Join Date: Nov 2005
Location: Las Vegas
Posts: 966
Likes: 0
Received 0 Likes on 0 Posts
That's good HP at 10lbs. Good stuff
xblazinlv is offline  
Old 05-23-06, 10:22 PM
  #10  
Full Member
10 Year Member
Thread Starter
 
rx_obsessed's Avatar
 
Join Date: Mar 2005
Location: Canada
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
oh i should have mentioned too that my numbers were with pump gas....94 octane only.....shoulda ran race fuel huh?
rx_obsessed is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Th0m4s
Build Threads
25
02-26-19 02:04 AM
stickmantijuana
3rd Generation Specific (1993-2002)
5
01-11-16 04:08 PM
stickmantijuana
Single Turbo RX-7's
0
08-21-15 08:35 PM
Turblown
Single Turbo RX-7's
0
08-14-15 04:48 PM


Thread Tools
Search this Thread
Quick Reply: rx7 brothers...here's my first dyno!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.