Rtek Forum Discuss the Rtek 2.0 and other Rtek ECU's

Fuel Cut?

Old 06-16-14, 08:40 PM
  #1  
tmoon
5 Year Member
Thread Starter
 
tmoon's Avatar
 
Join Date: Sep 2006
Location: Staunton, VA
Posts: 55
Likes: 0
Received 0 Likes on 0 Posts
VA Fuel Cut?

Ok random problem started on sunday... for the past 2 years i have been running a 2.1 with 720 injectors and the stock turbo(wastegate has been ported) I had a custom intercooler setup, similar to the Isuzu NPR, and my coolant temps were getting to high for me on hot days. So, this past weekend I put the stock radiator and top mount intercooler back on until I come up with a new front mount setup. Now, whenever I drive it and boost around 10psi or above it feels like the car is "hitting a wall". While under full throttle the car will build boost and accelerate, but then cuts out...if i continue to hold the throttle down the car doesn't accelerate, build boost or anything. It will not change until I release the throttle all the way, then its fine again. The car didn't do this before this past weekend, and to me it sounds like the overboost fuel cut, which doesnt make any sense why the rtek would randomly start having a fuel cut......any ideas?
tmoon is offline  
Old 06-17-14, 11:27 AM
  #2  
Rotary Enthusiast
iTrader: (1)
 
Join Date: Jul 2003
Location: ..
Posts: 1,311
Likes: 0
Received 2 Likes on 2 Posts
Probably a boot leak in one of the fitting.
turbo2ltr is offline  
Old 06-17-14, 11:49 AM
  #3  
tmoon
5 Year Member
Thread Starter
 
tmoon's Avatar
 
Join Date: Sep 2006
Location: Staunton, VA
Posts: 55
Likes: 0
Received 0 Likes on 0 Posts
I have checked and everything seems tight, no leaks. Why would I have to release the throttle all the way for it to reset if it was a boost leak?
tmoon is offline  
Old 06-17-14, 03:26 PM
  #4  
Rotary Enthusiast
iTrader: (1)
 
Join Date: Jul 2003
Location: ..
Posts: 1,311
Likes: 0
Received 2 Likes on 2 Posts
Have you checked error codes? Still say its a boost leak of some sort. Might have to do a pressure test.
turbo2ltr is offline  
Old 06-17-14, 04:09 PM
  #5  
tmoon
5 Year Member
Thread Starter
 
tmoon's Avatar
 
Join Date: Sep 2006
Location: Staunton, VA
Posts: 55
Likes: 0
Received 0 Likes on 0 Posts
I did, there are no codes. I took some logs of it happening and the injector p/w drops before it loses boost, so i dont think its gonna be a boost leak, but it cant hurt to double check. Im out of town right now, when I get back home I'll pressure test it just to be sure there isn't a leak.
tmoon is offline  
Old 07-16-14, 03:17 PM
  #6  
Full Member
5 Year Member
 
shadowboym's Avatar
 
Join Date: Oct 2007
Location: ohio
Posts: 118
Likes: 0
Received 0 Likes on 0 Posts
too much fuel is your problem
shadowboym is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
alphawolff
1st Generation Specific (1979-1985)
17
11-17-15 05:57 PM
Snook
3rd Generation Specific (1993-2002)
21
09-01-15 06:32 PM
armans
3rd Generation Specific (1993-2002)
5
08-15-15 09:08 PM


Thread Tools
Search this Thread
Quick Reply: Fuel Cut?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: