Finally! Tuning your Rtek Ecu with a laptop(or desktop) - Page 3 - RX7Club.com - Mazda RX7 Forum



Rtek Forum Discuss the Rtek 2.0 and other Rtek ECU's

Finally! Tuning your Rtek Ecu with a laptop(or desktop)

Reply
 
 
Old 08-18-10, 07:55 PM
  #51
F**K CANCER
10 Year Member
iTrader: (3)
 
R.O.D's Avatar
 
Join Date: Sep 2004
Location: Ft. Riley KS
Posts: 1,007
i got the pose to sync once, now it always says interupted..
when i check out the log, it says to close programs such as palm desktop, and palmone quick install.
made sure they were closed with no change..

soo i guess until this is perfected, ima have to rock my palm T|X (that i found in my laundry lol)
R.O.D is offline  
Reply With Quote
Old 08-20-10, 09:33 AM
  #52
My job is to blow **** up
Thread Starter
iTrader: (8)
 
lastphaseofthis's Avatar
 
Join Date: Jan 2005
Location: palmyra Indiana
Posts: 2,865
i'm not sure of your setup exactly, but on my laptop with a SERIAL port built in, IT always syncs with the reliability of the palm. except when you view maps, that parts still being a thorn in my side.
lastphaseofthis is offline  
Reply With Quote
Old 08-28-10, 11:54 PM
  #53
Rotary Enthusiast
5 Year Member
iTrader: (17)
 
Join Date: Dec 2007
Location: Texas
Posts: 779
After waiting 13 days for my null modem cable to come in from China I get the package and inside is a freaking phone charger!!! So today I finally said screw it, when down to frys and bought the cable and was surprisingly cheap and like 10ft long lol. Anyway, after hooking the thing up to my dell d600 I was very impressed. It worked 1st try and didn't have to configure anything. Never dropped the connection unlike my tungsten t3. I can make adjustments to the timing and fuel maps just fine. The datalog function works perfectly although I have tried viewing the log from the software. I was able to export the logs and look at them in the plviewer though. All I can say is that this is a really great improvement over the pda!!! Now gotta get something so I can charge the laptop in the car, this old battery isn't cutting it lol.


For anyone interested I'm just using a dell d600 with windows xp via serial with the female to female db9 connector, and the Palm OS Cobalt 6.1 simulator.
hiroichi1515 is offline  
Reply With Quote
Old 10-04-10, 10:23 PM
  #54
Make It Happen!
5 Year Member
iTrader: (11)
 
AmT_T's Avatar
 
Join Date: Jun 2010
Location: Ontario, Canada
Posts: 510
any ideas if this will work on a mac? just need the right emulator for mac? It looks so much more pimp than a palm.
AmT_T is offline  
Reply With Quote
Old 12-21-10, 11:04 PM
  #55
Senior Member
iTrader: (1)
 
Chriz88DX's Avatar
 
Join Date: May 2007
Location: Georgia
Posts: 387
need help with the rom image could some one send me a rom my palm stopped charging and i thought i could just use this but i still need a rom

thank in advance
Chriz88DX is offline  
Reply With Quote
Old 12-29-10, 09:28 PM
  #56
Senior Member
iTrader: (1)
 
Chriz88DX's Avatar
 
Join Date: May 2007
Location: Georgia
Posts: 387
ok i got a plam but when i try to download the rom i can not select a the usb port can any one help
Chriz88DX is offline  
Reply With Quote
Old 01-12-11, 03:55 PM
  #57
My job is to blow **** up
Thread Starter
iTrader: (8)
 
lastphaseofthis's Avatar
 
Join Date: Jan 2005
Location: palmyra Indiana
Posts: 2,865
rom's are on the net, you just gotta search for them. look for a m130 rom. if your using POSE.

for the Cobalt simulator, the rom is built in, but it can be kinda buggy.
lastphaseofthis is offline  
Reply With Quote
Old 02-05-11, 03:54 PM
  #58
Remission Motorsports
iTrader: (1)
 
89RedsunGTUs's Avatar
 
Join Date: Aug 2009
Location: SLC, Utah
Posts: 249
sorry to re open an old thread lol

but let me get this straight. (really want this to work lmao) i can't just buy a DB9 to DB9 Connector, i HAVE to find a Null Modem as well? cause as of now, i have a Female DB9 To Female DB9 hooked up and i have no connectivity (Red X) when i use the Colbalt Emulator.

i'm running Windows 7 if that changes anything lol
89RedsunGTUs is offline  
Reply With Quote
Old 02-05-11, 04:39 PM
  #59
My job is to blow **** up
Thread Starter
iTrader: (8)
 
lastphaseofthis's Avatar
 
Join Date: Jan 2005
Location: palmyra Indiana
Posts: 2,865
it's a null modem cable. not null modem+cable. search ebay for one.
lastphaseofthis is offline  
Reply With Quote
Old 02-06-11, 01:47 AM
  #60
Remission Motorsports
iTrader: (1)
 
89RedsunGTUs's Avatar
 
Join Date: Aug 2009
Location: SLC, Utah
Posts: 249
So its a Specific cable then? not just a Female to Female DB9 cable? damn....
89RedsunGTUs is offline  
Reply With Quote
Old 03-28-11, 02:24 PM
  #61
Turbo power, activate!
10 Year Member
iTrader: (7)
 
Black Knight RX7 FC3S's Avatar
 
Join Date: Nov 2002
Location: Philadelphia
Posts: 1,691
I just tried it yesterday and it works for me
I used a Serial null modem adapter though instead of a cable that I bought yesterday at microcenter
http://www.microcenter.com/single_pr...uct_id=0237075

and I already had a serial to usb cable from when I had my zetronix
http://www.newegg.com/Product/Produc...82E16812203018

Hooked it up to my netbook running windows xp and it ran well. One thing though is the cobalt is slow on my netbook, but the Palm OS emulator 3.5 runs smooth.
Black Knight RX7 FC3S is offline  
Reply With Quote
Old 09-26-11, 04:31 PM
  #62
Incomplete Project
5 Year Member
iTrader: (1)
 
rx7-kid's Avatar
 
Join Date: Aug 2006
Location: Oroville, California
Posts: 512
Sorry to revive the thread but i got the emulator and rom installed on window 7. I just couldn't get the connection to the ecu, it keeps on displaying the X. Thanks for any help. I have the null cable and the serial to usb but it just couldnt connect.
rx7-kid is offline  
Reply With Quote
Old 09-26-11, 05:04 PM
  #63
Rotary Enthusiast
iTrader: (1)
 
Join Date: Jul 2003
Location: ..
Posts: 1,302
Did you tell the emulator what com port to use?
turbo2ltr is offline  
Reply With Quote
Old 09-27-11, 01:58 AM
  #64
Incomplete Project
5 Year Member
iTrader: (1)
 
rx7-kid's Avatar
 
Join Date: Aug 2006
Location: Oroville, California
Posts: 512
how do i set the com port. Thanks in advance
rx7-kid is offline  
Reply With Quote
Old 09-27-11, 02:33 AM
  #65
Incomplete Project
5 Year Member
iTrader: (1)
 
rx7-kid's Avatar
 
Join Date: Aug 2006
Location: Oroville, California
Posts: 512
How do i set the emulator to run the rtek. I have all the cable and emulator installed but don't know how to set the emulator to be able to read the ecu? Thanks and sorry
rx7-kid is offline  
Reply With Quote
Old 09-27-11, 01:03 PM
  #66
Incomplete Project
5 Year Member
iTrader: (1)
 
rx7-kid's Avatar
 
Join Date: Aug 2006
Location: Oroville, California
Posts: 512
I got it to link now. It's just that i think my connection is not good cause it could only link for a few minute then it switch to the x again. So i think my connection is not that great
rx7-kid is offline  
Reply With Quote
Old 09-29-11, 06:08 PM
  #67
Incomplete Project
5 Year Member
iTrader: (1)
 
rx7-kid's Avatar
 
Join Date: Aug 2006
Location: Oroville, California
Posts: 512
I've been trying to data log for the past two day and couldn't get it to datalog at all. It would switch back to X, but once i turn off the engine and turn the key on it would link again. Do i need a pda to datalog?
rx7-kid is offline  
Reply With Quote
Old 09-29-11, 06:11 PM
  #68
Incomplete Project
5 Year Member
iTrader: (1)
 
rx7-kid's Avatar
 
Join Date: Aug 2006
Location: Oroville, California
Posts: 512
Quote:
Originally Posted by rx7-kid View Post
I got it to link now. It's just that i think my connection is not good cause it could only link for a few minute then it switch to the x again. So i think my connection is not that great
I've tried it on Window 7 (sony vaio) and it would not link at all so i switch over to my cousin window xp (Asus, running intel atom) and it would link when engine is off, but not when engine is running so i cant datalog at all.
rx7-kid is offline  
Reply With Quote
Old 09-30-11, 04:43 PM
  #69
My job is to blow **** up
Thread Starter
iTrader: (8)
 
lastphaseofthis's Avatar
 
Join Date: Jan 2005
Location: palmyra Indiana
Posts: 2,865
Cobalt won't do data logging, but the POSE on an m130 rom does.
lastphaseofthis is offline  
Reply With Quote
Old 10-01-11, 02:08 AM
  #70
Incomplete Project
5 Year Member
iTrader: (1)
 
rx7-kid's Avatar
 
Join Date: Aug 2006
Location: Oroville, California
Posts: 512
Thanks ill try it out to see if it'll datalog. Ill try to see if i can find the the m130 rom.
rx7-kid is offline  
Reply With Quote
Old 11-10-11, 05:48 PM
  #71
Senior Member
iTrader: (5)
 
freq's Avatar
 
Join Date: Jan 2006
Location: Boston, MA
Posts: 566
Got it working today.
Used an Adicon USB to serial port adapter.
A Null modem adapter..http://www.radioshack.com/product/in...ductId=3964616
And a db9 gender changer .. http://www.amazon.com/Cables-Go-0278...0968713&sr=8-1
freq is offline  
Reply With Quote
Old 11-25-11, 04:05 PM
  #72
IFO Forced Induction Slo
10 Year Member
iTrader: (3)
 
bigdv519's Avatar
 
Join Date: Mar 2004
Location: Houston
Posts: 1,315
I spy Katja vids

Other than that, I'm glad this option is here because I cant stand the palm...once upon a time I had an RTEK 1.7 on my 88 TII, and I had planned to go with the newer version needing the palm. I went with a PFC instead.

Now that I have an S5 vert, I'm considering the RTEK again.
bigdv519 is offline  
Reply With Quote
Old 04-01-12, 08:03 PM
  #73
Top Down, Boost Up
5 Year Member
iTrader: (7)
 
RotaryRocket88's Avatar
 
Join Date: Mar 2008
Location: San Diego, CA
Posts: 8,719
I just got this all set up and working last week, and I thought I'd reply here with some info should help out the next person that tries it.

Finding roms for Palm OS Emulator can be a hassle, but I eventually found a random webpage with 4 different ones. If you're thinking of using the rom transfer program that comes with POSE, it won't work unless your palm is connected via serial cable. With USB, it won't connect. I even tried the supposed work around with the USBPort.dll file, but it still failed.

To get POSE and your USB serial controller using the same communications port, you'll need to switch them both to COM 1.

For POSE, launch a rom, then right click. Select settings -> properties, then change "Serial Port:" to COM1.

For the USB serial controller, go through device manager. Go to advanced settings, and force it to use COM 1. Mine defaulted to COM 4.

If everything is plugged in, RX7Logger should connect and allow you to use a mouse instead of a stylus (thank God). I was able to enter my MAP based timing maps in about 1.5 hours, and with minimal hand cramping!

In contrast, I spent over an hour with my M515 and only entered about 50 values. The connection problems that particular model seems to have makes anything but small adjustments a nightmare. Don't buy an M515 (and maybe the M505 too). They randomly drop the connection to the ECU, which does fun things like zero out the cranking fuel map or change all the values in your timing maps!
RotaryRocket88 is offline  
Reply With Quote
Old 04-30-12, 05:32 PM
  #74
Full Member
5 Year Member
iTrader: (3)
 
Join Date: Aug 2008
Location: Toronto
Posts: 138
so with the POSE and m130 rom, you're able to save your maps and datalog???
dmak is offline  
Reply With Quote
Old 05-11-12, 12:19 AM
  #75
Top Down, Boost Up
5 Year Member
iTrader: (7)
 
RotaryRocket88's Avatar
 
Join Date: Mar 2008
Location: San Diego, CA
Posts: 8,719
Yes, the maps can be saved and you can datalog. I didn't try to retrieve the datalogs to view w/ pviewer, but they're at least viewable through the emulator.
RotaryRocket88 is offline  
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Skeese
Adaptronic Engine Mgmt - AUS
65
03-28-17 03:30 PM
lt1_rx7
Blue Ridge Rotary Run
46
10-09-15 03:11 PM
CaptainKRM
2nd Generation Specific (1986-1992)
14
08-26-15 09:52 PM
82streetracer
Haltech Forum
10
08-20-15 08:31 PM
baconflavored
SE RX-7 Forum
0
08-12-15 12:07 AM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:39 AM.


All content Copyright 2007 by Internet Brands, Inc.