Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Race Car Tech
Reload this Page >

Msd Coils Not Working W/microtech Please Help

Race Car Tech Discuss anything related to road racing and auto X.

Msd Coils Not Working W/microtech Please Help

Old 10-31-08, 09:02 AM
  #1  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
Msd Coils Not Working W/microtech Please Help

Hi i have a microtech lt10s with x4 box..... i have the coils wired the correct way because about a week ago when the car was still not completed we started the engine. but for reasons unkown to me the coils are getting power to the positive side of the coils and the negative side. i know its not the wiring because i have power only running to the positives on the coils. and the negatives are connected to the X4 box..

please someone help me i really cant figure this out!

thank you,

Vic
illtakeyochik is offline  
Old 10-31-08, 03:21 PM
  #2  
Senior Member
5 Year Member
 
SCCAIT7's Avatar
 
Join Date: Jul 2005
Location: Atlanta
Posts: 525
Likes: 0
Received 0 Likes on 0 Posts
Bad news man - You fried that box - Check your wiring.

On second thought - You have 12V on both side of the coil?
SCCAIT7 is offline  
Old 11-02-08, 03:03 PM
  #3  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
no i only have power to the positive side of the coils and thats it...
illtakeyochik is offline  
Old 11-04-08, 11:47 AM
  #4  
Senior Member
5 Year Member
 
SCCAIT7's Avatar
 
Join Date: Jul 2005
Location: Atlanta
Posts: 525
Likes: 0
Received 0 Likes on 0 Posts
Ok - So where is the box getting its signal from? Are you still running the ignitors?

Your saying the negitives are connected to the box - Which sounds correct -- Where is the box getting its signal to fire?
SCCAIT7 is offline  
Old 11-04-08, 03:35 PM
  #5  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
im a little confused on what you asking? but i have the negatives on the coils goin to the x4 box and the box going to the microtech... i have the box grounded to the firewall too.. but im gonna pu that on the motor tonight.. but i dont think thats gonna change anything
illtakeyochik is offline  
Old 11-07-08, 08:38 PM
  #6  
Senior Member
5 Year Member
 
SCCAIT7's Avatar
 
Join Date: Jul 2005
Location: Atlanta
Posts: 525
Likes: 0
Received 0 Likes on 0 Posts
Hey man - give me a call - 770-712-2708 - I am racing this weekend - however tomm afternoon or evening I should be available ... Sometimes its easiest to talk rather than try to put into words!
SCCAIT7 is offline  
Old 11-10-08, 08:56 AM
  #7  
187 RX7 Gone To Heaven
Thread Starter
 
illtakeyochik's Avatar
 
Join Date: Apr 2008
Location: Lakeland, Florida
Posts: 232
Likes: 0
Received 0 Likes on 0 Posts
hell yea man ill give you a call!!! thanks bro
illtakeyochik is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stickmantijuana
MoTeC
5
09-10-15 07:58 PM
Wolf_
Single Turbo RX-7's
3
08-11-15 04:23 PM


Thread Tools
Search this Thread
Quick Reply: Msd Coils Not Working W/microtech Please Help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: