1987 Turbo II rev problems - RX7Club.com - Mazda RX7 Forum



New Member RX-7 Technical Post your first technical questions here, in an easy flame free environment, before jumping into the main technical sections.

1987 Turbo II rev problems

Reply
 
 
Old 12-27-11, 09:30 PM
  #1
Junior Member
5 Year Member
Thread Starter
 
Join Date: Jul 2009
Location: Columbia,mo
Posts: 25
MO 1987 Turbo II rev problems

I bought re-rex7-94 1987 turbo II. I got everything back to gather. idles fine. It has problems reving from 2,000 rpm to 3,000 rpm. once it hits 3,000 rpm the car takes off. some times the engine shack's alittle. The mods are Bonez down pipe with a high flow cat and custom cat back exhaust. RX7.com clutch and preasure plate, 720cc injectors on the secondary's. I've replaced the fuel filter and drained, drained the old gas. new spark plugs, and wires. new vacuum lines. I've deleted the emissions. I'm sure there are no boost leaks or vacuum line leaks. The primary fuel injectors are stock, could they go bad or possible bad grounds? Thanks Marshall
insanekiller18 is offline  
Reply With Quote
Old 12-27-11, 11:45 PM
  #2
Junior Member
 
Join Date: Dec 2011
Location: SD
Posts: 28
check the cat...... could be plugged..... from what iv found rotarys HATE cats...... not saying im right but thats my guess..... probably plugged
2gboosted is offline  
Reply With Quote
Old 12-27-11, 11:46 PM
  #3
Junior Member
 
Join Date: Dec 2011
Location: SD
Posts: 28
or a vaccum line is leaking or not hooked up...... usually a good start
2gboosted is offline  
Reply With Quote
Old 12-28-11, 11:26 AM
  #4
*MODERATOR*
iTrader: (142)
 
misterstyx69's Avatar
 
Join Date: Sep 2005
Location: Smiths Falls.(near Ottawa!.Mapquest IT!)
Posts: 25,055
you got an aftermarket Ecu for those 720's?
misterstyx69 is offline  
Reply With Quote
Old 12-28-11, 02:41 PM
  #5
Junior Member
5 Year Member
Thread Starter
 
Join Date: Jul 2009
Location: Columbia,mo
Posts: 25
I know it not the cat it's brand new also it holds good idle. I also don't think there is a boost leak i check for vacuum leaks. with a propane torch. I am not running any fuel controller or upgraded ecu. would that cause no power between 2,000 to 3,000? then run great after that rpm. Also it is a jdm engine with us parts. the ecu is n332. also the turbo is stock ht-18
insanekiller18 is offline  
Reply With Quote
Old 12-28-11, 04:42 PM
  #6
Moderator
5 Year Member
 
Join Date: Jun 2005
Location: tulsa,ok.
Posts: 11,738
Make sure the TPS's Green/Red wire is set to 1 volt w/key to on after the car has fully warmed up and idles at 750 rpm. The secondaries kick in at 3800 so it sounds like your problem occurs when "only" the primary injectors are at work so you might want to look into that. Does the car free rev w/o problems when the car is in neutral. If it has no problems in the 2k to 3k range when free reving in neutral then take a look at the Boost Sensor as it should read between 2.3 to 2.7 volts w/key to on at the Brown/Red wire when the vacuum hose for the sensor is removed and capped. The fuel relay under the air box may also be at issue and it can be bypassed by removing its plug and jumpering the Blue/Red wires to the Blue wires within the plug.
satch is offline  
Reply With Quote
Old 12-28-11, 04:58 PM
  #7
Junior Member
5 Year Member
Thread Starter
 
Join Date: Jul 2009
Location: Columbia,mo
Posts: 25
Even when the car is in neutral it wont free rev it takes a while to get to 3,000rpm. then takes off. I really think it might be the primary injectors there the stock ones. The 720cc were brand new. I'm going to replace the primary injectors. To see if that fix's the problem.

Last edited by insanekiller18; 12-28-11 at 05:09 PM. Reason: miss spelled
insanekiller18 is offline  
Reply With Quote
Old 12-29-11, 07:48 PM
  #8
Junior Member
 
Join Date: Dec 2011
Location: vale nc
Posts: 8
im in shock with the information pushed around here i take my hat off to u guys!!!!
speedfreak88 is offline  
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Queppa
New Member RX-7 Technical
7
07-14-16 01:06 AM
cam_7779
2nd Generation Specific (1986-1992)
9
08-18-15 07:48 AM
pzr2
General Rotary Tech Support
1
08-15-15 08:29 PM
Kyo
2nd Generation Specific (1986-1992)
1
08-14-15 10:00 AM
Engine stand ready
2nd Generation RX-7 (1986-1992) Vehicles
0
08-13-15 01:06 PM



Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 05:44 AM.


All content Copyright 2007 by Internet Brands, Inc.