Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Microtech
Reload this Page >

Microtech T_INJ map and why is my car losing lots og power above 7k?

Microtech Area is for discussing Microtech systems

Microtech T_INJ map and why is my car losing lots og power above 7k?

Old 06-11-03, 07:28 PM
  #1  
Rotary Freak
5 Year Member
Thread Starter
 
SaabGuy's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA
Posts: 1,514
Likes: 0
Received 0 Likes on 0 Posts
T_INJ map and why is my car losing lots og power above 7k?

OK well first I want to say that the stock tachometer really sux on my car and most rx7s.

When it says 7000 the ecu says its at like 6600, so at 7500 the engine is at about 7100.

At this "7500/7100" rpm, my car loses a ton of power. its not like power drop off, more like something is just really wierd. The only ecu related option I can see is thie T_inj map (Screen 27).

I can see on my last dyno that at 6500 actual engine rpms my a/f was 11.5:1, and then at 6650 actual rpms my a/f was 11:1, so it got rich in a hurry.

Now I realize that this all could be my tuning on the 6500, 7000, 8000, 3200000 load map, but lets just view the T_INJ for now.

Please look at this attached file.
SaabGuy is offline  
Old 06-11-03, 07:31 PM
  #2  
Rotary Freak
5 Year Member
Thread Starter
 
SaabGuy's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA
Posts: 1,514
Likes: 0
Received 0 Likes on 0 Posts
Loads maps from 5000 through 9000 are relativly close in values, and are nice and even. There are no crazy dips in these load points
SaabGuy is offline  
Old 06-11-03, 08:14 PM
  #3  
Rotary Enthusiast
10 Year Member
 
No7Yet's Avatar
 
Join Date: Aug 2001
Location: Tallahassee, FL
Posts: 1,402
Likes: 0
Received 0 Likes on 0 Posts
Like I said, the first thing to do is to isolate whether it's RPM or load related - try revving up high while running less boost, and see what happens.

Brandon
BR7 Racing
No7Yet is offline  
Old 06-15-03, 10:42 AM
  #4  
Rotary Freak
5 Year Member
Thread Starter
 
SaabGuy's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA
Posts: 1,514
Likes: 0
Received 0 Likes on 0 Posts
I lowered the T_INJ setting at 7000 down one notch. So as it stands the setting is set to ~250 for 7000 rpms down from about ~280. This one adjustment seems to improve the cars power after 7000 rpm.

I did an A:B test on this setting. So far this test is just under stipulation to this point as I really dont know what a/fs are comming out of the pipe.

Before the car would sometimes hit a wall-like restriction. At first I thought it might be the eshaft flexing and the rotor hitting the housing or something but now I have my doughts for that. Yesterday at one point it felt like fuel/spark cut at 7100 rpms.

After this setting change the engine seemed to rev much better to 7500. I think I am going to leave this setting change, as long as the big boys in australia dont mind!

Last edited by SaabGuy; 06-15-03 at 10:54 AM.
SaabGuy is offline  
Old 06-16-03, 07:07 AM
  #5  
Banned. I got OWNED!!!
 
Join Date: Sep 2001
Location: Pensacola, FL
Posts: 311
Likes: 0
Received 0 Likes on 0 Posts
What are your injection times looking like up there? Really the only thing I can see that would cause a BIG problem would be if you were plain running out of time for the injectors to fire.

However I did have a problem with the same setting at the 4000rpm mark, I had a hessitation related to that there.

Daniel
BlackFC is offline  
Old 06-16-03, 07:36 AM
  #6  
Rotary Freak
5 Year Member
Thread Starter
 
SaabGuy's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA
Posts: 1,514
Likes: 0
Received 0 Likes on 0 Posts
Interesting.

My injection times are around the 6.5 to 7ms mark. Thats like 75-80% duty cycle.

Can you perhaps post a before (if different than my attachment) and after of the setting you changed?
SaabGuy is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
82streetracer
Haltech Forum
11
03-11-19 05:34 PM
sen2two
AEM EMS
9
10-23-15 07:51 PM
stickmantijuana
Microtech
5
08-23-15 11:04 AM
gtcd
1st Generation Specific (1979-1985)
30
08-19-15 02:44 AM


Thread Tools
Search this Thread
Quick Reply: Microtech T_INJ map and why is my car losing lots og power above 7k?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: