Microtech Area is for discussing Microtech systems

Microtech lt10s x4 msd 8207 ssblaster coils

Old 05-04-10, 05:02 PM
  #1  
FD Project
Thread Starter
iTrader: (58)
 
BLACK MAMBA's Avatar
 
Join Date: Apr 2009
Location: Palm Beach, FL
Posts: 2,353
Likes: 0
Received 1 Like on 1 Post
lt10s x4 msd 8207 ssblaster coils

went to dyno to tune the car but ignition starts breaking up at 7000 rpm, im using a modified microtech lt10s 12000rpm 45 lbs map sensor with the x4 box and msd 8207 blaster coils, tuner sugested that maybe the x4 box can keep up with the msd coils, and that i should swap the msd coils to 4 fc trailing coils. My question is can i use the x4 box with 2 msd dis-2 boxes to fire the msd coils or i should just change my coils to 4 trailing.
BLACK MAMBA is offline  
Old 05-04-10, 09:00 PM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
how much power you making?
rx72c is offline  
Old 05-04-10, 10:04 PM
  #3  
FD Project
Thread Starter
iTrader: (58)
 
BLACK MAMBA's Avatar
 
Join Date: Apr 2009
Location: Palm Beach, FL
Posts: 2,353
Likes: 0
Received 1 Like on 1 Post
i wasnt able to get a full boost run but i got 319hp at 11 lbs.
BLACK MAMBA is offline  
Old 05-04-10, 11:05 PM
  #4  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
so its not building full boost till 7000rpm?

i would get rid of the msd **** and put the x4 box and 4 mazda trailing coil packs. Tested till 550rwhp no worries and even more with an accuvolt.
rx72c is offline  
Old 05-05-10, 08:20 AM
  #5  
FD Project
Thread Starter
iTrader: (58)
 
BLACK MAMBA's Avatar
 
Join Date: Apr 2009
Location: Palm Beach, FL
Posts: 2,353
Likes: 0
Received 1 Like on 1 Post
Thanks i will try that, im already trying to get 2 moretrailing coils
BLACK MAMBA is offline  
Old 05-16-10, 10:57 AM
  #6  
FD Project
Thread Starter
iTrader: (58)
 
BLACK MAMBA's Avatar
 
Join Date: Apr 2009
Location: Palm Beach, FL
Posts: 2,353
Likes: 0
Received 1 Like on 1 Post
well i finally swap to 4 trailing coils and now im having another problem, the cars seams as if is breaking up from 3000 rpm to 5000 rpm but once it goes in to boost it responds fine, could it be just tunning, also i removed the spark plugs and the front trailing and leading are way darker than the rear, so i decide to check for ignition and hookup the timing light to all spark plug wires and i get the timing light to get signal from l2 and t2 but the light doesnt flash on l1 or t1, but when i removed the wires from the coils there is spark on the coils, so i decide to check the spark plug wires and there is spark to all 4 spark plugs but i still dont get the timing light to flash on l1 or t1, i swap cas and still no flash on the timing light, also with the ignition on i get 12 volts on negative and positive side of the coils, shouldnt the negative side signal from the x4 box to the coils flashing signal.
BLACK MAMBA is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dona1326cosprings7
1st Generation Specific (1979-1985)
4
10-29-15 06:47 AM
eplusz
General Rotary Tech Support
15
10-07-15 04:04 PM
RuffRx7
3rd Generation Specific (1993-2002)
4
10-01-15 03:08 AM
killerrx710
2nd Generation Specific (1986-1992)
1
09-24-15 10:57 PM


Thread Tools
Search this Thread
Quick Reply: Microtech lt10s x4 msd 8207 ssblaster coils


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: