Go Back  RX7Club.com - Mazda RX7 Forum > General Topics > Racing Kills Lounge > Kills Archive
Reload this Page >

My troubled '87 TII killed by 4th gen Monte Carlo

My troubled '87 TII killed by 4th gen Monte Carlo

 
 
 
 
Old 02-29-08, 07:34 PM
  #1  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
My troubled '87 TII killed by 4th gen Monte Carlo

I was just cruising/messing with some settings when a 4th gen Monte Carlo flew by while I was parked so I decided to give chase and see what he was up for (on a very long, very smooth, very open stretch of back road highway). We started at about 70mph, I put it in 3rd and ran up to 6500RPM (my current limit) eventually maxing at 5psi boost (I have a few issues right now). He got the jump on me as it was, but he was destroying me regardless. Didn't stop me from hitting fourth and continuing a bit, but the 'race' was over. I pulled beside and gave him a thumbs up, he grinned, then I came home to work on my car.

I can't be sure if anything was done to his car, I don't know much about them, but it was fairly quick. If I can figure out this 6500RPM issue and again make sure I have no intake leaks I should be able to actually turn up the boost, redline, and run significantly faster.
SpeedOfLife is offline  
Old 02-29-08, 09:15 PM
  #2  
Senior Member
5 Year Member
iTrader: (1)
 
SleepeR1st's Avatar
 
Join Date: May 2007
Location: Candia, New Hampshire
Posts: 329
Likes: 0
Liked 0 Times in 0 Posts
YOU GOT OWNED BY NASCAR! Heh just kidding, you'll get him next time.
SleepeR1st is offline  
Old 02-29-08, 09:43 PM
  #3  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
Hopefully, I actually fixed my 6500RPM wall tonight!!! So, I'll be waiting. Once I can hit boost properly again... It acts like my wastegate is flapping freely, I'll have to check that and a few other things.
SpeedOfLife is offline  
Old 02-29-08, 10:58 PM
  #4  
mmm doritos
10 Year Member
iTrader: (4)
 
13bturbofc's Avatar
 
Join Date: Apr 2006
Location: lancaster PA
Posts: 2,107
Likes: 0
Liked 0 Times in 0 Posts
5psi hahaha get it fixed up and crank up the boost and go kill that pos
13bturbofc is offline  
Old 02-29-08, 11:07 PM
  #5  
Ronald..
10 Year Member
iTrader: (1)
 
93rx74lyfe's Avatar
 
Join Date: Aug 2005
Location: Fairfax/Manassas VA
Posts: 2,013
Likes: 0
Liked 0 Times in 0 Posts
Nice death. Fix your car, THEN race.
93rx74lyfe is offline  
Old 03-01-08, 01:21 AM
  #6  
Newbie
 
Join Date: Mar 2008
Location: jerseyville, il
Posts: 3
Likes: 0
Liked 0 Times in 0 Posts
amen.
toadson is offline  
Old 03-02-08, 04:13 AM
  #7  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
Originally Posted by 93rx74lyfe View Post
Nice death. Fix your car, THEN race.
Hey, I gained some serious ground tonight!

Not only can I redline, but tonight I performed the TB mod, vac rack removal, cold start removal, pressure tested my intake (I think the one remaining leak is from that dumb little solenoid or motor on the rear side of the UIM, and it's a fairly small leak, anyone know what it's for? I'll just pull it if it isn't doing anything for me...). It looks like the twin scroll still isn't working, as I can't hit 5psi until about 5500RPM (shouldn't I be able to by 4k? Despite that, I have two words to describe how it drives now:

BACCI
*****
0-60 time with at least .25s of slip at the start was down at least half of a second at 9.5, I've never been able to pull past 120 as fifth gear just wasn't getting enough power at 120 before to go much farther with limited time (now it happily blows by 120, then I shift at 125 and keep going, w00t). It also revs faster and I tweaked my TB so the secondary plates would be held closer to parallel when at WOT (and they still close all the way, too, there was plenty of room to accomplish both).

I can't wait until I figure out the boost issue and of course turn it up a bit, it'll be scary fast then, as in you won't be sure all the time when you're going to have traction or not in the next couple seconds, lol. I have everything set to do so except for a quality boost controller. My cheap mbc isn't cutting it, but like I said there's probably another issue making it hard to boost quickly.

Even so, I suspect that I'm making the same power with less boost. Maybe not by a whole lot, but it sure pulls like it.

WOOO I'm having a great time now
SpeedOfLife is offline  
Old 03-02-08, 04:34 AM
  #8  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
Oh yeah... can't forget that I replaced the PD, too. The old one might have been leaking already, but the screw had fallen out. I also need to grab a couple parts to run dump lines for the PCV and charcoal canister.
SpeedOfLife is offline  
Old 03-02-08, 10:39 AM
  #9  
FB=OS Giken LSD
10 Year Member
iTrader: (20)
 
mikeric's Avatar
 
Join Date: Apr 2001
Location: Wilmington, DE
Posts: 2,279
Likes: 0
Liked 0 Times in 0 Posts
Was that Monte Carlo an SS by any chance?
mikeric is offline  
Old 03-02-08, 10:58 AM
  #10  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
Like I said I don't know much about them, and I didn't see much for badges, so I don't know.
SpeedOfLife is offline  
Old 03-02-08, 08:39 PM
  #11  
1 bar boost
10 Year Member
iTrader: (4)
 
notveryhappyjack's Avatar
 
Join Date: Jun 2005
Location: Seattle, Washington
Posts: 2,735
Likes: 0
Liked 0 Times in 0 Posts
what years we talking about, I own an 86 ss Nowhere as fast as my turbo 7 (maybe once the 75shot is in) but it gets 100 times more comments and looks then the turbo 7.
notveryhappyjack is offline  
Old 03-03-08, 01:28 AM
  #12  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
SpeedOfLife is offline  
Old 03-03-08, 01:41 PM
  #13  
FC guy
iTrader: (8)
 
Rob XX 7's Avatar
 
Join Date: Oct 2002
Location: Long Island, New York
Posts: 8,663
Liked 9 Times in 9 Posts
those cars can be hiding anywhere from a GN motor up to a big block, never under estimate them
Rob XX 7 is offline  
Old 03-03-08, 04:00 PM
  #14  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
I didn't underestimate by any stretch of the word. I figured there was a high chance he'd destroy me, I just wanted to play. I have enough fun driving alone, it's just a little more interesting when you're competing. Win or lose isn't always important.

I also got some more issues taken care of late last night, like burning of oil and the fact that my turbocharger had COME UNBOLTED FROM THE MANIFOLD. Awesome. So I tightened it down as safely as I could (half the gasket is, of course, gone); checked how it spun (just fine, amazingly, and next I'll tell you why...); and I don't know how much this had to do with it, but Friday or Saturday night when I took it out I saw a couple flashes under the hood, accompanied with nice *pops*. I was like "WTF?!", but nothing was apparently burnt or damaged, so I kept going... but this explains completely why I wasn't hitting boost quickly nor past 5psi (I'm surprised I even hit that, there was at least 3/8" gap at the bottom between the manifold and turbo). NOW, if I set my mbc barely too high, I can nail somewhere around 10psi by 4kRPM and start slipping the clutch, so I have it around 8 and this little '7 just HAULS, and the manifold still isn't 100% sealed...

btw does anyone have any issues with buzzing a student driver when they refuse to do over 40mph on a very long, straight on-ramp? lol

Last edited by SpeedOfLife; 03-03-08 at 04:09 PM.
SpeedOfLife is offline  
Old 03-03-08, 11:06 PM
  #15  
DOWNSTAIRS MIXUP
5 Year Member
 
1RevvinFC3S's Avatar
 
Join Date: Mar 2003
Location: Lampasas, TX
Posts: 2,723
Likes: 0
Liked 0 Times in 0 Posts
Replace the gasket.
1RevvinFC3S is offline  
Old 03-28-08, 12:35 PM
  #16  
Team Benjos Captain
10 Year Member
iTrader: (2)
 
XxMerlinxX's Avatar
 
Join Date: Aug 2005
Location: Greenwood/Hartsville, SC.
Posts: 2,720
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by SleepeR1st View Post
YOU GOT OWNED BY NASCAR! Heh just kidding, you'll get him next time.
Lol, that was the first thing I thought of too.
XxMerlinxX is offline  
Old 03-28-08, 02:00 PM
  #17  
Lives on the Forum

iTrader: (6)
 
7_rocket's Avatar
 
Join Date: Jul 2003
Location: Toronto
Posts: 7,112
Liked 18 Times in 16 Posts
Originally Posted by XxMerlinxX View Post
Lol, that was the first thing I thought of too.
+2
7_rocket is offline  
Old 03-28-08, 02:03 PM
  #18  
Former Rotorhead
5 Year Member
 
Sprockett's Avatar
 
Join Date: May 2002
Location: Midland, MI
Posts: 1,926
Likes: 0
Liked 0 Times in 0 Posts
very open stretch of back road highway
WHICH IS NOT A SANCTIONED RACE TRACK!

ILLEGAL STREET RACER!
Sprockett is offline  
Old 03-28-08, 02:12 PM
  #19  
rotors excite me
10 Year Member
Thread Starter
iTrader: (16)
 
SpeedOfLife's Avatar
 
Join Date: Jun 2006
Location: Central Iowa
Posts: 4,082
Likes: 0
Liked 3 Times in 3 Posts
Well, I will get him next time, unless my engine catches fire again, but I'd get spanked for posting it here. Do I dood it? *ponders* I dood it!

So I had a very interesting morning that involved accidentally getting up too early, having my engine start on fire, towing it home, calling a day off work to fix it, then getting fired. Quite a situation we've got here, Tom, indeed, Diane.
SpeedOfLife is offline  
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jeff20B
1st Generation Specific (1979-1985)
73
09-16-18 07:16 PM
jdayau
Build Threads
6
01-22-16 08:13 PM


Thread Tools
Search this Thread
Quick Reply: My troubled '87 TII killed by 4th gen Monte Carlo


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.