Help wanted........... - RX7Club.com - Mazda RX7 Forum

General Rotary Tech Support Use this forum for tech questions not specific to a certain model year

Help wanted...........

Reply

 
 
Old 07-12-17, 06:31 PM
  #1
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: puertorico
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Help wanted...........

Recently i rebuilt my 12 engine..new side seal...new corner seals...new goopy apex seals...everithing new..80% new housings and a half brige port...gt35 turbo and 600 holley....so the problem its when iddling at 1700 rpm the brige not sounds...he had a krazy iddle....and i hear noise comes out from the holley...like a poping noisy...the engine starts fast...and when iddle up to 2000 the bridge sounds litlle ok...im take down the engine and dissambled to inspect...all its allright...a friend of my tells me that the goopy apex take so much time to embedding...i dont know its the first time that i use this apex seals.....im worry about the poping noise come out from carb...but this noise only its a 1400 iddle...i dont know....anny sugestions....please let me know...thanksssss...
raldo is offline  
Reply With Quote
Old 07-13-17, 05:08 PM
  #2
Senior Member
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 501
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by raldo View Post
Recently i rebuilt my 12 engine..new side seal...new corner seals...new goopy apex seals...everithing new..80% new housings and a half brige port...gt35 turbo and 600 holley....so the problem its when iddling at 1700 rpm the brige not sounds...he had a krazy iddle....and i hear noise comes out from the holley...like a poping noisy...the engine starts fast...and when iddle up to 2000 the bridge sounds litlle ok...im take down the engine and dissambled to inspect...all its allright...a friend of my tells me that the goopy apex take so much time to embedding...i dont know its the first time that i use this apex seals.....im worry about the poping noise come out from carb...but this noise only its a 1400 iddle...i dont know....anny sugestions....please let me know...thanksssss...
Did u check timing? What afrs was it idling at i find my bridgeport doesnt like to brap with a lean idle and it didnt brap with out a advance idle so if u didnt set timing or it was running lean wouldnt sound to bridgey tbh cant always go by the sound if u went really conservitive on the ports u may not have a crazy amount of overlap, someone else can chim in i had a half bridge turbo fresh rebuild with goopy seals brapped on start up so ur problem imo is elsewhere
dillrx7 is offline  
Reply With Quote
Old 07-13-17, 06:22 PM
  #3
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: puertorico
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Help

The timing its full advance to breakin propocites...today i check compresion....75 in each rotor......i think the problem maybe the apex wont seal yet....
raldo is offline  
Reply With Quote
Old 07-14-17, 09:45 AM
  #4
Senior Member
iTrader: (3)
 
dillrx7's Avatar
 
Join Date: Aug 2013
Location: ottawa ontario
Posts: 501
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by raldo View Post
The timing its full advance to breakin propocites...today i check compresion....75 in each rotor......i think the problem maybe the apex wont seal yet....
Your issues arnt the apex seals lol, if they didnt seal u wouldnt have compression, as i said my goopy seals worked great since being rebuilt, pleasr post pictures of your set up and your porting job if you have any please
dillrx7 is offline  
Reply With Quote
Old 07-16-17, 11:07 AM
  #5
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,620
Thanks: 0
Thanked 13 Times in 13 Posts
Timing should not be full advance at idle, even for a bridgeport. Bring it down to 10 degrees and see how it behaves.
Aaron Cake is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 08:24 PM.


All content Copyright 2007 by Internet Brands, Inc. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: