HKS EVC 5 installation - Page 2 - RX7Club.com - Mazda RX7 Forum

3rd Generation Specific (1993-2002) 1993-2002 Discussion including performance modifications and Technical Support Sections.

HKS EVC 5 installation

Old 06-08-09, 05:17 PM
  #26  
Senior Member
iTrader: (3)
 
Join Date: Oct 2008
Location: los angeles
Posts: 709
Thanked 3 Times in 3 Posts
and what should i do with the pill?

remove or not? ( which pill?)



MILOS7 is offline  
Old 06-09-09, 05:13 PM
  #27  
Senior Member
iTrader: (3)
 
Join Date: Oct 2008
Location: los angeles
Posts: 709
Thanked 3 Times in 3 Posts
Bump
MILOS7 is offline  
Old 06-09-09, 07:06 PM
  #28  
RX7FD3S
iTrader: (3)
 
Join Date: Jun 2005
Location: South Bay, North Cali.
Posts: 1,482
Thanked 6 Times in 4 Posts
Originally Posted by MILOS7 View Post
and what should i do with the pill?

remove or not? ( which pill?)

If you look at the HKS install diagram. it shows you need to remove the pills and T them up with the correct size vaccume hoses to the HKS solenoid. just follow the illustration
RX7LINK is offline  
Old 11-23-11, 05:41 AM
  #29  
Pilot of the Ichikaze
 
Ryudake's Avatar
 
Join Date: Mar 2011
Location: World Tree
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
ANyone know where the throttle signal line is? For an 16bit ecu year 2000 model fd

Last edited by Ryudake; 11-23-11 at 05:49 AM.
Ryudake is offline  
Old 08-19-13, 12:15 AM
  #30  
PedoBear
iTrader: (4)
 
nycgps's Avatar
 
Join Date: Jun 2006
Location: Bye NYC. you SUCKED!
Posts: 1,418
Thanks: 0
Thanked 0 Times in 0 Posts
HOly thread resurrection!

Does both of the vacuum lines has to go to the left side on the actuator not the right? Does it matter which side i go? Reason is my friend's fd both vacuum lines goes to the right and capped the left side ... and all he gets is 6 psi wont go any higher

Also, will a dirty 6mm filter cause this? The filter is covered with dirt and oil, im gonna clean it.
nycgps is offline  
Old 02-05-19, 05:43 PM
  #31  
Senior Member
 
Michaelangelofb's Avatar
 
Join Date: Oct 2006
Location: Rio Rancho, N.M.
Posts: 721
Thanked 0 Times in 0 Posts
Quote and thread resurrection AGAIN sorry. In this pic where are you guys connecting the vacuum line labeled “BOOST” too. Just wondering where the preferred best source is according to you guys...


Originally Posted by RX7LINK View Post
Maybe this will help? after you hook everything up. u can either rework your vaccume hoses (capping off the 2nd nipple on both actuators that are routed to the stock solenoids) or simply unplug the electronic plugs on both of your stock solenoids and it'll keep those shut.

Michaelangelofb is offline  
Old 02-06-19, 09:05 AM
  #32  
RX-7 Bad Ass
iTrader: (52)
 
DaleClark's Avatar
 
Join Date: Jan 2002
Location: Pensacola, FL
Posts: 11,016
Thanked 231 Times in 200 Posts
The boost signal just needs to be a reference from the intake manifold. You can T it into the line going to your boost gauge.

Dale
DaleClark is offline  
The Following User Says Thank You to DaleClark For This Useful Post:
Michaelangelofb (02-06-19)
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gabescanlon
Interior / Exterior / Audio
1
08-11-15 06:59 PM


Thread Tools
Search this Thread
Quick Reply: HKS EVC 5 installation


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.