3rd Generation Specific (1993-2002) 1993-2002 Discussion including performance modifications and Technical Support Sections.

Car won't shut off

Old 03-12-16, 04:42 PM
  #1  
Committee Member #3
Thread Starter
iTrader: (7)
 
jm93rx7's Avatar
 
Join Date: Sep 2003
Location: S. Florida
Posts: 3,156
Likes: 0
Received 0 Likes on 0 Posts
Car won't shut off

Swapped over from a Microtech to a stock FD harness and Adaptronic. Car turns on with no problems but when you try to turn it off it will stay on even without key in the ignition. Have to turn off pump manually for it to shut off. I was recommended to try a different ignition switch so I swapped a spare on that I have and the issue doesn't go away. Any thoughts or suggestions?
jm93rx7 is offline  
Old 03-12-16, 07:31 PM
  #2  
Senior Member
iTrader: (22)
 
Join Date: Dec 2014
Location: Trenton NJ
Posts: 264
Received 4 Likes on 4 Posts
Something very similar happened to me this summer. It was the yellow relay on the drivers fender. EGI main relay. Says JE16 on the relay itself. I was able to use my AC relay to drive the car temporarily.

Hope this helps.

Last edited by NJ-JDM; 03-12-16 at 07:46 PM.
NJ-JDM is online now  
Old 03-12-16, 07:38 PM
  #3  
Committee Member #3
Thread Starter
iTrader: (7)
 
jm93rx7's Avatar
 
Join Date: Sep 2003
Location: S. Florida
Posts: 3,156
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by NJ-JDM View Post
Something very similar happened to me this summer. Is was the yellow relay on the drivers fender. EGI main relay. Says JE16 on the relay itself. I was able to use my AC relay to drive the car temporarily.

Hope this helps.

Thanks. Will check it out.
jm93rx7 is offline  
Old 03-12-16, 07:55 PM
  #4  
Senior Member
iTrader: (22)
 
Join Date: Dec 2014
Location: Trenton NJ
Posts: 264
Received 4 Likes on 4 Posts
Originally Posted by jm93rx7 View Post
Thanks. Will check it out.
Once the relay was stuck, my dash was lit up when we connected the battery. No key. I pulled that relay and everything went out. So I knew I had found it.
NJ-JDM is online now  
Old 03-14-16, 04:34 AM
  #5  
Senior Member
 
RuffRx7's Avatar
 
Join Date: May 2013
Location: Johannesburg, South Africa
Posts: 301
Likes: 0
Received 0 Likes on 0 Posts
I had this problem and turned out the tires had worn out my harness on the drivers side and caused a whole bunch of strange behaviour, one thing was that the car would not switch off when removing the key.
RuffRx7 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Crusty-SE
1st Generation Specific (1979-1985)
22
03-10-16 10:51 PM
jbherri2
1st Generation Specific (1979-1985)
10
03-08-16 07:52 PM


Thread Tools
Search this Thread
Quick Reply: Car won't shut off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.