92 - 2002 Efini Rx7 FD3S Help - RX7Club.com - Mazda RX7 Forum

3rd Generation Specific (1993-2002) 1993-2002 Discussion including performance modifications and Technical Support Sections.
Sponsored by: Elite Rotary Shop

92 - 2002 Efini Rx7 FD3S Help

Reply

 
 
Old 08-28-08, 05:29 PM
  #1
New to Improve
5 Year Member
Thread Starter
 
Join Date: Aug 2008
Location: Alberta
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Question 92 - 2002 Efini Rx7 FD3S Help

I've searched with every possible search i could think of and have got no results yet!
I hope there is someone out there somewhere i can obtain a electronic copy of wiring
diagrams for my 92 JDM Efini Rx7. My cooling fans do come on with my AC. I've tried using the wiring diagrams from the 93's that were sold in Northern America but found the wiring dose not match the car! I'm not at a loss. i've checked my Relays, Fuses, tried the test procedures and they failed as well. Any help would be greatly appreciated.
RX7Pilot101 is offline  
Reply With Quote
Old 08-28-08, 07:18 PM
  #2
bryant
10 Year Member
 
bryant's Avatar
 
Join Date: May 2002
Location: montgomery
Posts: 1,509
Thanks: 0
Thanked 0 Times in 0 Posts
so what exactly is wrong with the car?
bryant is offline  
Reply With Quote
Old 08-28-08, 07:28 PM
  #3
New to Improve
5 Year Member
Thread Starter
 
Join Date: Aug 2008
Location: Alberta
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
My Cooling fans do not run at all. I turn on the AC nothing happens! I know the Thermo switch is dead cause the fans don't come on when they are suppose to at 105C i believe that's the temp they kick on at. They work if i feed power directly from the battery.
RX7Pilot101 is offline  
Reply With Quote
Old 09-08-08, 09:49 PM
  #4
New to Improve
5 Year Member
Thread Starter
 
Join Date: Aug 2008
Location: Alberta
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Ok guys! I've replaced the water Temp. switch with a new switch for a turbo FC to get the fans to come on at 95 deg. C, Turning on the AC will turn on the fans now but they still don't click on at 95 deg. C. I've checked the relays for continuity, they have it, all fuses are good. Any ideas ???
RX7Pilot101 is offline  
Reply With Quote
Old 09-11-08, 12:28 PM
  #5
New to Improve
5 Year Member
Thread Starter
 
Join Date: Aug 2008
Location: Alberta
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Fans don't work at all again. Fans are still good, they work if hooked up directly to the battery!
RX7Pilot101 is offline  
Reply With Quote
 
 
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BNR34RB26DETT
Build Threads
32
06-20-17 11:27 PM
SHOCKANAWE
3rd Generation RX-7 (1993-2002) Parts
2
10-24-15 12:12 PM
Sabbath-7
1st Generation RX-7 (1979-1985) Vehicles
13
09-05-15 12:10 PM
MattGold
3rd Generation RX-7 (1993-2002) Parts
5
08-24-15 07:58 AM
Rx7_brad
3rd Generation Specific (1993-2002)
0
08-15-15 09:57 AM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:46 AM.


All content Copyright 2007 by Internet Brands, Inc.