6 Port Turbo, Megasquirt Build - Page 2 - RX7Club.com - Mazda RX7 Forum

2nd Generation Non-Technical and pictures Show off your car & view 2nd gen RX-7 pictures here.
Sponsored by:

6 Port Turbo, Megasquirt Build

Old 05-27-10, 09:48 PM
  #26  
Boosted. I got BLOWN!!!
10 Year Member
iTrader: (29)
 
beefhole's Avatar
 
Join Date: Sep 2003
Location: Queens, NY
Posts: 3,742
Thanks: 0
Thanked 0 Times in 0 Posts
^Where in NY are you?
beefhole is offline  
Old 05-27-10, 10:18 PM
  #27  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Binghamton, 3 hours from NYC.
killalot13601 is offline  
Old 05-28-10, 10:24 AM
  #28  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Thanks: 0
Thanked 21 Times in 20 Posts
Originally Posted by killalot13601 View Post
The Oil Pressure sensor is 1/8th NPT thread. I am getting the oil feed from there. I used a 4 way split capped on side, put the sensor straight out and the feed line coming off the split headed to the front of the car.
I will take photos as soon as possible.
Actually, it is 1/8" BSPT. That's a British taper thread and slightly different then NPT. Some NPT fittings do fit, but in the process either the threads on the fitting or in the block are damaged. I guess if you never intend to remove it, you are probably alright with 1/8" NPT.

Originally Posted by Chriz88DX View Post
another note how did you slove the problem of the oil injection system it work with vaccum how does it react well to boost
The oil nozzles have built in check valves.
Aaron Cake is offline  
Old 05-28-10, 02:44 PM
  #29  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Aaron Cake View Post
Actually, it is 1/8" BSPT. That's a British taper thread and slightly different then NPT. Some NPT fittings do fit, but in the process either the threads on the fitting or in the block are damaged. I guess if you never intend to remove it, you are probably alright with 1/8" NPT.
Oh wow, thank you for the correction.
killalot13601 is offline  
Old 05-31-10, 12:57 AM
  #30  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
New photos, got the intercooler piping hooked up with the pipes we had available. A better job will be done later on.

I will add that all the parts to the oil feed system I used from an Ebay oil feed line kit. I have used them in the past never a problem so for everything you need that is an option. Do not order the drain lines because they use real cheap AN fittings.

Pictures
lol a light cord is hanging in the picture.




Like I said we are trying to get the car running for an event June 5th. We had to use 3 PVC couplers for now.


The battery cable is a summit kit that came with the mounting tray and all.

In the picture is where the line comes out from under the passenger side rear bin. The grommet is not in place yet but you can see it there.


Line routed up to the starter.


Another view


Shot of the manifold, down pipe and 50mm wastegate.




I love questions and comments.
Thanks for reading,
Chris Stewart
killalot13601 is offline  
Old 05-31-10, 10:21 AM
  #31  
Banned. I got OWNED!!!
iTrader: (5)
 
Join Date: Jan 2010
Location: FLORIDA
Posts: 377
Thanks: 0
Thanked 0 Times in 0 Posts
That look great man? quick question are you able to use an intercooler like an rsx one or similar to it so you can run both ic pipes one way? im debating on doing the same just dont wanna run so much piping



Uploaded with ImageShack.us
s2kguy17 is offline  
Old 05-31-10, 11:35 AM
  #32  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Dude that is very possible. Look at my first post how I routed the piping on my old 6 port turbo (last picture).
killalot13601 is offline  
Old 05-31-10, 12:54 PM
  #33  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Video Update

<object width="480" height="385"><param name="movie" value="http://www.youtube.com/v/4fXm9g2QuNk&hl=en_US&fs=1&"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/4fXm9g2QuNk&hl=en_US&fs=1&" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed></object>
killalot13601 is offline  
Old 09-27-10, 12:41 PM
  #34  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
I guess I want to add that this is still the same clutch that came with the car and I expect it to be stock. Anything over 6PSI and it starts to slip.
New clutch soon so we can power shift the big turbo straight into the next gear.

2.5 60 foot times, so we have a lot to gain without raising boost levels at all.

First Run with Jon Bixby's RX7 6PSI
<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/lvQMEcEgPTc?hl=en&fs=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/lvQMEcEgPTc?hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>

Second to last run 8PSI
<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/IUzGJEkhIdE?hl=en&fs=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/IUzGJEkhIdE?hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>

Fastest and last run of the night. 10PSI
<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/g-m8YCeiDos?hl=en&fs=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/g-m8YCeiDos?hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>
killalot13601 is offline  
Old 09-27-10, 07:42 PM
  #35  
yeah its a rotary
10 Year Member
iTrader: (1)
 
turbo2SE's Avatar
 
Join Date: Aug 2005
Location: Va Beach or IN, indianapolis
Posts: 795
Thanks: 0
Thanked 0 Times in 0 Posts
good job! im also doing the same setup with the stock s4 turbo but this is going into my first gen and already have the ms built for it.

added this to fav's
turbo2SE is offline  
Old 09-27-10, 10:07 PM
  #36  
the machinest
iTrader: (9)
 
need-a-t2's Avatar
 
Join Date: Mar 2002
Location: binghamton, ny
Posts: 1,058
Thanks: 0
Thanked 8 Times in 5 Posts
one of these days we're going to have to meet up. I finally got my FC up and running again on the microtech. just needs a bit of tuning now.
need-a-t2 is offline  
Old 09-28-10, 10:18 AM
  #37  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by need-a-t2 View Post
one of these days we're going to have to meet up. I finally got my FC up and running again on the microtech. just needs a bit of tuning now.

YEAH! Most certainly need to meet up before winter.
killalot13601 is offline  
Old 10-17-10, 01:11 PM
  #38  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Just got a new clutch yesterday, OEM looked fried xD
killalot13601 is offline  
Old 09-19-12, 06:13 AM
  #39  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
I wanted to post an updated picture of the engine bay. Car is still running at 10psi.
The owner like the turbo lag more then anything. The exhaust housing was downsized to a .84 A/R.

I would estimate low 12s in the 1/4th mile drag.
Attached Thumbnails 6 Port Turbo, Megasquirt Build-181662_177031569008377_8221289_n.jpg  
killalot13601 is offline  
Old 09-19-12, 04:06 PM
  #40  
Junior Member
 
Join Date: Sep 2012
Location: Minneapolis
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Wow nice set up... LOL at the China turbo though
tkltian is offline  
Old 09-20-12, 07:45 AM
  #41  
Senior Member
10 Year Member
Thread Starter
iTrader: (5)
 
Join Date: Sep 2005
Location: New York
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
yeah one of the only things I could never get the cars owner to do was buy a real turbocharger. Still works fine though
killalot13601 is offline  
Old 06-16-16, 04:21 AM
  #42  
Full Member
 
Hygoog's Avatar
 
Join Date: Jun 2015
Location: Alabama
Posts: 97
Thanked 0 Times in 0 Posts
So beautiful! I like your car!
Hygoog is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Th0m4s
Build Threads
24
12-09-17 07:50 PM
hotshot2014
New Member RX-7 Technical
8
07-18-17 03:30 PM
Engine stand ready
New Member RX-7 Technical
3
08-14-15 11:26 PM


Thread Tools
Search this Thread
Quick Reply: 6 Port Turbo, Megasquirt Build


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: