HUGE Backfire, muffler blew up - RX7Club.com



HUGE Backfire, muffler blew up

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 06-17-08, 05:26 PM   #1
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
HUGE Backfire, muffler blew up

ok, i searched, and couldn't find anyone with my situation.

the car is an 83 gsl, rat's nest gone, and dlidfis installed. i just replaced the fuel pump and filter. i tried to start it, and it was flooded. so i unflooded it. after unflooding it, i tried to start it up agian, and i think i left the key on for a while and the fuel pump was running if that means anything. then i tried to start it. cranked it a while, and nothing. then....

BOOOOOM!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!

it scared my pants off. so i got out to look at the muffler, and the end of it was blown right off, and the tail pipes were sticking out all weird.

so i said, "hmm." and went to fire it up again. same thing happened, only this time it drew my mom out of the house. she said i had to quit for a while, so i figured i'd start a thread here.

any idea why this is happening? should i just keep trying to start it like nothing's wrong? any other info would be awesome

thanks
jonvo4591 is offline   Reply With Quote
Old 06-17-08, 06:40 PM   #2
Leaking oil like crazy!
10 Year Member
iTrader: (1)
 
1stgen4life's Avatar
 

Join Date: Sep 2003
Location: Utah
Posts: 698
If you try to start it again video tape it, I have to see this. Also pics of the muffler blown up could be fun. Sorry I can't help. Sounds like it is just dumping gas into the exhaust and then igniting in there. Ignition working alright? Good luck.
1stgen4life is offline   Reply With Quote
Old 06-17-08, 07:10 PM   #3
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
i maybe can get a vid, but yeah definitly a picture cuz i got out of the car and started laughing cuz i thought it looked hillarious. maybe even tonight if you're lucky.
jonvo4591 is offline   Reply With Quote
Old 06-17-08, 09:37 PM   #4
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
Ok for your viewing and laughing pleasure:


jonvo4591 is offline   Reply With Quote
Old 06-17-08, 09:45 PM   #5
Stu-Tron Get Yo Groove On
5 Year Member
iTrader: (4)
 
Jeezus's Avatar
 

Join Date: Nov 2006
Location: Huntsville AL
Posts: 8,321
Welcome to the club

From my 78 SA, may she rest in peace.

EDIT: Back with mechanical secondaries. Decided to try it out with doing donuts. 3 seconds after stopping BOOM! I thought I shot a rotor out the housing.


Last edited by Jeezus; 06-17-08 at 09:55 PM.
Jeezus is offline   Reply With Quote
Old 06-17-08, 09:53 PM   #6
ߣ
Post Pimp
10 Year Member
iTrader: (1)
 
ߣ's Avatar
 

Join Date: May 2003
Location: Spokane valley, Washington
Posts: 2,800
wow thas cool. i have never sn that before
ߣ is offline   Reply With Quote
Old 06-17-08, 10:03 PM   #7
7-less
5 Year Member
 

Join Date: Dec 2005
Location: No. Virginia, USA
Posts: 2,053
*L* Awesome! A video would just make this even better.
85 FB is offline   Reply With Quote
Old 06-17-08, 10:10 PM   #8
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
workin on a vid, maybe tomorrow nite.

i think for now, i'll just do a little "muffler delete"
jonvo4591 is offline   Reply With Quote
Old 06-17-08, 10:28 PM   #9
PSHH! PSHH! HEAR ME NOW?
5 Year Member
iTrader: (3)
 
bad 83's Avatar
 

Join Date: Nov 2005
Location: Statesville NC
Posts: 4,132
Now that's some funny sh..... I have shot flames out that you think would do that, but with 3" straight through exhaust there is no back pressure!
bad 83 is offline   Reply With Quote
Old 06-18-08, 01:45 AM   #10
Lapping = Fapping
15 Year Member
iTrader: (12)
 
Jeff20B's Avatar
 

Join Date: Aug 2001
Location: Near Seattle
Posts: 15,035
Wow, my friend blew a dime sized chunk out of his RB header, which I'm sure took some serious force, but your muffler is hilarious.
Jeff20B is online now   Reply With Quote
Old 06-18-08, 02:29 AM   #11
weak minds wear the crown
5 Year Member
iTrader: (2)
 
blackdeath647's Avatar
 

Join Date: Oct 2006
Location: Wilkesboro, NC
Posts: 2,103
this is too damn funny, can't wait to see the video lol. i'm sorry this happened dude, i wish i could help but i have no clue what's causing this.
blackdeath647 is offline   Reply With Quote
Old 06-18-08, 02:32 AM   #12
its supposed to do that
10 Year Member
 
flight_of_pain's Avatar
 

Join Date: Jan 2003
Location: PNW
Posts: 1,350
thats how the stock muffler was on my car when i bought it, It seems to be common on feedback carbed subarus as well. Its like a damn bomb.


isaac
flight_of_pain is offline   Reply With Quote
Old 06-18-08, 11:47 AM   #13
Respecognize!
10 Year Member
 
Whizbang's Avatar
 

Join Date: Sep 2004
Location: Santa Rosa, CA
Posts: 3,959
all the fuel probably was floating around in your exhaust and one good ignition source in the exhaust set it off. My friends vert had BOTH muffler blown out several inches at the seem.
Whizbang is offline   Reply With Quote
Old 06-18-08, 02:48 PM   #14
Bubble Gum's Good
10 Year Member
iTrader: (1)
 
glewsRx's Avatar
 

Join Date: May 2005
Location: Norfolk, VA
Posts: 625
It looks like it ate some bad mexican food
glewsRx is offline   Reply With Quote
Old 06-18-08, 05:15 PM   #15
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
ok, i just tried to start it agian, and the same old thing happened. KABOOM! twice, so i figgerd id see what i can find on the good old forum. while i let the car cool down.
jonvo4591 is offline   Reply With Quote
Old 06-18-08, 05:19 PM   #16
new paint
5 Year Member
 
DC13B's Avatar
 

Join Date: Jul 2005
Location: Durham,NC
Posts: 392
no idea on your problem, but thats hilarious dude
DC13B is offline   Reply With Quote
Old 06-18-08, 06:04 PM   #17
Banned. I got OWNED!!!
iTrader: (2)
 

Join Date: Oct 2004
Location: London, Ontario
Posts: 6,122
Wow ... that quite the explosion alright. I wasn't expecting that. Does the "Kaboom" sound happen after you try cranking it for a while, or happens like on the first crank deal?

Another things that might of went if they're still there, your 3 catalytic converters. They could be just as filled with fuel and sparking up everytime.
dj55b is offline   Reply With Quote
Old 06-18-08, 07:51 PM   #18
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
yeah it happened after cranking for a while, but right after i have everything together after deflooding. I got it to backfire again today, every time i am ready to start after deflooding, it backfires if you crank it for about 10 seconds. i finally got it to fire up, and my dad was inside he held the pedal down to keep it running, because it ran like crap. but when he revved it up it revved good. after he shut it off, i pulled the plugs out and the two on the back rotor were all black and burnt, and the front's were clean. none were wet, but when i cranked it without the plugs, the mist came out, so i let it set, cranked it again, and put it back together, and my dad tried to start it up again. i couldn't get it to run since that ordeal, so i checked spark. the leading sparked amazing when plugs are clean (i did the DLIDFIS conversion using GM ignitors). the trailing is a different story. it sparks when it wants to (not every revolution like it should) while cranking, and really good when you let off the key and the engine is freewheeling. i don't know why this is, and i can't figure out why it won't run now. if i had a video camera, i would take a vid showing what's happening while cranking, but i don't so i can't. it just cranks, and kinda tries to fire, and when it catches, it runs at like 50 (fifty) rpm, sounds like it's only on one rotor, and little drops of gas and a lot of fuel vapor shoot out of the carb. then it just dies, and probably floods out again. sorry for the super long post, but i wanted to say everything i could think of while it was fresh in my mind. any insight would be awesome.

thanks
jonvo4591 is offline   Reply With Quote
Old 06-18-08, 08:12 PM   #19
7less for now!
5 Year Member
 
yetterben's Avatar
 

Join Date: Oct 2007
Location: eau claire
Posts: 1,372
un-flood it and remove exhaust header or manifold whatever you got!
yetterben is offline   Reply With Quote
Old 06-18-08, 08:41 PM   #20
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
man, you dont' know how many times ive tried to unflood it. ( like 15 (ok now you know)) but i can't get it to run for long enough for it to warm up so i can shut it off like i'm supposed to. i can't figure out what's goin on, and it won't idle at all. it's kinda frustrating me.

what is a sure fire way to unflood it other than push starting it (i can't push start cuz there's no driveshaft in it)?
jonvo4591 is offline   Reply With Quote
Old 06-18-08, 09:07 PM   #21
Senior Member
 
TeamSMS's Avatar
 

Join Date: Sep 2007
Location: Texas
Posts: 338
lol the same thing happened to the muffler on my gsl-se....but it didnt fall apart like yorus...just the canister seperated a little different...not as much but still popped REALLY LOUD.
TeamSMS is offline   Reply With Quote
Old 06-18-08, 10:30 PM   #22
Play Well
10 Year Member
 
fcdrifter13's Avatar
 

Join Date: Feb 2005
Location: We're all fine here now, thank you. How are you?
Posts: 4,218
Turn your key to the on position and see if it is running constant fuel into motor down the venturis
fcdrifter13 is offline   Reply With Quote
Old 06-18-08, 11:05 PM   #23
back in the game
Thread Starter
 
jonvo4591's Avatar
 

Join Date: Apr 2008
Location: Grand Rapids, MI
Posts: 143
it's not, i just rebuilt the carb. it was doing that before, so i rebuilt it.
jonvo4591 is offline   Reply With Quote
Old 06-18-08, 11:09 PM   #24
Play Well
10 Year Member
 
fcdrifter13's Avatar
 

Join Date: Feb 2005
Location: We're all fine here now, thank you. How are you?
Posts: 4,218
Have you messed with the timing at all make sure it is spot on.
fcdrifter13 is offline   Reply With Quote
Old 06-19-08, 12:19 AM   #25
Armchair engineer
15 Year Member
iTrader: (2)
 
j9fd3s's Avatar
 

Join Date: Mar 2001
Location: http://www.k2rd.com
Posts: 22,898
Quote:
Originally Posted by jonvo4591 View Post
man, you dont' know how many times ive tried to unflood it. ( like 15 (ok now you know)) but i can't get it to run for long enough for it to warm up so i can shut it off like i'm supposed to. i can't figure out what's goin on, and it won't idle at all. it's kinda frustrating me.

what is a sure fire way to unflood it other than push starting it (i can't push start cuz there's no driveshaft in it)?
unplug the fuel pump
j9fd3s is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
[Wanted to Buy] S4 or S5 turbocharger in good condition chap2700 West For Sale/ Wanted/ Classifieds 4 11-23-15 04:52 PM
broke every apex seal Logan Reinisch General Rotary Tech Support 42 10-13-15 03:20 PM
[For Sale] 88 GTU starts, running issues excitingleopard 2nd Generation RX-7 (1986-1992) Vehicles 5 10-10-15 05:00 PM
Too much afterburner/backfire. Jmpabon93 New Member RX-7 Technical 1 09-30-15 05:57 PM
[For Sale] 1988 Convertible for Restoration hey111you 2nd Generation RX-7 (1986-1992) Vehicles 0 09-26-15 09:29 PM


Tags
84, backfire, backfired, backfires, blew, blow, blown, car, engine, flooded, insides, means, muffler, rx7, start, up

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:28 PM.


All content Copyright 2007 by Internet Brands, Inc.