L31 5.7 vortec swap help - RX7Club.com - Mazda RX7 Forum

L31 5.7 vortec swap help

Reply

 
 
Old 12-04-17, 11:50 PM
  #1
Can Post Only in New Member Section
Thread Starter
 
Join Date: Dec 2017
Location: Illinois
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
L31 5.7 vortec swap help

Ive got a 5.7 vortec and all the under hood gm harnesses and fuse box. I know that i can use the stock gm harness and get 12v to the 6 pink wires under run/start, and that i need 12v to the starter wiring during start and run as well and it will run. My question is, should i get the harness out of the gm truck that has the connecting fuse box under the dash for those wires or should i wire them into the harness of the rx7? Id like to use the fc harness, but id really appreciate some imput as to what wiring to get the 12v out of from the harness in the car? Thanks
Stanky is offline  
Reply With Quote
Old 12-05-17, 11:50 PM
  #2
Full Member
 
Yolo7's Avatar
 
Join Date: Oct 2014
Location: winters, ca
Posts: 167
Thanks: 0
Thanked 1 Time in 1 Post
I donít have any direct knowledge of FCs or the differences in GM harnesses. But I would probably skip using the GM fuse block and just grab the wires you identified and splice them into the RX7 harness. Thatís will I plan on doing to my first gen and Ford EFI setup. After all, the engine just needs powers and gounds to run. Just be aware of the Mazda fuses current ratings so that you donít overr draw from the Mazda circuit.
Yolo7 is offline  
Reply With Quote
Old 12-06-17, 08:06 AM
  #3
Penis Healthy
iTrader: (5)
 
Fuhnortoner's Avatar
 
Join Date: Jul 2013
Location: █▬█ █▄█ █▬█ █▄██▬█ █▄█ █▬█ █▄█
Posts: 1,721
Thanked 23 Times in 21 Posts
Just run it standalone. Use the GM harness and modify it.

Im just finishing up my swap. Heres what I used.

You can get 12v Switched from IGN1 on the ignition switch.










Last edited by Fuhnortoner; 12-06-17 at 08:16 AM.
Fuhnortoner is offline  
Reply With Quote
Old 12-06-17, 08:13 AM
  #4
Penis Healthy
iTrader: (5)
 
Fuhnortoner's Avatar
 
Join Date: Jul 2013
Location: █▬█ █▄█ █▬█ █▄██▬█ █▄█ █▬█ █▄█
Posts: 1,721
Thanked 23 Times in 21 Posts
This is where I plugged in my starter solenoid wire. Unplug the relay. Works good so far.


Fuhnortoner is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:40 PM.


All content Copyright © 2007 by Internet Brands, Inc. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: