Injectors fire on the ON position, help.. - RX7Club.com - Mazda RX7 Forum

Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Rtek Forum
Reload this Page >

Injectors fire on the ON position, help..

Rtek Forum Discuss the Rtek 2.0 and other Rtek ECU's

Injectors fire on the ON position, help..

Reply

 
 
 
Old 05-12-12, 04:56 PM
  #1  
Rotary Haven
5 Year Member
Thread Starter
iTrader: (8)
 
FCinWV's Avatar
 
Join Date: Jun 2010
Location: West Virginia
Posts: 541
Thanks: 0
Thanked 0 Times in 0 Posts
Injectors fire on the ON position, help..

I just installed an Rtek 1.8 on my S4 TII. When I turn the key on the injectors immediately start firing or "clicking". it idles fine.. a little high but I also removed the thermowax and haven't adjusted it yet. I took it down the road easily staying out of boost and when I creep up on 3k it hits the wall ( im guessing a grounding issue ). My main concern is the injectors instantly clicking when the key is on. Anyone have a clue whats going on or what I screwed up ? Any help would be greatly appreciated.
FCinWV is offline  
Reply With Quote
Old 05-12-12, 05:28 PM
  #2  
Rotary Haven
5 Year Member
Thread Starter
iTrader: (8)
 
FCinWV's Avatar
 
Join Date: Jun 2010
Location: West Virginia
Posts: 541
Thanks: 0
Thanked 0 Times in 0 Posts
delete thread please... had a bad case of head in ***.
FCinWV is offline  
Reply With Quote
Old 05-14-12, 08:38 AM
  #3  
Eats, Sleeps, Dreams Rotary
10 Year Member
iTrader: (52)
 
XLR8's Avatar
 
Join Date: Oct 2001
Location: NJ
Posts: 3,901
Thanks: 0
Thanked 0 Times in 0 Posts
It happens.....
XLR8 is offline  
Reply With Quote
Old 05-15-12, 06:43 PM
  #4  
Warheads on foreheads!
10 Year Member
iTrader: (8)
 
MIDNFauciUSN's Avatar
 
Join Date: Mar 2003
Location: Salinas, CA
Posts: 1,691
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by FCinWV View Post
delete thread please... had a bad case of head in ***.
was it the duty solenoid that was making the clicking noise?
MIDNFauciUSN is offline  
Reply With Quote
Old 05-16-12, 11:19 AM
  #5  
Rotary Haven
5 Year Member
Thread Starter
iTrader: (8)
 
FCinWV's Avatar
 
Join Date: Jun 2010
Location: West Virginia
Posts: 541
Thanks: 0
Thanked 0 Times in 0 Posts
sure was and the other 4 beside it. toom out the rtek reinstalled ina new ecu. and i guess i fried it. i check for codes and it shoes nothings wrong. but when i crank it over it will fire up to about 400 rpms then die. if i give it gas it runs but pulses really bad and has literly no response and dies. and yes the tps is adjusted. so i bouyht a 2.1 its on the way
FCinWV is offline  
Reply With Quote
Old 05-16-12, 04:51 PM
  #6  
Warheads on foreheads!
10 Year Member
iTrader: (8)
 
MIDNFauciUSN's Avatar
 
Join Date: Mar 2003
Location: Salinas, CA
Posts: 1,691
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by FCinWV View Post
sure was and the other 4 beside it. toom out the rtek reinstalled ina new ecu. and i guess i fried it. i check for codes and it shoes nothings wrong. but when i crank it over it will fire up to about 400 rpms then die. if i give it gas it runs but pulses really bad and has literly no response and dies. and yes the tps is adjusted. so i bouyht a 2.1 its on the way
That's kinda funny. I actually started a thread about the exact same thing. That's how I knew

My ecu is fine though. Or it seems fine, I don't really know if that solenoid is supposed to do that still or what?
MIDNFauciUSN is offline  
Reply With Quote
Old 05-17-12, 02:47 PM
  #7  
Rotary Haven
5 Year Member
Thread Starter
iTrader: (8)
 
FCinWV's Avatar
 
Join Date: Jun 2010
Location: West Virginia
Posts: 541
Thanks: 0
Thanked 0 Times in 0 Posts
i unplugged all mine and had no change in how it ran.. my friend ditched them all and taped back the connectors and it never affected him..hes been running thatcs setup for quite a long time and its fast hell
FCinWV is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bryancmatthews
Power FC Forum
14
10-05-15 09:49 PM
ZacMan
Build Threads
4
09-19-15 10:20 PM
bryancmatthews
Power FC Forum
0
09-05-15 04:57 PM


Thread Tools
Search this Thread
Quick Reply: Injectors fire on the ON position, help..


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: