Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Rtek Forum
Reload this Page >

I need help. S5 T2 1.8 chip 850/850 injectors and leaning under 2psi boost

Rtek Forum Discuss the Rtek 2.0 and other Rtek ECU's

I need help. S5 T2 1.8 chip 850/850 injectors and leaning under 2psi boost

Old 03-07-14, 12:30 AM
  #1  
so you got pistons oh wow
5 Year Member
Thread Starter
iTrader: (1)
 
polito Racing's Avatar
 
Join Date: Nov 2007
Location: Killeen, Texas
Posts: 901
Likes: 0
Received 0 Likes on 0 Posts
I need help. S5 T2 1.8 chip 850/850 injectors and leaning under 2psi boost

Okay here is my situation. I have a rtek 1.8 chip and I am using 850cc injectors for both primary and secondary. I am also controlling the injectors with SFAC2. The problems that I am facing are:

When I switch the key to the on position all my relays and injectors go crazy inside my engine bay to the point where fuel leaks into the ground. Once I crank the vehicle and it will stop doing it.

The second problem that I'm having is that I am completely leaning once I build any kind of boost. To me it feels like the secondary injectors are not staging. The vehicle will drive fine as long as I maintain the throttle below 50%. Once I go past that point my afr's will go all the way up to 19 and 20 instantly. So far I have checked grounds and wiring and have ensured that everything is properly connected. Tps is calibrated I'm not leaking fuel anywhere. No vaccum leaks. I'm getting frustrated as I can't seem to find the issue.

Here is a list of all my mods:
S5 TII block port matched to accept rew intake manifolds and lightly street ported. All REW internals and housings. using S4 front cover and CAS

REW intake manifolds, throttle body and TPS

Walbro 400lph in tank pump and 850/850 injectors with -6 braided lines from the tank to the rails. -6 fuel rails and a aeromotive a1000 fpr.

Front mount intercooler and 2 3/4 piping. Greddy compression tube.

Hybrid T70 turbo with s5 hot side and 2.75 down pipe. Stock S5 turbo manifold and wastegate

Electric fans and taurus 130 amp alternator.

RTEK 1.8 chip with omp delete feature and SAFCII.

LC-1 wide band and gauge. Connected just for monitoring. (Not connected to ecu)

I know for a fact that I can't be maxing out my injectors as this amount of fuel should support nearly 400hp which I'm sure I'm not making without being able to boost!! Don't know what else to check. Please help!!!

Last edited by polito Racing; 03-07-14 at 12:35 AM. Reason: Misspell
polito Racing is offline  
Old 03-07-14, 12:46 AM
  #2  
so you got pistons oh wow
5 Year Member
Thread Starter
iTrader: (1)
 
polito Racing's Avatar
 
Join Date: Nov 2007
Location: Killeen, Texas
Posts: 901
Likes: 0
Received 0 Likes on 0 Posts
This is what my engine bay looks like.
Attached Thumbnails I need help. S5 T2 1.8 chip 850/850 injectors and leaning under 2psi boost-image.jpg  
polito Racing is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Queppa
New Member RX-7 Technical
8
09-02-18 09:53 AM
trickster
2nd Generation Specific (1986-1992)
20
03-29-18 02:05 PM
Jeff20B
1st Generation Specific (1979-1985)
4
06-26-16 10:21 AM
eddierotary
2nd Generation Specific (1986-1992)
4
08-16-15 04:12 PM


Thread Tools
Search this Thread
Quick Reply: I need help. S5 T2 1.8 chip 850/850 injectors and leaning under 2psi boost


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: