New Member RX-7 Technical Post your first technical questions here, in an easy flame free environment, before jumping into the main technical sections.

installed weber no spark

Old 04-11-10, 02:32 AM
  #1  
Can Post Only in New Member Section
Thread Starter
 
Join Date: Apr 2010
Location: melbourne australia
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Unhappy installed weber no spark

hi everyone i need help. ihave a 82 rx7 s2 and i installed a weber carb to stock 12a, i just unplugged all the electrical leads to nikki carb removed nikki and put on webber carb engine will not fire ihave spark and power to dizzy but no spark to plugs can anyone help plse

thks ron
ronrx7s2 is offline  
Old 04-11-10, 12:00 PM
  #2  
1200 gone......but......
5 Year Member
iTrader: (24)
 
RXnos1200's Avatar
 
Join Date: Oct 2006
Location: so cal
Posts: 902
Likes: 0
Received 0 Likes on 0 Posts
you posted "ihave spark and power to dizzy but no spark to plugs "

where do you have spark at?

cap and rotor on right?

igniters working?

12v's to the coils when ignition on?
RXnos1200 is offline  
Old 04-13-10, 03:09 AM
  #3  
Can Post Only in New Member Section
Thread Starter
 
Join Date: Apr 2010
Location: melbourne australia
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
yes thats right i have power to and from coils to dizzy i have power to igniters but have no spark from dizzy to plugs. Iam checking igniters but cant understand why they should not be working as car was running fine until niki carb disconnnected. and if they have faulted what caused this. im at a lost because everyone i spoken to and posted threads have said that all of theirs just fired up and ran with out problems

thks ron
ronrx7s2 is offline  
Old 04-13-10, 07:51 AM
  #4  
1200 gone......but......
5 Year Member
iTrader: (24)
 
RXnos1200's Avatar
 
Join Date: Oct 2006
Location: so cal
Posts: 902
Likes: 0
Received 0 Likes on 0 Posts
Changing the carb should have nothing to do with your ignition system......that I know of...

just have to check out your ignition system.

gap in distributor for pickups, cap and rotor, wires, igniters, plugs......check volts to the coils when cranking over the engine.......
RXnos1200 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trickster
2nd Generation Specific (1986-1992)
20
03-29-18 02:05 PM
FC_DREAMS
General Rotary Tech Support
7
08-30-15 09:12 PM
gabescanlon
Interior / Exterior / Audio
1
08-11-15 05:59 PM


Thread Tools
Search this Thread
Quick Reply: installed weber no spark


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: