Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Microtech
Reload this Page >

Microtech Is there something wrong with my microtech?

Microtech Area is for discussing Microtech systems

Microtech Is there something wrong with my microtech?

Old 09-05-03, 11:08 AM
  #1  
Full Member
5 Year Member
Thread Starter
 
Join Date: Mar 2003
Location: Singapore
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
Is there something wrong with my microtech?

Hi Guys,

My FC is acting rather strange lately, the car stalls whenever I move off from standstill. And furthermore, when I am stuck in a traffic Jam with the aircon on, the car will suddenly die off from idle. My mechanic claims that it is due to the faulty microtech MT-8 that I am using, the car gives me a feeling that it is running lean. But we have already adjusted it to very rich. Pls help. Any microtech Gurus?

Thanks & Best Regards,
Francis
seven is offline  
Old 09-05-03, 12:23 PM
  #2  
Round&Round not Up&Down
10 Year Member
 
jimmyv13's Avatar
 
Join Date: Aug 2001
Location: West Bloomfield, MI
Posts: 2,805
Likes: 0
Received 0 Likes on 0 Posts
Are you making adjustments according to a WB reading or are you just guessing? You MUST know what is going on internally with the engine before you start messing with the maps.
jimmyv13 is offline  
Old 09-05-03, 07:30 PM
  #3  
Full Member
5 Year Member
Thread Starter
 
Join Date: Mar 2003
Location: Singapore
Posts: 83
Likes: 0
Received 0 Likes on 0 Posts
Hi Jimmvv13,

I was facing the same problems in my previous engine running with 3mm seals, but can you believe it. One of the seal's corner got chipped off. And now with another recond engine, I'm still facing the same problems like stalling and such, in fact it has gotten worst. Pls advise?

Best Regards,
Francis
seven is offline  
Old 09-05-03, 07:55 PM
  #4  
Despise Enmity
10 Year Member
 
Josepi's Avatar
 
Join Date: May 2001
Location: Richmond, VA
Posts: 2,420
Likes: 0
Received 0 Likes on 0 Posts
What's the logs look like:

Voltage at idle
Vacuum at idle
RPM at idle

?

Josepi is offline  
Old 09-10-03, 10:44 AM
  #5  
Rotary Freak
5 Year Member
 
SaabGuy's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA
Posts: 1,514
Likes: 0
Received 0 Likes on 0 Posts
Try increasing fuel from idle to 2000 rpms in the 30-15 inches of vac range.

My car does the same things if these settings are too low.

oh dont play with these too much since you dont have a wide band.
SaabGuy is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dona1326cosprings7
1st Generation Specific (1979-1985)
4
10-29-15 06:47 AM
pfsantos
2nd Generation Specific (1986-1992)
1
09-30-15 01:29 PM


Thread Tools
Search this Thread
Quick Reply: Microtech Is there something wrong with my microtech?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: