Microtech Area is for discussing Microtech systems

MS for injectors not working correctly

Old 07-15-15, 03:17 PM
  #1  
Senior Member
Thread Starter
iTrader: (3)
 
janousekmike's Avatar
 
Join Date: Apr 2010
Location: Duluth
Posts: 274
Likes: 0
Received 0 Likes on 0 Posts
MS for injectors not working correctly

When checking through all sensors are connect and no errors, everything is good. Car is a Rotary turbo drag racing only. For fuel I'm running 4x brand new 2250cc inj. Mechanical pump "no electric", I did wire the fuel pump rely to a led light, and it shows the light turn on as a pump would, and shuts off normal when ecu starts afterm a few seconds. Then when cranking light is always on. I noticed the injector ms stay at 9.33 during crank. Figured I would ask first as this is a new drag setup and first time running mechanical pump. Any experience with this before? Is it normal to read ms on LT10s with car off?

Also abnormal ms reading for my injectors. When I start the car, and it is just pouring fuel down, and fouling out spark plugs. I have my Idle and 1000-2000RPM screens set down to 1.5-1.8ms for the injectors but my readings for the injectors with the car running at idle show 3.5ms way to rich for the car to run correctly. I have went through all screens that would add fuel such as Air, Water, all of my AUX inputs and 0.00 out all additional fuel. Still no change. Is there something I'm missing when running high impedance injectors 8.Ohm and no electronic fuel pump. This is a drag car setup so I will not need driviblity corrections, I just want to be able to input my map screens the correct ms for injectors, and control the fuel correctly. Any direction would be much appreciated.

Thank you,
Mike
janousekmike is offline  
Old 07-19-15, 10:30 AM
  #2  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
Check your %Stage. The primary injector time is multiplied by 1.that number to get the primary pulse width until the secondaries begin to fire, then primary pulse is reduced.
Aaron Cake is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trickster
2nd Generation Specific (1986-1992)
20
03-29-18 02:05 PM
jza80
Suspension/Wheels/Tires/Brakes
2
08-12-15 11:10 PM


Thread Tools
Search this Thread
Quick Reply: MS for injectors not working correctly


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: