Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Microtech
Reload this Page >

microtech lt8 on 87 tii is out of whack from previous owner

Microtech Area is for discussing Microtech systems

microtech lt8 on 87 tii is out of whack from previous owner

Old 05-10-15, 04:54 PM
  #1  
snap crackle brap
5 Year Member
Thread Starter
 
blackrotary23's Avatar
 
Join Date: Dec 2007
Location: indianapolis, indiana
Posts: 536
Likes: 0
Received 0 Likes on 0 Posts
microtech lt8 on 87 tii is out of whack from previous owner

Hello all. I've posted a couple posts about my microtech, but didn't really get anywhere. Really need some help guys. Not looking for someone to solve my problems, but maybe able to help with get me the right plug in values on my screens.

I've got an lt8. T78 turbocharger, hks wastegate, fmic, 2 1/2" intercooler piping, 3" exhaust, 720cc primaries, 1680cc secondaries, Aem wideband,aeromotive fpr at 40psi, walbro255 fp, toggled dual fans, optima red top battery, 99 Taurus alternator at 130amp, rx7.com underdrive pulley with timing marks at -20/-10/0/+10.I think that sums up most of the important specs.

I got the microtech from a friend who ran e85 and the map was all jumbled.
I've tried plugging in different maps from other members posts, but it still is having problems.

I need someone to help me plug the right numbers in ALL 32 screens as I can only find certain maps that only have values for certain screens. I need a map for ALL screens 1-34 to make sure my numbers are correct.

Also, should I use stock timing or 0? Please and thank you to whomever can get me through this mess so I can take it to a tuner.

Last edited by blackrotary23; 05-10-15 at 04:56 PM.
blackrotary23 is offline  
Old 05-10-15, 05:18 PM
  #2  
Rotary Enthusiast
iTrader: (1)
 
Join Date: Dec 2004
Location: california
Posts: 764
Received 1 Like on 1 Post
You should really look at the microtech manual. It tells you exactly what each function does, and gives an example of situations.

OR from what you are asking, pay a tuner to "plug in the right numbers in ALL 32 screens"
silentblu is offline  
Old 05-10-15, 05:55 PM
  #3  
snap crackle brap
5 Year Member
Thread Starter
 
blackrotary23's Avatar
 
Join Date: Dec 2007
Location: indianapolis, indiana
Posts: 536
Likes: 0
Received 0 Likes on 0 Posts
The point is to get my car running decent at idle so I know there isn't another problem. But thanks for positive vibe.
blackrotary23 is offline  
Old 05-16-15, 09:32 AM
  #4  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
Unfortunately, no one can simply give you some numbers to plug in which will make the car run correctly, in ALL 32 screens.

But for sure, we can give advice if you explain what the car is doing wrong. And the manual does actually contain descriptions of the settings, with for the most part those descriptions being helpful. If there's one that you need clarification on, then post it up.

As for timing, setting at 0 degrees is the easiest. Lock timing on the Microtech at 0, then adjust CAS until pulley mark lines up to pointer. Then unlock timing and verify that the pointer is now at about the timing the Microtech is commanding.
Aaron Cake is offline  
Old 05-19-15, 06:27 PM
  #5  
snap crackle brap
5 Year Member
Thread Starter
 
blackrotary23's Avatar
 
Join Date: Dec 2007
Location: indianapolis, indiana
Posts: 536
Likes: 0
Received 0 Likes on 0 Posts
Thanks for the reply. A friend who is familiar came over Sunday and gave me a hands on rundown of the system. Got a good street tune on her now running 13 lbs of boost on 93 octane. Timing set at 0tdc, 550/720 injectors, 40lbs fuel pressure, running a t70 turbo. Pulls great. Now I can understand the microtech a lot easier due to my friend.
blackrotary23 is offline  
Old 05-24-15, 10:11 AM
  #6  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
Glad to hear it. Always nice to have someone familiar with the system to show you the ropes.

I actually installed my first Microtech in Indianapolis. At the side of the track.
Aaron Cake is offline  
Old 06-01-15, 09:47 AM
  #7  
Old Rotary Dude
iTrader: (33)
 
jtbshaw's Avatar
 
Join Date: Jun 2003
Location: Jemison, AL
Posts: 487
Likes: 0
Received 0 Likes on 0 Posts
Glad you have yours going. Mine is still running like poo. Been at a tuner for nearly 4 months and still has done nothing. I so would prefer to figure this thing out myself.

JTB
jtbshaw is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MazdaspeedR1
The Bad & Fugly Businesses
27
05-22-18 05:58 PM
troym55
3rd Generation Specific (1993-2002)
23
05-25-16 12:42 PM
ncds_fc
2nd Generation Specific (1986-1992)
17
09-10-15 03:52 AM


Thread Tools
Search this Thread
Quick Reply: microtech lt8 on 87 tii is out of whack from previous owner


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: